Jump to content
Not connected, Your IP: 34.200.252.156
Guest MuYiXiao

ANSWERED SSH "Socket bind failed on local address"

Recommended Posts

Guest MuYiXiao

Running Fedora 21, KDE

I'm in china

 

Trying to connect via SSH.  I tried all 4 port options listed.  Same error.

 

I know SSH works (I'm using it right now).   In the AirVPN client, I authorize, it gets to local forwarding, and then kills.  Is this a setting in the client or is something happening with Fedora that's blocking it?

 

I 2016.04.13 15:59:41 - AirVPN client version: 2.10.3 / x64, System: Linux, Name: Fedora release 21 (Twenty One)Kernel \r on an \m (\l) / x64
. 2016.04.13 15:59:41 - Reading options from /home/blaze/.airvpn/AirVPN.xml
. 2016.04.13 15:59:41 - Data Path: /home/blaze/.airvpn
. 2016.04.13 15:59:41 - App Path: /usr/lib64/AirVPN
. 2016.04.13 15:59:41 - Executable Path: /usr/lib64/AirVPN/AirVPN.exe
. 2016.04.13 15:59:41 - Command line arguments (1): path="/home/blaze/.airvpn"
. 2016.04.13 15:59:41 - Updating systems & servers data ...
. 2016.04.13 15:59:41 - Operating System: Unix 4.1.13.100 - Linux localhost.localdomain 4.1.13-100.fc21.x86_64 #1 SMP Tue Nov 10 13:13:20 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux
I 2016.04.13 15:59:41 - OpenVPN Driver - Found, /dev/net/tun
I 2016.04.13 15:59:41 - OpenVPN - Version: OpenVPN 2.3.8 (/usr/sbin/openvpn)
I 2016.04.13 15:59:41 - SSH - Version: OpenSSH_6.6.1p1, OpenSSL 1.0.1k-fips 8 Jan 2015 (/usr/bin/ssh)
I 2016.04.13 15:59:41 - SSL - Version: stunnel 5.06 (/usr/lib64/AirVPN/stunnel)
! 2016.04.13 15:59:41 - Ready
. 2016.04.13 15:59:55 - Systems & servers data update completed
I 2016.04.13 15:59:55 - Session starting.
I 2016.04.13 15:59:59 - Checking authorization ...
! 2016.04.13 16:00:00 - Connecting to Cynosura (Canada, Vancouver)
. 2016.04.13 16:00:00 - SSH > OpenSSH_6.6.1, OpenSSL 1.0.1k-fips 8 Jan 2015
. 2016.04.13 16:00:00 - SSH > debug1: Reading configuration data /etc/ssh/ssh_config
. 2016.04.13 16:00:00 - SSH > debug1: /etc/ssh/ssh_config line 56: Applying options for *
. 2016.04.13 16:00:00 - SSH > debug1: Connecting to 71.19.252.23 [71.19.252.23] port 53.
. 2016.04.13 16:00:00 - SSH > debug1: Connection established.
. 2016.04.13 16:00:00 - SSH > debug1: permanently_set_uid: 0/0
. 2016.04.13 16:00:00 - SSH > debug1: identity file /home/blaze/.airvpn/189e8ed5e7f10a9ac107404f1e5579080d0bbc5c0c91387a7f624295a65dfb4f.tmp.key type -1
. 2016.04.13 16:00:00 - SSH > debug1: identity file /home/blaze/.airvpn/189e8ed5e7f10a9ac107404f1e5579080d0bbc5c0c91387a7f624295a65dfb4f.tmp.key-cert type -1
. 2016.04.13 16:00:00 - SSH > debug1: Enabling compatibility mode for protocol 2.0
. 2016.04.13 16:00:00 - SSH > debug1: Local version string SSH-2.0-OpenSSH_6.6.1
. 2016.04.13 16:00:02 - SSH > debug1: Remote protocol version 2.0, remote software version OpenSSH_6.7p1 Debian-5+deb8u1
. 2016.04.13 16:00:02 - SSH > debug1: match: OpenSSH_6.7p1 Debian-5+deb8u1 pat OpenSSH* compat 0x04000000
. 2016.04.13 16:00:02 - SSH > debug1: SSH2_MSG_KEXINIT sent
. 2016.04.13 16:00:02 - SSH > debug1: SSH2_MSG_KEXINIT received
. 2016.04.13 16:00:02 - SSH > debug1: kex: server->client aes128-ctr hmac-sha1-etm@openssh.com none
. 2016.04.13 16:00:02 - SSH > debug1: kex: client->server aes128-ctr hmac-sha1-etm@openssh.com none
. 2016.04.13 16:00:02 - SSH > debug1: kex: curve25519-sha256@libssh.org need=20 dh_need=20
. 2016.04.13 16:00:02 - SSH > debug1: sending SSH2_MSG_KEX_ECDH_INIT
. 2016.04.13 16:00:02 - SSH > debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
. 2016.04.13 16:00:02 - SSH > debug1: Server host key: ECDSA be:eb:33:ee:f6:ee:81:82:bb:46:76:ce:34:af:4b:20
. 2016.04.13 16:00:02 - SSH > debug1: checking without port identifier
. 2016.04.13 16:00:02 - SSH > Warning: Permanently added '[71.19.252.23]:53' (ECDSA) to the list of known hosts.
. 2016.04.13 16:00:02 - SSH > debug1: ssh_ecdsa_verify: signature correct
. 2016.04.13 16:00:02 - SSH > debug1: SSH2_MSG_NEWKEYS sent
. 2016.04.13 16:00:02 - SSH > debug1: expecting SSH2_MSG_NEWKEYS
. 2016.04.13 16:00:02 - SSH > debug1: SSH2_MSG_NEWKEYS received
. 2016.04.13 16:00:02 - SSH > debug1: Roaming not allowed by server
. 2016.04.13 16:00:02 - SSH > debug1: SSH2_MSG_SERVICE_REQUEST sent
. 2016.04.13 16:00:03 - SSH > debug1: SSH2_MSG_SERVICE_ACCEPT received
. 2016.04.13 16:00:03 - SSH > debug1: Authentications that can continue: publickey,password
. 2016.04.13 16:00:03 - SSH > debug1: Next authentication method: publickey
. 2016.04.13 16:00:03 - SSH > debug1: Trying private key: /home/blaze/.airvpn/189e8ed5e7f10a9ac107404f1e5579080d0bbc5c0c91387a7f624295a65dfb4f.tmp.key
. 2016.04.13 16:00:03 - SSH > debug1: key_parse_private2: missing begin marker
. 2016.04.13 16:00:03 - SSH > debug1: read PEM private key done: type RSA
. 2016.04.13 16:00:03 - SSH > debug1: Authentication succeeded (publickey).
. 2016.04.13 16:00:03 - SSH > Authenticated to 71.19.252.23 ([71.19.252.23]:53).
. 2016.04.13 16:00:03 - SSH > debug1: Local connections to LOCALHOST:25316 forwarded to remote address 127.0.0.1:2018
. 2016.04.13 16:00:03 - SSH > debug1: Local forwarding listening on ::1 port 25316.
. 2016.04.13 16:00:03 - SSH > debug1: channel 0: new [port listener]
. 2016.04.13 16:00:03 - SSH > debug1: Local forwarding listening on 127.0.0.1 port 25316.
. 2016.04.13 16:00:03 - SSH > debug1: channel 1: new [port listener]
. 2016.04.13 16:00:03 - SSH > debug1: Requesting no-more-sessions@openssh.com
. 2016.04.13 16:00:03 - SSH > debug1: Entering interactive session.
. 2016.04.13 16:00:03 - OpenVPN > OpenVPN 2.3.8 x86_64-redhat-linux-gnu [sSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [iPv6] built on Aug  4 2015
. 2016.04.13 16:00:03 - OpenVPN > library versions: OpenSSL 1.0.1k-fips 8 Jan 2015, LZO 2.08
. 2016.04.13 16:00:03 - Auto retry with another port.
. 2016.04.13 16:00:03 - OpenVPN > MANAGEMENT: Socket bind failed on local address [AF_INET]7.0.0.1:3203: Cannot assign requested address
. 2016.04.13 16:00:03 - OpenVPN > Exiting due to fatal error
! 2016.04.13 16:00:04 - Disconnecting
. 2016.04.13 16:00:04 - Connection terminated.
I 2016.04.13 16:00:07 - Checking authorization ...
! 2016.04.13 16:00:08 - Connecting to Cynosura (Canada, Vancouver)
. 2016.04.13 16:00:08 - SSH > OpenSSH_6.6.1, OpenSSL 1.0.1k-fips 8 Jan 2015
. 2016.04.13 16:00:08 - SSH > debug1: Reading configuration data /etc/ssh/ssh_config
. 2016.04.13 16:00:08 - SSH > debug1: /etc/ssh/ssh_config line 56: Applying options for *
. 2016.04.13 16:00:08 - SSH > debug1: Connecting to 71.19.252.23 [71.19.252.23] port 53.
. 2016.04.13 16:00:08 - SSH > debug1: Connection established.
. 2016.04.13 16:00:08 - SSH > debug1: permanently_set_uid: 0/0
. 2016.04.13 16:00:08 - SSH > debug1: identity file /home/blaze/.airvpn/a4efbef29b08d78051b928fdfcca999aa03a9d699b425841ab069cdce4a06957.tmp.key type -1
. 2016.04.13 16:00:08 - SSH > debug1: identity file /home/blaze/.airvpn/a4efbef29b08d78051b928fdfcca999aa03a9d699b425841ab069cdce4a06957.tmp.key-cert type -1
. 2016.04.13 16:00:08 - SSH > debug1: Enabling compatibility mode for protocol 2.0
. 2016.04.13 16:00:08 - SSH > debug1: Local version string SSH-2.0-OpenSSH_6.6.1
. 2016.04.13 16:00:08 - SSH > debug1: Remote protocol version 2.0, remote software version OpenSSH_6.7p1 Debian-5+deb8u1
. 2016.04.13 16:00:08 - SSH > debug1: match: OpenSSH_6.7p1 Debian-5+deb8u1 pat OpenSSH* compat 0x04000000
. 2016.04.13 16:00:08 - SSH > debug1: SSH2_MSG_KEXINIT sent
. 2016.04.13 16:00:08 - SSH > debug1: SSH2_MSG_KEXINIT received
. 2016.04.13 16:00:08 - SSH > debug1: kex: server->client aes128-ctr hmac-sha1-etm@openssh.com none
. 2016.04.13 16:00:08 - SSH > debug1: kex: client->server aes128-ctr hmac-sha1-etm@openssh.com none
. 2016.04.13 16:00:08 - SSH > debug1: kex: curve25519-sha256@libssh.org need=20 dh_need=20
. 2016.04.13 16:00:08 - SSH > debug1: sending SSH2_MSG_KEX_ECDH_INIT
. 2016.04.13 16:00:08 - SSH > debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
. 2016.04.13 16:00:09 - SSH > debug1: Server host key: ECDSA be:eb:33:ee:f6:ee:81:82:bb:46:76:ce:34:af:4b:20
. 2016.04.13 16:00:09 - SSH > debug1: checking without port identifier
. 2016.04.13 16:00:09 - SSH > Warning: Permanently added '[71.19.252.23]:53' (ECDSA) to the list of known hosts.
. 2016.04.13 16:00:09 - SSH > debug1: ssh_ecdsa_verify: signature correct
. 2016.04.13 16:00:09 - SSH > debug1: SSH2_MSG_NEWKEYS sent
. 2016.04.13 16:00:09 - SSH > debug1: expecting SSH2_MSG_NEWKEYS
. 2016.04.13 16:00:09 - SSH > debug1: SSH2_MSG_NEWKEYS received
. 2016.04.13 16:00:09 - SSH > debug1: Roaming not allowed by server
. 2016.04.13 16:00:09 - SSH > debug1: SSH2_MSG_SERVICE_REQUEST sent
. 2016.04.13 16:00:09 - SSH > debug1: SSH2_MSG_SERVICE_ACCEPT received
. 2016.04.13 16:00:09 - SSH > debug1: Authentications that can continue: publickey,password
. 2016.04.13 16:00:09 - SSH > debug1: Next authentication method: publickey
. 2016.04.13 16:00:09 - SSH > debug1: Trying private key: /home/blaze/.airvpn/a4efbef29b08d78051b928fdfcca999aa03a9d699b425841ab069cdce4a06957.tmp.key
. 2016.04.13 16:00:09 - SSH > debug1: key_parse_private2: missing begin marker
. 2016.04.13 16:00:09 - SSH > debug1: read PEM private key done: type RSA
. 2016.04.13 16:00:10 - SSH > debug1: Authentication succeeded (publickey).
. 2016.04.13 16:00:10 - SSH > Authenticated to 71.19.252.23 ([71.19.252.23]:53).
. 2016.04.13 16:00:10 - SSH > debug1: Local connections to LOCALHOST:38586 forwarded to remote address 127.0.0.1:2018
. 2016.04.13 16:00:10 - SSH > debug1: Local forwarding listening on ::1 port 38586.
. 2016.04.13 16:00:10 - SSH > debug1: channel 0: new [port listener]
. 2016.04.13 16:00:10 - SSH > debug1: Local forwarding listening on 127.0.0.1 port 38586.
. 2016.04.13 16:00:10 - SSH > debug1: channel 1: new [port listener]
. 2016.04.13 16:00:10 - SSH > debug1: Requesting no-more-sessions@openssh.com
. 2016.04.13 16:00:10 - SSH > debug1: Entering interactive session.
. 2016.04.13 16:00:10 - OpenVPN > OpenVPN 2.3.8 x86_64-redhat-linux-gnu [sSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [iPv6] built on Aug  4 2015
. 2016.04.13 16:00:10 - OpenVPN > library versions: OpenSSL 1.0.1k-fips 8 Jan 2015, LZO 2.08
. 2016.04.13 16:00:10 - Auto retry with another port.
. 2016.04.13 16:00:10 - OpenVPN > MANAGEMENT: Socket bind failed on local address [AF_INET]7.0.0.1:3204: Cannot assign requested address
. 2016.04.13 16:00:10 - OpenVPN > Exiting due to fatal error
! 2016.04.13 16:00:10 - Disconnecting
. 2016.04.13 16:00:10 - Connection terminated.
I 2016.04.13 16:00:13 - Checking authorization ...
I 2016.04.13 16:00:14 - Cancel requested.
! 2016.04.13 16:00:14 - Session terminated.
 

Share this post


Link to post
. 2016.04.13 16:00:03 - OpenVPN > MANAGEMENT: Socket bind failed on local address [AF_INET]7.0.0.1:3203: Cannot assign requested address

That's the error. It must be 127.0.0.1. How does that happen?


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
Guest MuYiXiao

 

. 2016.04.13 16:00:03 - OpenVPN > MANAGEMENT: Socket bind failed on local address [AF_INET]7.0.0.1:3203: Cannot assign requested address

That's the error. It must be 127.0.0.1. How does that happen?

 

Okay.... that makes sense.     Any idea if this is a client issue or a Linux issue?

Share this post


Link to post

Neither of them.

Check your /etc/hosts for the proper IP address of "localhost", it should be 127.0.0.1.

 

Unless you have a line containing

127.0.0.1	localhost

in your /etc/hosts, on any *nix OS, things will behave abnormally.


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post
Guest MuYiXiao

Neither of them.

Check your /etc/hosts for the proper IP address of "localhost", it should be 127.0.0.1.

 

Unless you have a line containing

127.0.0.1	localhost

in your /etc/hosts, on any *nix OS, things will behave abnormally.

 

Bingo!   I have to muck about with my hosts file all the time, and I apparently deleted the first two digits of "home".  I completely missed that.  OOPS!

 

Thank you.  It's so nice when the answer is simple and easy to fix

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...