Jump to content
Not connected, Your IP:
Sign in to follow this  

Local IPs not accessible

Recommended Posts

Goal: get https://github.com/jishi/node-sonos-http-api to find my local Sonos devices


Mac: running AirVPN, Local IP:

Sonos: IP:


When AirVPN is not connected, and I run the node server from the URL above, the server quickly finds the Sonos speaker and connects.  However, once I connect to AirVPN, the server endlessly loops with:


scanning for players in ip
scanning for players in ip <-- AirVPN IP


If I go to AirVPN --> Preferences --> Routes --> "Not specified routes go: Outside the VPN tunnel," it works.  However, I know that effectively stops the benefit of AirVPN.  So, if I set AirVPN --> Preferences --> Routes --> Not specified routes go: Inside the VPN tunnel, and set an IP Range of, it does NOT work and endlessly loops scanning.


Am I understanding the routes table correctly?  I'm so not privy of CIDR formats, but I think I understand that means -, correct?

Share this post

Link to post

Do you have the "allow local/lan" setting checked under Preferences --> Advanced --> Network Lock ? I'm on a Mac too and I do sometimes have problems with finding machines on my network while network lock is active. I can work around this by using IP addresses instead of hostnames mostly though.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

  • Create New...