Jump to content
Not connected, Your IP: 3.231.166.56

Recommended Posts

Hi guys,

 

I'm experiencing drop outs when using P2P. To clarify, the VPN is NOT disconnecting, instead P2P will drop speeds to 0.0Kb/s, then startup and work fine for about a minute at full speed then the drop will happen again, then repeat.

 

Any ideas on how to keep the connection steady?

 

Cheers,

 

DC.

 

 

 

Mac OS X 10.10.3

Viscosity 1.5.6

 

Edit: Added logs.

 

May 16 21:23:46: Viscosity Mac 1.5.6 (1285)
May 16 21:23:46: Viscosity OpenVPN Engine Started
May 16 21:23:46: Running on Mac OS X 10.10.3
May 16 21:23:46: ---------
May 16 21:23:46: Checking reachability status of connection...
May 16 21:23:47: Connection is reachable. Starting connection attempt.
May 16 21:23:47: OpenVPN 2.3.6 x86_64-apple-darwin [sSL (OpenSSL)] [LZO] [PKCS11] [MH] [iPv6] built on Apr  5 2015
May 16 21:23:47: library versions: OpenSSL 1.0.2a 19 Mar 2015, LZO 2.09
May 16 21:23:48: Control Channel Authentication: using '/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/connection.dZxq5U/ta.key' as a OpenVPN static key file
May 16 21:23:48: UDPv4 link local: [undef]
May 16 21:23:48: UDPv4 link remote: [AF_INET]62.102.***.***:443
May 16 21:23:52: [server] Peer Connection Initiated with [AF_INET]62.102.***.***:443
May 16 21:23:54: TUN/TAP device /dev/tun0 opened
May 16 21:23:54: do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
May 16 21:23:54: /sbin/ifconfig tun0 delete
May 16 21:23:54: NOTE: Tried to delete pre-existing tun/tap instance -- No Problem if failure
May 16 21:23:54: /sbin/ifconfig tun0 10.4.0.221 10.4.0.221 netmask 255.255.0.0 mtu 1500 up
May 16 21:23:54: Initialization Sequence Completed

 

Removed some IP's from logs just in case using ***

Share this post


Link to post

I'm also interested because this happens to me with every VPN service using OpenVPN UDP. It recovers after a few seconds but log doesn't show any interruption

Share this post


Link to post

Try port forwarding its a must with p2p performance, also switch to qbittorent program (green tick should pop up at bottom of program to show ports forwarded successfully) that program is much faster and better then utorrent and others I found. You should also try to make your bb connection more stable, stronger sometimes you need better micro filters or higher quality cables or even to move your computer closer to the router and via a short network cable.

 

You may need to try different servers also try switching to netherlands, uk, germany and other servers in europe or closer to home, its trial and error.

I found the server closest to me to be sluggish in p2p but one in netherlands even faster.

 

I use to get this issue much in the old days, but doing the above greatly improved the performance of p2p, the issue if I recall is due to errors and latencies while under openvpn/vpns in general but I never found a set of tweeks or configs to 100% fix it, once I did the above few options and also moved my laptop closer to the router the quality of the internet line improved and helped greatly also.

 

These may not work but worth a shot !

Share this post


Link to post

I'm also interested because this happens to me with every VPN service using OpenVPN UDP. It recovers after a few seconds but log doesn't show any interruption

 

one VPN service I've used has some servers that drop out like this with UDP connections.  But others of their servers work just fine.  It happens to me just using downthemall! extension for firefox with several segments enabled.

 

really weird.  Other VPN providers (including Air) along very similar routing have no problems at all.

Share this post


Link to post

I think I might have fixed the problem!

 

I followed the advice from everyone here, I forwarded ports via AirVPN, added that port to Transmission and it still didnt work.

 

Then I turned off some settings, specifically "enable micro transport protocol" in Transmission and then all torrents downloaded perfectly with a nice even amount of bandwidth.

 

This is what my transmission looks like now, is it safe to continue using it as such?

Share this post


Link to post
Guest Chaf

You could:

 

Uncheck "Ignore Encrypted peers"

 

And moreover (as it doesn't appear in your screenshot)

 

Set a port in peer listening port after generating one from your "Client Area" on Airvpn website.

Share this post


Link to post

I think I might have fixed the problem!

 

I followed the advice from everyone here, I forwarded ports via AirVPN, added that port to Transmission and it still didnt work.

 

Then I turned off some settings, specifically "enable micro transport protocol" in Transmission and then all torrents downloaded perfectly with a nice even amount of bandwidth.

 

This is what my transmission looks like now, is it safe to continue using it as such?

attachicon.gifscreen1.png

attachicon.gifscreen2.png

 

 

As I was saying earlier I have the exact same issue but just lived with it for the past 2 years, but you maybe onto something with that utp option !

 

under bitorrent it says its under Speed section and it list: enable bandwith managment (utp) and also : apply rate limit to utp connections. I think ill uncheck them and give it a test....

 

Ill post back here later and let you know if it worked.

 

Did it work for you in the end ?

Share this post


Link to post

You could:

 

Uncheck "Ignore Encrypted peers"

 

And moreover (as it doesn't appear in your screenshot)

 

Set a port in peer listening port after generating one from your "Client Area" on Airvpn website.

 

I removed the port number, that's why you don't see it in the screenshot but there is actually a port there. It's a forwarded port using AirVPN via this website.

 

 

I think I might have fixed the problem!

 

I followed the advice from everyone here, I forwarded ports via AirVPN, added that port to Transmission and it still didnt work.

 

Then I turned off some settings, specifically "enable micro transport protocol" in Transmission and then all torrents downloaded perfectly with a nice even amount of bandwidth.

 

This is what my transmission looks like now, is it safe to continue using it as such?

attachicon.gifscreen1.png

attachicon.gifscreen2.png

 

 

As I was saying earlier I have the exact same issue but just lived with it for the past 2 years, but you maybe onto something with that utp option !

 

under bitorrent it says its under Speed section and it list: enable bandwith managment (utp) and also : apply rate limit to utp connections. I think ill uncheck them and give it a test....

 

Ill post back here later and let you know if it worked.

 

Did it work for you in the end ?

 

I did some reading on it also, it is basically controlling speeds and making sure other apps dont suffer when one takes all the traffic.

 

It has been working perfectly for me. The difference is night and day.

 

The only two real things I did was uncheck the enable micro transport protocol box in Transmission (you can do this with uTorrent also) and used port forwarding via the AirVPN website. I'm downloading at full speed now without any dips.

 

Let me know how you get on!

Share this post


Link to post

Yeah was reading about utp here:

 

http://www.guidingtech.com/4094/disable-utp-utorrent-bittorrent-bandwidth/

 

It does appear to help more with apps taking over all the bandwith/speed, so if you torrent is taking up all the performance your web browser will suffer. UTP switched on claims to manage that bandwith so your browser or any other app wont suffer I believe.

 

I am still a bit unclear if its actually done anything to my torrent performance or fixed the issue, in fact when I switch it off my port forwarding becomes blocked under qbittorent, leaving it on makes it unblocked but speed is still similar oddly!

 

That article does say it tends to only effect people with much slower bb connections mines relative fast perhaps that is why it has not worked. Only difference I noted was it improved my upload speed.

 

As I said earlier though its a weird issue sometimes I see it but past day no issues that is with utp switched on even.... I may try and switch it off when I see the issue.

 

On another note you have to restart your torrent app when ever changing utp settings for it to take effect.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...