Jump to content
Not connected, Your IP: 54.226.4.91
jimmythelaw

Trouble configuring Comodo Firewall to prevent leaks

Recommended Posts

Hello,

 

Prior to having trouble I was using an older version of Comodo Firewall that had a GUI similar to the one in this post: https://airvpn.org/topic/3405-windows-comodo-prevent-leaks/ (sorry I don't recall the exact version). The firewall was working fine and prevented any form of leaks when AirVPN was disconnected for whatever reason. Upon doing a clean install of Comodo Firewall two days ago and reconfiguring the global rules as described in the tutorial above traffic coming from my computer when the VPN connections is down is no longer blocked based on ipleak.net. Im assuming there is something that changed in the new version of Comodo Firewall because I followed the same procedure as I had in the past.

 

This blog post: https://www.bestvpn.com/blog/10218/build-your-own-vpn-kill-switch-in-windows-comodo/ also mentioned problems regarding their implementation of preventing leaks upon using the new version of Comodo Firewall, so I don't believe I am following the tutorial provided by AirVPN incorrectly. If anyone else could test AirVPNs initial tutorial with the newest version of Comodo Firewall it would be appreciated just so I know it's not me that is doing something wrong. If that is the case I can take screenshots of what I've done to try to fix my issue.

 

As of now I have been using the Network Lock feature in the GUI and it seems to be working fine which I will stick to if I can't get Comodo to work. Thanks.

Share this post


Link to post

Hello,

running Windows 7 Enterprise, 32 bit
running ComodoFirwall, Product Vers. 8.1.0.4426
setup of firewall as described in tutorial here:
https://airvpn.org/topic/3405-windows-comodo-prevent-leaks/

connection tested, if AirVPN Client is not running:

trying to connect with Firefox to web site:   www.usatoday.com
result: no connection

trying to update antivirus (FreeAntiVir)
result: no connection

trying to update SpybootSearchandDestroy
no connection

trying to connect to : https://airvpn.org/
result (as expected !!!!!):   connected!!!!!

trying to connect to: http://ipleak.net/
result: no connection

 

No problem on my side as it seems

Share this post


Link to post

Can you post screenshots of your global rules page as well as network zones page? I am using comodo 8 as well and it is working just fine.

Share this post


Link to post

I am using Comodo CIS security suite on my Win 7 64bit desktop PC. Prior to installing Comodo v8 I had a set of rules as described in the How To here for running AirVPN. While installing Comodo v8 I stupidly forgot to copy them to paper. After installing Comodo v8 I set it up as described in Chirons instructions at Gizmos site http://www.techsupportalert.com/content/how-install-comodo-firewall.htm On starting up my PC again I of course got a set of popups in relation to AirVPN. Realising then I had forgotten to copy the rules down I just "temporarily" set AirVPN as an allowed application. After getting back on line I came here and did an ip leak test from the link and found I had no leaks at all. I then checked the how to here on AirVPN and Comodo but it was as daunting as ever and remembering the time it took to get it right before I decided to leave it as it was for the time being and check the ip leak regularly. That was several weeks ago and since then I haven't had any leaks at all not even with the RPC? one mentioned lately. I use qBittorrent for downloads and also the 64bit Pale Moon browser with the Startpage Search Engine as my homepage. I do have a ruleset for qBittorrent which connects through the specific port designated via the port forwarding option here and it all works fine. Personally speaking, I would say that if like me you are not a PC tekkie type then as far as I can see setting AirVPN and Comodo up in the way that I have works very well with no leaks whatsoever.

Share this post


Link to post

I have entered everything as described in the comodo fw link above.

 

1. is there way in order NOT to have to enter EVERY airvpn entry ip in the [air vpn entry ips] network zone into comodo?

2. somehow eddie cannot connect via SSL protocol. if I configure to use "automatic" it works. otherwise not.

3. although I have defined the airvpn frontend servers as a network zone and created a rule for it - when the client is not running I cannot connect to the sites. but I should be able to, or not?

 

thx for the help.

 

my system:

win7 pro 64bit SP1, comodo internet security premium 8.2.0.4792

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...