Jump to content
Not connected, Your IP: 34.229.151.87
Sign in to follow this  
jservs7

Unable to connect via AirVPN UDP on mobile data

Recommended Posts

On my Android phone using Kitkat 4.4.4, I am unable to connect to any AirVPN server while on my mobile data using UDP.

 

TCP however connects fine on mobile data and UDP works perfect while I'm on a WiFi network. I have tried configs using ports 443, 80 and 2018 using the AirVPN config generator, but none work.

 

The only thing the log files continue to show are:

 

Waiting for server reply:

Protecting socket fd 4

 

and/or

 

The VpnService API allows routes to be set on connect only.

 

I recently switched to a 4G LTE mobile plan via Straight Talk wireless. On 3G, I was able to connect to the VPN of my home network just fine using a standard PPTP setup via my mobile data. However, even since I switched to my new 4G LTE plan, I have been unable to connect to my home network using PPTP or UDP via AirVPN.

 

Has anyone experience this or could possibly offer some insight as to how I can use UDP via my mobile data?

Share this post


Link to post

it may or may not be a specific block however, the way that straight talk/Tracfone handles routing may also be an issue.  They have a very convulted/non-conventional system.  I observed out-port IP Address changes as frequently as once every 3minutes.  Their tech support is clueless on this, i had to switch to pre-paid with verizon and it has worked fine since and no crazy out-port IP address changes except on disconnect/reconnect.  The IP address i am referring to is the carrier public address not related to vpn service at all.

Share this post


Link to post

Thanks for the reply freeworld.

 

I read plenty of stories about Straight Talk's restrictions, but their service is cheap and pretty decent for me, so I'm fine with TCP being my only method to use AirVPN services.

 

Now I have to figure out a way to restrict certain apps on my phone to not use AirVPN. I notice that apps like Tapatalk and MMS messages won't work while I'm connected.

Share this post


Link to post

I am having same problem with T-Mobile USA with 4G LTE. In my case, I can connect via UDP 443 port but some websites doesn't open. For example, I can't access dnsleaktest, airvpn or whatismyip websites. I just can't figure out what is causing a problem!

 

Edit: I have solved my problem! It was related to my phone network APN settings. T-Mobile USA is using IPv6 on the supported phones. So, when I was using VPN it was causing problems. So, I have changed my APN setting to IPv4 and everything is working without any problem!

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...