Jump to content


Photo

AirDNS stopped working unexpectedly after two months of use on pfSense

airdns pfsense

  • Please log in to reply
57 replies to this topic

#41 cr00

cr00

    Newbie

  • Members2
  • Pip
  • 8 posts

Posted 28 December 2018 - 07:48 PM

After reinstalling my old config I followed these steps. It worked.

 

But there is a catch. If I reboot, my internet connection is lost.

 

Did you reboot after you found this workaround?

 

I had to reinstall the configuration with this workaround to make it work again.

 

 

 

DNS-Forwarder is disabled: Enable [  ] Enable DNS forwarder is unchecked.
DNS-Resolving worked immediately after disabling DNSSEC in the DNS-Resolver-config. After disabling DNSSEC there you got to restart the DNS-Resolver.

Enabling DNSSEC + restarting the DNS-Resolver leads again to the error.

 

In the meantime I restarted the pfsense-box too. With DNSSEC disabled everything is working fine now.



#42 Wolke68

Wolke68

    Member

  • Members2
  • PipPip
  • 20 posts

Posted 28 December 2018 - 07:53 PM

Sure i rebooted a few times after that and it worked with dnssec

What are your Main DNS in System?
With or without a Gateway?

Dont youse 10.4.0.1 for Gateway monitoring!

#43 hbs

hbs

    Advanced Member

  • Members2
  • PipPipPip
  • 40 posts

Posted 28 December 2018 - 08:43 PM

After reinstalling my old config I followed these steps. It worked.

 

But there is a catch. If I reboot, my internet connection is lost.

 

Did you reboot after you found this workaround?

 

I had to reinstall the configuration with this workaround to make it work again.

 

 

 

DNS-Forwarder is disabled: Enable [  ] Enable DNS forwarder is unchecked.
DNS-Resolving worked immediately after disabling DNSSEC in the DNS-Resolver-config. After disabling DNSSEC there you got to restart the DNS-Resolver.

Enabling DNSSEC + restarting the DNS-Resolver leads again to the error.

 

In the meantime I restarted the pfsense-box too. With DNSSEC disabled everything is working fine now.

 

This is my configuration (DNS Resolver) as of the moment it is working.

 

screencapture-192-168-0-1-services_unbound-php-2018-12-28-17_30_15.png

 

The only thing I did to make this work was unchecking DNSSSEC 

 

and save it. And Apply settings.

 

Do you want me to disable DNS resolver. Then Enable DNS Forwarder?

 

Didn't get that part



#44 hbs

hbs

    Advanced Member

  • Members2
  • PipPipPip
  • 40 posts

Posted 28 December 2018 - 08:48 PM

Sure i rebooted a few times after that and it worked with dnssec

What are your Main DNS in System?
With or without a Gateway?

Dont youse 10.4.0.1 for Gateway monitoring!

 

screencapture-192-168-0-1-status_gateways-php-2018-12-28-17_45_45.png

screencapture-192-168-0-1-system-php-2018-12-28-17_46_13.png



#45 Wolke68

Wolke68

    Member

  • Members2
  • PipPip
  • 20 posts

Posted 28 December 2018 - 08:51 PM

DNS resolver is ok
If it works for you it s your choice

I have no DNS Query Forwarding
and i have in the Advanced Box some other Option not 127.0.0.1


Sorry and you dont read my Messages

Main DNS Not 10.4.0.1

Mine are

208.67.222.222
208.67.220.220

#46 Wolke68

Wolke68

    Member

  • Members2
  • PipPip
  • 20 posts

Posted 28 December 2018 - 09:05 PM

these are mine options

 

Attached Thumbnails

  • 1.PNG
  • 2.PNG


#47 hbs

hbs

    Advanced Member

  • Members2
  • PipPipPip
  • 40 posts

Posted 28 December 2018 - 10:37 PM

these are mine options

 

Thanks for replying.

 

I tried to use your DNS Resolver custom options for my DNS Resolver but they are ending in error.

 

Could you please, copy and paste it here?



#48 Air4141841

Air4141841

    Advanced Member

  • Members2
  • PipPipPip
  • 101 posts

Posted 29 December 2018 - 12:21 AM

this thread has made my head hurt bad.

 

i have tried to set mine up the way others are explaining and i can not get it to work.      i guess i am working with a broken Pfsense box as well    :no:



#49 hbs

hbs

    Advanced Member

  • Members2
  • PipPipPip
  • 40 posts

Posted 29 December 2018 - 12:51 AM

Air4141841 sorry to hear that.

 

But I assure you. If you follow the pfsense Tutorial from AirVPN it will work.

 

For that, to work you only need to disable DNSSEC like mentioned above.

 

Only that.

 

But you will end up like me. Without the possibility to reboot.

 

I'm waiting to hear what else cr00 can tell us.



#50 cr00

cr00

    Newbie

  • Members2
  • Pip
  • 8 posts

Posted 29 December 2018 - 12:30 PM

DNS-Forwarder is disabled: Enable [  ] Enable DNS forwarder is unchecked.


DNS-Resolving worked immediately after disabling DNSSEC in the DNS-Resolver-config. After disabling DNSSEC there you got to restart the DNS-Resolver.

Enabling DNSSEC + restarting the DNS-Resolver leads again to the error.

 

In the meantime I restarted the pfsense-box too. With DNSSEC disabled everything is working fine now.

This is my configuration (DNS Resolver) as of the moment it is working.

 

attachicon.gifscreencapture-192-168-0-1-services_unbound-php-2018-12-28-17_30_15.png

 

The only thing I did to make this work was unchecking DNSSSEC 

 

and save it. And Apply settings.

 

Do you want me to disable DNS resolver. Then Enable DNS Forwarder?

 

Didn't get that part

Hi hbs,

maybe I have not expressed myself clearly. sorry for that.

 

My current settings for the

DNS-Resolver (DNS-Resolver activated, DNSSEC disabled) and the

DNS-Forwarder (disabled) are identical to pfsense_fan's tutorial, except the DNSSEC, which in the tutorial ist wrongly enabled.

 

AirVPN support informed me, that there is no need of DNSSEC in case you use the AirVPN-DNS-Servers (a.e. 10.4.0.1).

Under this configuration I have no DNS-Resolving issues.

 

Indead it is strange, that the enabled DNSSEC option was working until last week, although the AirVPN DNS-servers are not configured for DNSSEC.

The support couldn't explain this yet, the tech-support will investigate further.

 

I hope your config is working with these settings now, like my pfsense-box does.



#51 hbs

hbs

    Advanced Member

  • Members2
  • PipPipPip
  • 40 posts

Posted 29 December 2018 - 04:04 PM

Hi cr00, thanks for replying.

 

My internet connection is working (although I had to relate to you guys that Netflix USA is being geo-blocked on my Fire TV, Nvidia Shield. Is not working anymore. But this is a side note) but If I reboot. it is gone. My settings are identical to yours on the DNS Resolver. 

 

I discovered that if I reenable DNSSEC, reboot and the re-disable DNSSEC it works again. It is ludicrous. But at least it is working. I found easier just to reload a saved configuration.

 

Since I am not so sure it is working 100% as it is now, because of the issue with Netflix (Well who knows maybe it is working for other people and this is just a strange week for me) I will try to re-config later. To see if I missed some step on the community pfsense guide.



#52 Air4141841

Air4141841

    Advanced Member

  • Members2
  • PipPipPip
  • 101 posts

Posted 30 December 2018 - 01:18 PM

Netflix does not work on any android or LG tv on my  Air Tunnel either. But a device going through the WAN using Eddie DOES work...    in the 3 years i've used Pfsense i have not been able to figure it out with Airvpn. it does not work with ProtonVpn for the trial i used with them either with Pfsense.     so this is not a Air or Proton issue its a configuration issue

 

Pfsense is SO complicated...   



#53 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7796 posts

Posted 30 December 2018 - 01:32 PM

Netflix does not work on any android or LG tv on my  Air Tunnel either. But a device going through the WAN using Eddie DOES work...    in the 3 years i've used Pfsense i have not been able to figure it out with Airvpn. it does not work with ProtonVpn for the trial i used with them either with Pfsense.     so this is not a Air or Proton issue its a configuration issue

 

Pfsense is SO complicated...   

 

Hello!

 

A possible explanation is related to the DNS settings of the device behind the pfSense box. Keep in mind that in order to access Netflix USA the device must query Air VPN DNS. Any device will not necessarily query the DNS set in pfSense, obviously. On top of that, some devices such as the Roku 3 have hard coded DNS (an old version of Roku queries Google DNS for example). In such cases you need to pre-route (re-direct) any DNS query from any device to AirVPN DNS through the tun interface (you can't reach VPN DNS from outside the tunnel).

 

Kind regards



#54 hbs

hbs

    Advanced Member

  • Members2
  • PipPipPip
  • 40 posts

Posted 30 December 2018 - 08:07 PM

Netflix does not work on any android or LG tv on my  Air Tunnel either. But a device going through the WAN using Eddie DOES work...    in the 3 years i've used Pfsense i have not been able to figure it out with Airvpn. it does not work with ProtonVpn for the trial i used with them either with Pfsense.     so this is not a Air or Proton issue its a configuration issue

 

Pfsense is SO complicated...   

 

Hello!

 

A possible explanation is related to the DNS settings of the device behind the pfSense box. Keep in mind that in order to access Netflix USA the device must query Air VPN DNS. Any device will not necessarily query the DNS set in pfSense, obviously. On top of that, some devices such as the Roku 3 have hard coded DNS (an old version of Roku queries Google DNS for example). In such cases you need to pre-route (re-direct) any DNS query from any device to AirVPN DNS through the tun interface (you can't reach VPN DNS from outside the tunnel).

 

Kind regards

 

Hi Staff,

 

Is there a tutorial on how we can redirect DNS to AirVPNs through the tun interface?

 

Or maybe if you can elaborate with more info. I like the sound of that. I'd like to give a try.

 

Please,let us know



#55 lordlukan

lordlukan

    Member

  • Members2
  • PipPip
  • 25 posts

Posted 10 January 2019 - 08:45 PM

Netflix does not work on any android or LG tv on my  Air Tunnel either. But a device going through the WAN using Eddie DOES work...    in the 3 years i've used Pfsense i have not been able to figure it out with Airvpn. it does not work with ProtonVpn for the trial i used with them either with Pfsense.     so this is not a Air or Proton issue its a configuration issue

 

Pfsense is SO complicated...   

Hello!

 

A possible explanation is related to the DNS settings of the device behind the pfSense box. Keep in mind that in order to access Netflix USA the device must query Air VPN DNS. Any device will not necessarily query the DNS set in pfSense, obviously. On top of that, some devices such as the Roku 3 have hard coded DNS (an old version of Roku queries Google DNS for example). In such cases you need to pre-route (re-direct) any DNS query from any device to AirVPN DNS through the tun interface (you can't reach VPN DNS from outside the tunnel).

 

Kind regards

Hi Staff,

 

Is there a tutorial on how we can redirect DNS to AirVPNs through the tun interface?

 

Or maybe if you can elaborate with more info. I like the sound of that. I'd like to give a try.

 

Please,let us know

I managed to get Netflix working with pfsense, using Unbound (DNS Resolver).

Services > DNS resolver > General Settings

1. Network Interfaces should only have localhost and your LAN highlighted

2. Outgoing network interfaces should only include all of your VPN interfaces. In my case there are 3 different AirVPN interfaces

3. System domain local type: Transparent

4. DNSSEC: unchecked

5. DNS Query forwarding: unchecked

6. DHCP resgistration: checked

7. Static DHCP: Checked

8. Custom options:

forward-zone:
name: "."
forward-addr: 10.4.0.1

 

System > General Setup

DNS Servers 10.4.0.1 Gateway None

 

Hope this helps.



#56 hbs

hbs

    Advanced Member

  • Members2
  • PipPipPip
  • 40 posts

Posted 11 January 2019 - 09:19 PM

 

Netflix does not work on any android or LG tv on my  Air Tunnel either. But a device going through the WAN using Eddie DOES work...    in the 3 years i've used Pfsense i have not been able to figure it out with Airvpn. it does not work with ProtonVpn for the trial i used with them either with Pfsense.     so this is not a Air or Proton issue its a configuration issue

 

Pfsense is SO complicated...   

Hello!

 

A possible explanation is related to the DNS settings of the device behind the pfSense box. Keep in mind that in order to access Netflix USA the device must query Air VPN DNS. Any device will not necessarily query the DNS set in pfSense, obviously. On top of that, some devices such as the Roku 3 have hard coded DNS (an old version of Roku queries Google DNS for example). In such cases you need to pre-route (re-direct) any DNS query from any device to AirVPN DNS through the tun interface (you can't reach VPN DNS from outside the tunnel).

 

Kind regards

Hi Staff,

 

Is there a tutorial on how we can redirect DNS to AirVPNs through the tun interface?

 

Or maybe if you can elaborate with more info. I like the sound of that. I'd like to give a try.

 

Please,let us know

I managed to get Netflix working with pfsense, using Unbound (DNS Resolver).

Services > DNS resolver > General Settings

1. Network Interfaces should only have localhost and your LAN highlighted

2. Outgoing network interfaces should only include all of your VPN interfaces. In my case there are 3 different AirVPN interfaces

3. System domain local type: Transparent

4. DNSSEC: unchecked

5. DNS Query forwarding: unchecked

6. DHCP resgistration: checked

7. Static DHCP: Checked

8. Custom options:

forward-zone:
name: "."
forward-addr: 10.4.0.1

 

System > General Setup

DNS Servers 10.4.0.1 Gateway None

 

Hope this helps.

 

Thanks for replying it.

 

I followed your guidelines but still can't make it work on my Nvidia Shield or Roku Ultra. I'm being blocked with that damn message.

 

On Outgoing network interfaces, I only have two interfaces linked to AirVPN (they were created following the community guide provided by AirVPN) 

 

screencapture-192-168-0-1-services_unbound-php-2019-01-11-18_06_17.png

 

This is my DNS resolver config.

 

I wonder. On what devices have you been able to get Netflix working?



#57 lordlukan

lordlukan

    Member

  • Members2
  • PipPip
  • 25 posts

Posted 12 January 2019 - 09:18 AM

I wonder. On what devices have you been able to get Netflix working?

I only use Netflix through Chrome Browser on computers and on PS4.



#58 hbs

hbs

    Advanced Member

  • Members2
  • PipPipPip
  • 40 posts

Posted 15 January 2019 - 03:32 PM

I wonder. On what devices have you been able to get Netflix working?

I only use Netflix through Chrome Browser on computers and on PS4.

On Web Browsers, it works for me. But I wanted to make it run on any streaming device like some comments implied on the thread announcement about Netflix at this forum.

 

Thanks for your reply. 

 

I believe is not possible to do what  I wanted to do. At least for now.

 

I pretty sure I am redirecting all traffic to AirVPN DNS. 







Similar Topics Collapse


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14855 - BW: 48989 Mbit/sYour IP: 52.91.176.251Guest Access.