Jump to content


Photo

Slow speeds with PFsense


  • Please log in to reply
7 replies to this topic

#1 dssguy11

dssguy11

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 02 August 2014 - 07:53 AM

Hey guys, wondering if anyone can give me some help.  I have PFsense installed using the guide on the forums. Everything is working but no matter what server i try, i only get 3-5Mbs no matter what server i try. I have 50Mbs service.  I was hoping to get in the 40's since i built a pfsense box to get around the limitations of a consumer router.  Any help would be much appreciated..

 

hey guys, figured it out.  It was the auto speed setting in pfsense on my intel NIC. Once i changed it, i was getting about 80% of my 50Mbs service through the VPN.



#2 dalesd

dalesd

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts

Posted 22 August 2014 - 11:12 PM

Where is this auto speed setting in pfsense?  



#3 pfSense_fan

pfSense_fan

    Advanced Member

  • Members
  • PipPipPip
  • 247 posts

Posted 23 August 2014 - 02:28 AM

Hey guys, wondering if anyone can give me some help.  I have PFsense installed using the guide on the forums. Everything is working but no matter what server i try, i only get 3-5Mbs no matter what server i try. I have 50Mbs service.  I was hoping to get in the 40's since i built a pfsense box to get around the limitations of a consumer router.  Any help would be much appreciated..

 

hey guys, figured it out.  It was the auto speed setting in pfsense on my intel NIC. Once i changed it, i was getting about 80% of my 50Mbs service through the VPN.

 

 

I'll assume you're talking about the auto negotiation of the port speed on the interface settings page?

 

If yes, what intel NIC do you have? what drivers does it use? em0, em1 etc or is it igb0, igb1 etc?  I may be able to toss a few extra, more specific tweaks your way.

 

Also, are you using the IP fastforwarding sysctl tweak at the end of the guide?


Have my guides helped you? Help me keep helping you, use my referral: userbar.png

How to set up pfSense 2.3 for AirVPN

Friends don't let friends use consumer networking equipment!


#4 dssguy11

dssguy11

    Advanced Member

  • Members
  • PipPipPip
  • 32 posts

Posted 23 August 2014 - 03:18 PM

Where is this auto speed setting in pfsense?  

 

it's on the interface settings page.

 

 

My network card is the Intel PRO/100 PT Dual Port Server adapter.  It uses EM0 and EM1 driver, any tweaks would be great.  I didn't see that tweak until I re-read your post, then i added it, will test it out! 

 

 

When is your new guide coming out?  was considering buying another switch but may not need it.



#5 dalesd

dalesd

    Advanced Member

  • Members
  • PipPipPip
  • 33 posts

Posted 23 August 2014 - 09:44 PM

Sorry to hijack your thread, dssguy11.  
 
My PfSense setup was "good enough", but I was only getting ~15 Mbps when I have a 50 Mbps connection, and the ping is kinda high, so I tried fixing it.  
 
First, I changed from UDP port 443 to 53.  That didn't seem to do anything.  I have changed back to 443.  
 
Next, all I did was change my Interfaces from "Default" to 100baseTX <full-duplex> WAN and 1000baseT <full-duplex> LAN.
That didn't help. In fact, things got a lot slower on the download, although my Upload increased.
 
 
3709512106.png
 
 
Then I set the IP fastforwarding sysctl tweak.  
 
The CPU is a Core2Duo 3.0GHz, and utilization never goes above 10% when doing speed tests.  
 
I've always had this "extra" AirVPN Gateway, plus an IPv6 gateway.  Is that normal?
 
EDIT by Staff: image removed for privacy reasons. User published own IP address in the screenshot.

#6 pfSense_fan

pfSense_fan

    Advanced Member

  • Members
  • PipPipPip
  • 247 posts

Posted 24 August 2014 - 01:52 AM

Edit: Thank You Staff!

 

 

Don't post pics of the dashboards guys... private info! Take this down... PM  me for assistance!


Have my guides helped you? Help me keep helping you, use my referral: userbar.png

How to set up pfSense 2.3 for AirVPN

Friends don't let friends use consumer networking equipment!


#7 Sekrit_Skworl

Sekrit_Skworl

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 26 February 2015 - 03:41 AM

Hey guys, wondering if anyone can give me some help.  I have PFsense installed using the guide on the forums. Everything is working but no matter what server i try, i only get 3-5Mbs no matter what server i try. I have 50Mbs service.  I was hoping to get in the 40's since i built a pfsense box to get around the limitations of a consumer router.  Any help would be much appreciated..

 

hey guys, figured it out.  It was the auto speed setting in pfsense on my intel NIC. Once i changed it, i was getting about 80% of my 50Mbs service through the VPN.

 

Ok,

I have been trying PFsense on and off as work has allowed... I have thought that it was the Ubiquiti equipment.  However, after scratching all other options in PFSense and doing a simple speed test, I simply do not have the speeds that I do from my Arris Gateway through Comcast.

 

My PFsense speedtest speeds are (4.5 Mbps down/ .14Mbps up)

My Arris Gateway speeds are (47 Mbps down / 9 Mbps up)

 

what on earth am I doing wrong here?



#8 flat4

flat4

    Advanced Member

  • Members
  • PipPipPip
  • 416 posts

Posted 27 February 2015 - 01:03 PM

I have not configured my pfSense box yet, however i was trying out Eddie (latest) and on my fiber connection when out of tunnel i got my advertised speed. When in the the tunnel it drooped to %20 of total bandwidth. I posted this and giganerd and the air vpn staff suggested i try it with SSL and BOOM! getting my full speed.

 

So I was told by both parties that my internet provider was more than likely doing traffic shaping.  I have read an re-read pfSense_fan and probably read it again to get familiar with pfSense.

 

 

anyway I would try eddie on clear net (not thru pfsense) see you speeds just connecting to Airvpn and then AirVPN using SSL and compare the difference. I know for me its going to have to use SSL.

 

 

 

EDIT: I guess you cannot use the SSL option when using a config for a router or other, Sorry I spoke.







Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 15080 - BW: 50290 Mbit/sYour IP: 54.197.24.206Guest Access.