Jump to content
Not connected, Your IP: 52.203.18.65
iwih2gk

Eddie hanging/freezing after Debian 11 updates last week

Recommended Posts

I don't see anything being posted by other users so once again maybe I am having all the fun here!  I am running the latest stable release of Eddie and its been working flawlessly for a long time.  About a week ago I did apt-get updates to Bullseye.  I wish I had copied a list of the files that updated before I ran the process, but who does that?  Shortly afterwards my Eddie clients have been hanging on about 5 machines all running Bullseye.  Prior to the Deb 11 updates these all ran for many months without any glitches.

When I mount/boot the machines Eddie will come up flawlessly and never drops my connection.  I cannot change servers or Exit/close Eddie from the UI.  I simply shutdown my OS when I am finished and the next time it mounts perfectly again.  I am going to tinker with preferences but right now I can't grab logs because the client is hung.  Network lock still working and as long as I only want to use one server per session I would be good.  That is not the case because I move around like alot of other users here.

Maybe I should delete Eddie-UI and reinstall it to see if that has any effect.  I wouldn't delete the config files for Eddie just the main client.  If I do that I will come back and let you know how it went.

Other ideas since I don't have logs.

Share this post


Link to post
51 minutes ago, iwih2gk said:

About a week ago I did apt-get updates to Bullseye.  I wish I had copied a list of the files that updated before I ran the process, but who does that?


/var/log/apt/history.log[.gz.X]. :)

I've had my fair share of breakage with major version upgrades of Debian and I vowed to never do that again. I also stopped doing do-release-upgrade on Ubuntu servers, it's just absolutely unpredictable. Glad to have jumped ship to a rolling distribution, even for servers, this is sooo much more fun.

Does Eddie show the same behavior if you don't launch it at boot, then launch it manually via terminal?

NOT AN AIRVPN TEAM MEMBER. USE TICKETS FOR PROFESSIONAL SUPPORT.

LZ1's New User Guide to AirVPN « Plenty of stuff for advanced users, too!

Unofficial Eddie for Android F-Droid repository: repo.opensourcery.eu

Want to contact me directly? All relevant methods are on my About me page.

Share this post


Link to post

Just wanted to touch back here to correctly note the problem.  It is NOT the upgrade of Debian that caused the issues I STILL experience.  This is only happening on Linux hosts using VirtualBox with connected VM's.  When Debian updated it caused VirtualBox to rebuild a bunch of stuff, which is quite common with Debian updates.

Again ---- my Debian systems running bare metal and no VM's are running flawlessly with Eddie.  Earlier I had neglected to note that non-VirtualBox systems were and are unaffected where Eddie is concerned.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...