Jump to content
Not connected, Your IP:

Installation and launch problems

Recommended Posts

I have been using AirVPN/Eddie - UI for several years. Recently I had to reset my PC to factory settings and re-installed AirVPN/Eddie - UI. After some hassles it was running but not auto starting and then auto started. However, today I uninstalled it through Windows/Settings/Apps and then could not re-install it after downloading it. It stops installing with the message Error opening file for writing C:\Program Files\AirVPN\libcrypto-1_1-x64.dll Retry does nothing. Ignore changes the filename to liblzo2-2.dll then libpkcs11-helper-1.dll then libssl-1_1-x64.dll then openvpn.exe The final click on Ignore causes the installation to, apparently, be Completed.. Clicking Next results in me being told that Eddie - OpenVPN UI has been installed and I click Finish. I then go to Windows Start/AirVPN/ and click Eddie - UI, which launches Eddie - UI. It goes through a couple of small black windows/whatevers with scripts "Connect with daemon for system privileges" and "Raise system privileges". A dialog box/window appears asking if I want this app to make changes to my device. Irrespective of whether I click Yes or No, the result is the same, "Unable to obtain elevated privileges (required). Unable to start (No socket). I have tried deleting the sub-folder AirVPN in C:\Program Files\ and tried to delete the files in the folder but am unable to. Attached hereto are sequential images of the steps described above. Advice will be appreciated.

Screenshot 2021-03-01 213758.jpg

Screenshot 2021-03-01 213949.jpg

Screenshot 2021-03-01 214037.jpg

Screenshot 2021-03-01 214135.jpg

Screenshot 2021-03-01 214222.jpg

Screenshot 2021-03-01 214302.jpg

Screenshot 2021-03-01 214352.jpg

Screenshot 2021-03-01 214429.jpg

Screenshot 2021-03-01 214510.jpg

Screenshot 2021-03-01 214548.jpg

Screenshot 2021-03-01 214628.jpg

Screenshot 2021-03-01 214706.jpg

Screenshot 2021-03-01 214747.jpg

Screenshot 2021-03-01 215002.jpg

Share this post

Link to post
Posted ... (edited)

I have the same errors when trying to install Eddie Desktop 2.20.0 released ...:-(
(Windows 10 Professionnel 20H2 - version 19042.867)

In fact the 4 .dll and the .exe of the previous version can't be deleted ...
Must manually deleted after stoping the service.
A scan with Advanced System Care, and beboot. After what I can install 2.20.0 😉

Edited ... by Eniripsa
found a solution

Share this post

Link to post

Thanks for the reply.
I have Windows version 1909 OS Build 18363.1440. This is an old Lenovo Yoga 700-141SK that must have a serious amount of work done to it. 
My launch problems seem to have disappeared except it does launch automatically as setup.. I have the "Connect at Startup" checkbox ticked and  the "Start with System" checkbox is unticked. Eddie version 2.20.0 is installed

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...