Jump to content
Not connected, Your IP: 34.237.124.210

Recommended Posts

I am trying to forward TCP port 32400 using DD_WRT using the following rules:-

iptables -I FORWARD -i tun0 -p tcp -d destIP --dport port -j ACCEPT
iptables -t nat -I PREROUTING -i tun0 -p tcp --dport port -j DNAT --to-destination destIP
 
However when i check using  https://www.canyouseeme.org/  I can see that the port is still closed? I have tried 3 different NL servers so far?

If I try and forward port TCP port 32400 using Your forwarded ports, a random port is created. However I I run the TCP test I keep getting Error 110 connection timed out.

If I try and use Your forwarded ports and just let random ports be selected, they too fail the TCP test?

I have confirmed that tun0 is the correct for my router

 

Share this post


Link to post

Port 32400 is the internal management port for PLEX. Meaning, it's the port you would access from your local network only. If you're attempting to access it from outside of your home network, you need to setup a port on Air (e.g. 1234) and have your router forward any incoming traffic on the connection to that port (e.g. 1234), to the device running PLEX. In your PLEX options, you manually specify a port for forwarding, which is the port on Air (e.g. 1234). PLEX should then indicate it's reachable outside of your network.

Share this post


Link to post

I had so many problems with Plex and port forwarding.

My solution was to:
1. Get a random port from AirVPN
2. Set the local port on AirVPN to 32400
3. Set the port in Plex to default (32400)

When I tried chaning the port on Plex to anything else, my port would always be closed when I checked.
Hosting anything else on the same port, like a webserver, would work perfectly.

Share this post


Link to post

I have got it working, I needed to put the iptables rules in the startup script box in DD-WRT instead of the firewall script box.

Plex reports that in has no connection to the outside world, but it works fine on wireless devices of my network?

I tried the solution in the post above and found it didnt work, also once I had created a random port, if I run the TCP test it would fail, with an Error 1110?

Share this post


Link to post
Posted ... (edited)

The Startup commands are only executed at boot. The Firewall commands are executed multiple times in a normal boot cycle and also when you Apply certain GUI pages to tweak things. Maybe other times as well... I don't remember. Any time the firewall needs to be rebuilt/reinitialized. At each such time that occurs after your Startup commands are run, you will lose any firewall commands you created with iptables commands in Startup. So putting iptables commands in the Startup box is generally a bad idea. 

In any case, I discovered all this by putting a command

    date >> /tmp/root/fwlog

in the Firewall box, rebooting, and then having a look at the file later using ssh. If you want the date lines in the syslog instead, you can use something like this in the Firewall box instead:

    echo 'commands executed' | logger -t Firewall

Edited ... by SurprisedItWorks

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...