Jump to content
Not connected, Your IP: 3.238.174.50
nooky

Eddie cannot be installed on Kubuntu 20.10!

Recommended Posts

Posted ... (edited)

Hi Guys!

I have a new computer and I installed Kubuntu 20.10 on it.

I wanted to install Eddie (with the previous system, ubuntu 18.04, it worked without any problems) but it didn't work.

First I tried the instructions for the terminal at:

https://airvpn.org/linux/

wget -qO - https://eddie.website/repository/key
s/eddie_maintainer_gpg.key
-----BEGIN PGP PUBLIC KEY BLOCK-----
Version: GnuPG v1
"...
mQINBFhzx0YBEADaS2ec+KDO8YvaNhR5VmlAEBLi8+LZQXn27TS3bst/3r8wY11R
p75wZhTEhEB1vZwJ1hvR6oaLZmtrsEoVCD38qmJ9OHPiTAXMW520gdH3Vv1ST2YR
JARF3dExae5BSeAIVaZ0JWQCpwSm3g2JJAzs7zzIu0Qw6U6tNg+7wzwgdRVenFrL
9Q7TQMdA7SWiQbmfOGm7XFzBPFZhjjCpWGcJ1jKHkl8e6GMHIxE8ZEvh4Om1iUAF
..."
-----END PGP PUBLIC KEY BLOCK-----
nooky@nooky-lautlos:~$


after that:

sudo apt-key add
[sudo] Passwort für nooky:  
Warning: apt-key is deprecated. Manage keyring files in trusted.gpg.d
instead (see apt-key(8)).


and then nothing more happened!.

I then have the file

eddie-ui_2.18.9_linux_x64_portable.tar.gz

downloaded and installed! it looked like it worked! However, if I want to start it, what can be seen on the screeshots in the attachment opens!

So the window is the familiar but nothing else in it or to click or something!

When starting from the console, this output comes out:

ooky@nooky-lautlos:~$ eddie-ui

(mono:12168): Gtk-WARNING **: 20:48:52.135: Unable to locate theme eng
ine in module_path: "adwaita",
. 2020.10.27 20:48:52 - Eddie version: 2.18.9 / linux_x64, System: Lin
ux, Name: Ubuntu 20.10 \n \l, Version: Linux nooky-lautlos 5.8.0-25-ge
neric #26-Ubuntu SMP Thu Oct 15 10:30:38 UTC 2020 x86_64 x86_64 x86_64
GNU/Linux, Mono/.Net: 6.8.0.105 (Debian 6.8.0.105+dfsg-3 Mon Apr 27 1
9:25:46 UTC 2020); Framework: v4.0.30319
. 2020.10.27 20:48:52 - Command line arguments (2): path.resources="/u
sr/share/eddie-ui" path.exec="/usr/bin/eddie-ui"
. 2020.10.27 20:48:52 - Raise system privileges
. 2020.10.27 20:49:00 - Profile path: /home/nooky/.config/eddie/defaul
t.profile
. 2020.10.27 20:49:00 - Reading options from /home/nooky/.config/eddie
/default.profile
. 2020.10.27 20:49:01 - Tun Driver - /dev/net/tun
. 2020.10.27 20:49:01 - OpenVPN - Version: 2.4.9 - OpenSSL 1.1.1f  31
Mar 2020, LZO 2.10 (/usr/sbin/openvpn)
. 2020.10.27 20:49:01 - SSH - Version: OpenSSH_8.3p1 Ubuntu-1, OpenSSL
1.1.1f  31 Mar 2020 (/usr/bin/ssh)
. 2020.10.27 20:49:01 - SSL - Version: stunnel 5.56 (/usr/bin/stunnel4
)
. 2020.10.27 20:49:01 - curl - Version: 7.68.0 (/usr/bin/curl)

(eddie-tray:12205): Gtk-WARNING **: 20:49:01.483: Unable to locate the
me engine in module_path: "adwaita",
I 2020.10.27 20:49:02 - Ready
. 2020.10.27 20:49:02 - Collect information about AirVPN completed



How can I completely uninstall Eddie again?

Then how do I get Eddie to run?


 

Screenshot_Eddie_Air_VPN.png

Screenshot_Eddie_Air_VPN_II.png

Edited ... by nooky

Share this post


Link to post

Did you pipe wget output to apt-key? Looks like you used the two commands separately.
 


If you use apt-key add without anything after add, apt-key reads from STDIN, which would explain why nothing was printed after it. Try with the pipe, then continue following procedure, after which you can delete the portable.
 
13 hours ago, nooky said:

So the window is the familiar but nothing else in it or to click or something!


You're missing some Mono libraries which would've been installed via APT. So make sure to follow the installation steps above.
 
13 hours ago, nooky said:

How can I completely uninstall Eddie again?


It's not installed. Delete the portable directory and it's gone. :)

» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...