Jump to content
Not connected, Your IP: 3.227.233.6
varttaanen

SSL connection drops when data is transferred

Recommended Posts

Hello everyone,

Since some time now, whenever I open a SSL connection via Eddie, the connection is made with the server and Eddie stays connected, but only until data starts being transferred, for example when I type 'google.com' in my browser's address bar. Then it immediately disconnects, and tries to recover the connection (no use, because the recovered connection has the same issue).

Any ideas how to solve this? SSL gives me the best connection as my provider caps most other protocols.

I'm using Manjaro Linux and Eddie 2.16.3,


Win7 | Manjaro Gnome | Eddie stable

Share this post


Link to post

Are you sure they didn't start capping it, too? :)


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
On 7/5/2019 at 9:59 PM, giganerd said:

Are you sure they didn't start capping it, too? :)


Probably, but I've never had the VPN automatically disconnecting by itself when data starts being transferred. With all other protocols, the connection is just very slow. Using SSH now on some obscure port and that goes a bit better, but not as good as the SSL was...

Checking the logs, maybe a problem with stunnel?
.
 2019.07.07 13:02:39 - OpenVPN > Initialization Sequence Completed
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: transfer() loop executes not transferring any data
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: please report the problem to Michal.Trojnara@stunnel.org
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: stunnel 5.51 on x86_64-pc-linux-gnu platform
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: Compiled/running with OpenSSL 1.1.1b  26 Feb 2019
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: Threading:PTHREAD Sockets:POLL,IPv6,SYSTEMD TLS:ENGINE,FIPS,OCSP,PSK,SNI
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: protocol=TLSv1.2, SSL_pending=0
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: sock_open_rd=Y, sock_open_wr=Y
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: SSL_RECEIVED_SHUTDOWN=n, SSL_SENT_SHUTDOWN=n
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: sock_can_rd=n, sock_can_wr=n
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: ssl_can_rd=n, ssl_can_wr=n
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: read_wants_read=Y, read_wants_write=n
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: write_wants_read=n, write_wants_write=n
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: shutdown_wants_read=n, shutdown_wants_write=n
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG3[0]: socket input buffer: 0 byte(s), TLS input buffer: 0 byte(s)
. 2019.07.07 13:02:45 - SSL > 2019.07.07 13:02:45 LOG5[0]: Connection reset: 32927 byte(s) sent to TLS, 37313 byte(s) sent to socket
. 2019.07.07 13:02:45 - OpenVPN > Connection reset, restarting [-1]
. 2019.07.07 13:02:45 - OpenVPN > SIGUSR1[soft,connection-reset] received, process restarting
. 2019.07.07 13:02:45 - OpenVPN > Restart pause, 5 second(s)
! 2019.07.07 13:02:45 - Disconnecting
. 2019.07.07 13:02:45 - Routes, removed a route previously added, 213.152.161.220 for gateway 192.168.0.1
. 2019.07.07 13:02:46 - Routes, removed a route previously added, 213.152.161.219 for gateway 10.12.109.1
. 2019.07.07 13:02:46 - Routes, removed a route previously added, 2a00:1678:2470:52:5af7:2c86:d778:b3c9 for gateway fde6:7a:7d20:86d::1
. 2019.07.07 13:02:46 - Sending management termination signal
. 2019.07.07 13:02:46 - Management - Send 'signal SIGTERM'


 

Win7 | Manjaro Gnome | Eddie stable

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...