Jump to content
Not connected, Your IP: 54.86.132.30

Recommended Posts

Hi i have installed airvpn on my router (asus wrt) and all went swimmingly, however when it went to open ports i had issues so i had to stop the vpn.

One of the ports i tried to open gave the message that they were already being used by another user? i,m trying to open 3 ports in total, i managed to open one port but it directed the port to my laptop i think which i dont want, i want to open ports on another device that is connected to my router but there seems to be no option to select a different internal ip for the device i want the ports open on.

I tried deleting the ports that were originally open on my router but it made no difference.

Also the ddns i had to input that with no dots? am i doing that right?

Any help is well appreciated

MK

Share this post


Link to post

Hi, just an update, i have seen how to add my ports in iptables on the router so i will manage that but i am still not sure of some things if someone can help..

I have a netgear nighthawk with asus wrt merlin ( NG Branch: 384.11_2 ) and i,m not sure which tun i input, also wondering if i still open ports in members area as well as iptables on my router.

Port XXXXX already reserved by another user.  This message appears in red also when i try to forward one of my ports in the members area.. i replaced my port with X

Any help greatly appreciated.

Share this post


Link to post
20 hours ago, meerkat7 said:

One of the ports i tried to open gave the message that they were already being used by another user?


Every port can only be forwarded to one specific user, of course. Simply click Add and configure your client to use the port the system chooses automatically. If you need a specific port, you can always forward a random remote port to that specific local port, though other users (or you) must use the remote port in order to connect to whatever you forwarded that port for.
 
20 hours ago, meerkat7 said:

Also the ddns i had to input that with no dots? am i doing that right?


If you enter ddns, you can reach it via ddns.airdns.org:yourremoteport.

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
Every port can only be forwarded to one specific user, of course. Simply click Add and configure your client to use the port the system chooses automatically. If you need a specific port, you can always forward a random remote port to that specific local port, though other users (or you) must use the remote port in order to connect to whatever you forwarded that port for.


No idea how to do that...it will take a week for this post to be moderated... and by which time i will have grown a beard....

Share this post


Link to post
1 hour ago, meerkat7 said:

it will take a week for this post to be moderated... and by which time i will have grown a beard....


Don't be so negative.. you're online.
 
1 hour ago, meerkat7 said:

No idea how to do that


pfwdialog.png.affc8f9b9994dc296b2d3e29968e26fc.png

First mask is the remote port you want to forward. Let's say you entered 9000. People must connect to you by using that port, e.g. 1.2.3.4:9000. If you enter nothing, a random free port will be forwarded.
In the protocol menu you select TCP, UDP or both. Leave it.
Local port is to which local port a connection to 1.2.3.4:9000 will be forwarded. If you enter 80, you need to configure your local software to use port 80, but people must still use port 9000 to connect to that software. If you enter nothing, the remote port (9000 here) will be forwarded to the same local port 9000.
If you enter myname into DDNS, people can additionally use the domain myname.airdns.org:9000 to connect instead of typing out 1.2.3.4:9000. If you enter nothing, people must use the IP.

Hope that clears up things a bit. :)

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Hi giganerd, sorry for the negativity, it was directed at the forum owners who decided to take an age to moderate my posts...not sure how long this post will take to moderate either, in post 2 i had an update which took ages for them to moderate so things got confusing... 

If i may can i start on fresh heels here... with your patience ofcourse giganerd.

I have found out some of my ports i cannot open properly as they are already taken... thats fine i can change that but one of my ports is ok so i can go ahead, 2 ports i will change and adapt to router but i dont know which tun to use...tun1?... its a netgear nighthawk r7000

Also some of my clients already use my own ddns... do i need to change that on all clients or can they still connect to my ddns once i have selected the ports, i have already selected ports available within airvpn

In ddns i had to use it with no dots... ie myddns.dyndns,net changed to myddnsdyndnsnet      is that ok

Does my clients have to now use airdns.org if i open ports properly.

Many thanks

Share this post


Link to post
18 hours ago, meerkat7 said:

it was directed at the forum owners who decided to take an age to moderate my posts...not sure how long this post will take to moderate either, in post 2 i had an update which took ages for them to moderate so things got confusing...


Moderators are people, too, who work, sleep and live their lives. In a more or less anonymous setting like this it's easier to forget that, but they are not supposed to sit around all day moderating these forums. Anyway, you will be removed from the mod queue after five approved posts, and as I can see you only need one more. :)
 
18 hours ago, meerkat7 said:

but i dont know which tun to use...tun1?... its a netgear nighthawk r7000


Do you have multiple (OpenVPN) connections on the same machine running? If not, there should be one tun interface only and it's usually tun0.
 
18 hours ago, meerkat7 said:

Also some of my clients already use my own ddns... do i need to change that on all clients or can they still connect to my ddns once i have selected the ports


Honestly, not sure what you're asking.. maybe it's the ambiguity between "my own ddns" and "airvpn"? What do you mean by the first and what by the second?
 
18 hours ago, meerkat7 said:

In ddns i had to use it with no dots... ie myddns.dyndns,net changed to myddnsdyndnsnet      is that ok


Erm, it should be with dots, it's how DNS works. Where do you enter such a thing?
 
18 hours ago, meerkat7 said:

Does my clients have to now use airdns.org if i open ports properly.


They can still use both the DNS name (myname.airdns.org) or the IP, but the IP is considerably harder to access because it changes when you switch servers. :)

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Thanks giganerd, apoligies to all including @admin, i got a bit lost, maybe too many drinks and lost patience which is not my strong field and then i got frustrated.

Anyway i am only using one vpn connection which is airvpn so i will try tun0 (thanks giganerd)

The ddns i am trying to input is one from noip which will update on my router or i can manually update my server ip on the said website if i have to, however if i try and input my noip ddns in the client area on airvpn while opening ports i recieve this message ( DNS name 'xxxxxxxx.ddns.net' invalid. Only the following characters are allowed: abcdefghijklmnopqrstuvwxyz0123456789- )

I have replaced my user with x for security purposes... if i input my ddns while opening ports in airvpn website from noip with no dots it accepts it...just a bit confused there and hope its clear.

Apoligies again for the negativity and thanks again for your help giganerd.

Share this post


Link to post

Oooh, I understand now what you are trying to achieve, but that won't work. You want AirDNS to tell No-IP your IP address but it's not the purpose of this feature.
What you really do with it is to give a name when forwarding a port and then you can reach your OpenVPN client by connecting to that name.airdns.org along with the port you forwarded (if it's port 9000, you connect to your client via name.airdns.org:9000). This is not a mask for DDNS domain names from other providers.


Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
On 6/14/2019 at 3:32 PM, giganerd said:

You want AirDNS to tell No-IP your IP address but it's not the purpose of this feature.

I have opened the ports with server names as advised by yourself giganerd but i am still having issues, can you tell me how i tell noip my address via airvpn.

I tried recently there to activate my vpn in my router and my browsers all acknowledge the new vpn ip but my own ddns will not update.

Share this post


Link to post
13 hours ago, meerkat7 said:

can you tell me how i tell noip my address via airvpn


You still don't do that directly. But there might be a way to make it work.

If you can enter CNAME or Alias entries in your No-IP.com account, you can enter name.airdns.org as destination/target/value/whatever it's called, name being what you entered in the DDNS field on port creation.

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post

Thanks giganerd, i dont seen to have that function on my noip account unless i am missing something but its a great idea, i can manually update my ip to the ip issued with airvpn but i suppose thats going to be an ongoing procedure and i dont even know if my clients will connect to my wan ip or airvpn if i do that.

My only other option i think is to change my clients over to servername.airdns.org , your input on that move would be appreciated too giganerd, bit of a faff but if thats what i need to do then so be it, i think i have exhausted enough of your time buddy on this and admin aswell.

Although if i can push the boat out once more, i have a netgear nighthawk with illegal software i am told so trying to get support is taxing it seems, i can move to tomato advanced but the software seems to be a tad outdated, dont know if thats due to it being rock solid or support has just stopped so i,m a little apprehensive to change over.

So i want to stay with asus xwrt on my netgear but i have read the commands will be different than the iptables commands already posted here and elsewhere , if you have time advice on the correct commands would be appreciated too giganerd.

Many thanks for all your time and help giganerd, really is appreciated.

MK

Share this post


Link to post
16 hours ago, meerkat7 said:

i can manually update my ip to the ip issued with airvpn but i suppose thats going to be an ongoing procedure and i dont even know if my clients will connect to my wan ip or airvpn if i do that


Not when you only ever connect to one single server. :D They will connect to whatever IP you manually enter, and since AirVPN exit IPs don't change it could work. But you still need to connect to only one server.
 
16 hours ago, meerkat7 said:

My only other option i think is to change my clients over to servername.airdns.org , your input on that move would be appreciated too giganerd, bit of a faff but if thats what i need to do then so be it


Yes. If you want to be connected the whole time, it's the recommended solution.
 
16 hours ago, meerkat7 said:

So i want to stay with asus xwrt on my netgear but i have read the commands will be different than the iptables commands already posted here and elsewhere , if you have time advice on the correct commands would be appreciated too giganerd.


I don't, sorry. But others surely can help with this. :)

Four simple things:
There's a guide to AirVPN. Before you ask questions, take 30 minutes of your time to go through it.

Amazon IPs are not dangerous here. It's the fallback DNS.
Running TOR exits is discouraged. They're subject to restrictions on the internet and harm all AirVPN users.

Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, you'll be unique among the mass again.

 

XMPP: gigan3rd@xmpp.airvpn.org or join our lounge@conference.xmpp.airvpn.org

Share this post


Link to post
9 hours ago, giganerd said:
I don't, sorry. But others surely can help with this. :)

https://airvpn.org/forums/topic/11264-asus-merlin-wrt-port-forwarding-script-setup/

I tried this above but still not sure how to find vlan and correct tun from option 8 of the guide

ifconfig gave me this so wondering what tun i should have in my config if you could help please.

br0       Link encap:Ethernet  HWaddr xxxxxxxxxxxxx  
          inet addr:192.168.1.1  Bcast:192.168.1.255  Mask:255.255.255.0
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
          RX packets:474311 errors:0 dropped:0 overruns:0 frame:0
          TX packets:294260 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:50036687 (47.7 MiB)  TX bytes:107091086 (102.1 MiB)

eth0      Link encap:Ethernet  HWaddr xxxxxxxxxxxxxx
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:23783891 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7974466 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:842005393 (802.9 MiB)  TX bytes:735977750 (701.8 MiB)
          Interrupt:181 Base address:0x6000 

eth1      Link encap:Ethernet  HWaddr xxxxxxxxxxxx
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
          RX packets:7763795 errors:0 dropped:0 overruns:0 frame:939994
          TX packets:21021441 errors:6331 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:644343109 (614.4 MiB)  TX bytes:616821177 (588.2 MiB)
          Interrupt:163 

eth2      Link encap:Ethernet  HWaddr xxxxxxxxxxxxxxxxxxx 
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:68603
          TX packets:0 errors:23 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:169 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING MULTICAST  MTU:16436  Metric:1
          RX packets:227420 errors:0 dropped:0 overruns:0 frame:0
          TX packets:227420 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:48491099 (46.2 MiB)  TX bytes:48491099 (46.2 MiB)

lo:0      Link encap:Local Loopback  
          inet addr:127.0.1.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING MULTICAST  MTU:16436  Metric:1

vlan1     Link encap:Ethernet  HWaddr xxxxxxxxxxxxxx
          UP BROADCAST RUNNING ALLMULTI MULTICAST  MTU:1500  Metric:1
          RX packets:915348 errors:0 dropped:0 overruns:0 frame:0
          TX packets:379131 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1224834058 (1.1 GiB)  TX bytes:35918311 (34.2 MiB)

vlan2     Link encap:Ethernet  HWaddr xxxxxxxxxxxxxxx 
          inet addr:xx.xx.xxx.xxx  Bcast:xx.xx.xxx.xxx  Mask:255.255.252.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:22874624 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7601409 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:29527972599 (27.5 GiB)  TX bytes:630353677 (601.1 MiB)

Many thanks

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...