Jump to content
Not connected, Your IP: 3.235.139.152
alfavpn

SOULSEEK Forward Ports impossible???

Recommended Posts

Soulseek ask me to open the 55740 port, but Airvpn tell me: "Port 55740 already reserved by another user." What means???

How can to do? Please help me

Share this post


Link to post

A given port can only be reserved by one account. If someone else reserved it already, I'm sorry.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post
 
Quote

given port can only be reserved by one account. If someone else reserved it already, I'm sorry.


Is this not normally solved with an technic based on V-Ports which Routed internally to the specific User  ? 

or is this not possible in these scenario

best regards
 

Share this post


Link to post

Hi @alfavpn, are you sure that the listening port for soulseek is fixed to that? You should check the settings in case that port number can be changed to one that is still free to configure in AirVPN.
 

Share this post


Link to post
2 hours ago, eburom said:

Hi @alfavpn, are you sure that the listening port for soulseek is fixed to that? You should check the settings in case that port number can be changed to one that is still free to configure in AirVPN.
 


I believe Soulseek hardcoded the port number 57038 for listening port. I recently downloaded Soulseek and test if it is possible to modify, and I couldn't change it. Look like @alfavpn is stuck, the user have to wait for the user who reserved 57038 to let it go back to the pool and that will be a while. It is possible that the user who reserved 57038 is using Soulseek as well.

The best @alfavpn can do is to reach out the developer of Soulseek and request to have customizable port number feature.

Share this post


Link to post

In soulseek you can change listening port under: Options->Change Listening Port

image.png.25a993572eb41a566852c1328b526fe9.png

Share this post


Link to post

Ok @NoiselessOwl, I didn't install it myself but did a quick search and found some guides where it looked like the listening port could be changed.

https://www.theloadguru.com/soulseek-configuration/
https://www.wikihow.com/Optimize-Soulseek-for-Downloading-Music

They are old but seemed estrange that they would have taken that option out.

Also notice that the port you mention is not the same the user showed interest in.

 

Share this post


Link to post
@ethralon Hot damn! How the hell I miss that!? Thanks for correcting me. That is odd UI choice to separate itself from Listening port section, that is nowhere I will see when the toolbar changes. I don't even notice the toolbar changes for every tab. I never encountered that UI choice until now. And to be fair, the listening port field looks it can be editable which I discovered it is not. Just why bothering to set it up just like that? Would it be beneficial have the field to be editable than separating itself?

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...