Jump to content
Not connected, Your IP: 3.236.232.99
curlybrian

Forcing AirVPN to use local PiHole DNS

Recommended Posts

I've found the exact opposite of what I'm trying to do all over the place. Here's my situation:

Comcast<==>Modem<==>Ubiquiti Router<==>Desktop Machine<==>Ubuntu VM on Desktop Machine

 

I use my Ubuntu VM to access less-savory websites that I don't really want infecting my Windows Desktop. I've got Eddie running on the Ubuntu VM without issue.

I just added a PiHole machine onto my network. It's sending all DNS requests through itself via DHCP instructions. The only part I can't get to run through the PiHole

is the Ubuntu VM once Eddie is connected. The VM will send all DNS requests through the PiHole when Eddie ISN'T running, but once Eddie is connected, all DNS

appears to go through the AirVPN servers.

 

How do I shunt this DNS traffic back onto my local network to have PiHole handle it and block malicious ads?

Share this post


Link to post

Did this ever get resolved? I am having the same problem. I have a Pi-Hole device sitting behind my router. Router is connected to AirVPN. Then on the local Windows PC's I have Eddie running for the VPN connection. With Eddie shut down, DNS requests successfully route to the Pi-Hole device. With Eddie running and connected, DNS requests to the Pi-Hole device time out. Here is the DNS page I configured in Eddie:

 

VhdSOLQ.jpg

 

When I run "ipconfig /all" I see the tunnel adapter has the Pi-Hole IP set for the DNS:

 

DNS Servers . . . . . . . . . . . : 192.168.1.224

 

Any ideas?

Share this post


Link to post

The only part I can't get to run through the PiHole

is the Ubuntu VM once Eddie is connected. The VM will send all DNS requests through the PiHole when Eddie ISN'T running, but once Eddie is connected, all DNS

appears to go through the AirVPN servers.

 

What's the content of /etc/resolv.conf in both cases? You should find your Pihole DNS server there.

Share this post


Link to post

I partially figured out how to make the Eddie client successfully work with Pi-Hole. Under the DNS tab, I had to uncheck "Ensure DNS Lock". Also checked "Ignore IPv6 DNS pushed by server" for good measure. Now hostnames resolve and when I go to ipleak.net I see the Eddie AirVPN IP under "Your IP Addresses" and the AirVPN IP obtained by my router under "DNS Address". Remember my Pi-Hole instance points to my router for it's DNS server entry.

 

ez7SnKB.jpg

 

I do say "partially" working because when Eddie is running I get random delays in the browser with the "Resolving hosts" message.Sometimes no delay and sometimes 5 - 10 seconds. If I shutdown Eddie and just have my normal network connection pointing to the Pi-Hole I don't get any delays. This tells me the issue is not with Pi-Hole or the router and VPN connection on the router as all three of those are common across both use cases. Seems to be an Eddie thing. Any ideas?

Share this post


Link to post

Don't think the DNS slowness was an Eddie or PiHole issue. I re-installed windows and problems with DNS resolving went away.

 

 

Side question: Any security issue for the PC -> PiHole -> Router connectivity I described in the previous posts?

Share this post


Link to post

Finaly update on the DNS issues I was seeing. Apparently a problem with the Dallas server or some combination of my ISP, hardware and the Dallas servers. This is per AirVPN support. Once I started connecting to non-Dallas servers the issues went away.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...