Jump to content
Not connected, Your IP: 3.227.2.246
Sign in to follow this  
peldx

ANSWERED Need help with LEDE - LuCI OpenVPN configuration

Recommended Posts

I always get this error no matter what:

Sat Dec  2 19:17:00 2017 daemon.err openvpn(LA_VPN)[4922]: Options error: specify only one of --tls-server, --tls-client, or --secret
Sat Dec  2 19:17:00 2017 daemon.warn openvpn(LA_VPN)[4922]: Use --help for more information.

Screenshots are attached, OpenVPN version is 2.4.4-2, is there anything I can do to fix this through LuCI?

Share this post


Link to post

Struggling to get this working too but this particular issue seems to be fixed by removing the line:

 

option secret 'shared-secret.key'

 

from:

 

/var/etc/openvpn-<your vpn>.conf

and

/etc/config/openvpn (under section for your vpn connection)

 

(requires ssh as I don't think it can be fixed under luci)

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...