Jump to content
Not connected, Your IP: 18.215.161.19
Sign in to follow this  
bitcoinivtu

AirVPN with DD-WRT and access point

Recommended Posts

Hello,

 

I have one problem. I am using airvpn on dd-wrt router and that works like a charm. I also setup some policies as you suggested in previous posts, and some machines are on VPN and some are not.

Now I have problem to setup access point. I do not want to use wireless repeater, because it is slow if many devices are connected...

 

I want to wire access point (not wiereless) and use the same SSID as main router has...

 

My configuration:

 

DSL model (10.10.2.1) <-LAN-------WAN-> DD-WRT router (10.10.3.1) <-LAN-------LAN-> access point [non-dd-wrt] (?.?.?.?)

 

 

DD-WRT 'sees' DSL modem (via routing), but DSL modem doesn't know for 10.10.3.1/24 network.

 

 

What I did:

1. Disabled DHCP on access point

2. Connected router's LAN with access point's LAN (not WAN)

3. Set access point's IP address to 10.10.3.2...

4. Set router's channel to 6

5. Set access point's channel to 11

6. Set access point's SSID to the same SSID as router has

and at the end I cannot establish IP anymore if I use access point's wireless network.

 

I tried to leave on DHCP on access point..., but in that case I do not have access to the internet but I can connect to the access point's wireless...

 

 

I suppose AirVPN's firewall commands are problem:

iptables -I FORWARD -i br0 -o tun1 -j ACCEPT
iptables -I FORWARD -i tun1 -o br0 -j ACCEPT
iptables -I INPUT -i tun1 -j REJECT
iptables -t nat -A POSTROUTING -o tun1 -j MASQUERADE

iptables -I FORWARD -s 10.10.2.0/24 -j ACCEPT
 

 

 

 

Can someone help me with this?

 

Thanks in advance.

Share this post


Link to post

I probably can't help you very much, but where did you do this and why? 

3. Set access point's IP address to 10.10.3.2...

 

I have a similar setup kinda.... modem -> non-ddwrt router (to broadcast wireless outside VPN) -> PFSENSE with AirVPN -> DDWRT Wireless Access Point.   

 

I set the local address to 192.168.1.2.  Does your AP router have these options?

Use DNSMasq for DHCP or DNS?

I disabled those and disabled the WAN.

 

 

Hope this helps somewhat...

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...