Jump to content
Not connected, Your IP: 100.24.113.182

Recommended Posts

macOS users have an option to screenshare into other computers using a feature called "Back To My Mac" (it is a part of iCloud). I've been trying to use this feature with one of my computers connected to AirVPN but I have not been successful. I was wondering if anybody knows if there are specific settings I need to enable/disable to get screensharing to work through Back To My Mac.

 

Thank you!

Share this post


Link to post

According to the ports document from Apple, you must open ports for vnc-server. Port tcp/5900 on the receiving end if I see it right.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

Thanks for that info. Unfortunately, I'm not too well-versed in how to set that up. If I wanted to screenshare (from an external network) into a Mac that has AirVPN client running, how would I go about making that happen? At the moment, with AirVPN default settings, I cannot connect via screenshare. But when I turn it off on the Mac, it works fine.

Share this post


Link to post

You need to forward port 5900 but it's already taken.

Alternatively, forward a random port and change the VNC port on your Mac.


» I am not an AirVPN team member. All opinions are my own and are not to be considered official. Only the AirVPN Staff account should be viewed as such.

» The forums is a place where you can ask questions to the community. You are not entitled to guaranteed answer times. Answer quality may vary, too. If you need professional support, please create tickets.

» If you're new, take some time to read LZ1's New User Guide to AirVPN. On questions, use the search function first. On errors, search for the error message instead.

» If you choose to create a new thread, keep in mind that we don't know your setup. Give info about it. Never forget the OpenVPN logs or, for Eddie, the support file (Logs > lifebelt icon).

» The community kindly asks you to not set up Tor exit relays when connected to AirVPN. Their IP addresses are subject to restrictions and these are relayed to all users of the affected servers.

 

» Furthermore, I propose that your paranoia is to be destroyed. If you overdo privacy, chances are you will be unique amond the mass again.

Share this post


Link to post

I was trying to get Screen Sharing back up and running over the internet with the vpn on and ran into this post, suggesting that I manually edit the Mac VNC port to accept a randomly generated port forward from AirVPN. On a whim, I decided to generate a port forward and entered the designated Mac VNC port of 5900 in the Local Port entry. I launched Screen Sharing and entered the VPN server's IP address (x) plus the generated public port (y) (vnc://xxx.xx.xxx.xx:yyyyy). I logged in and have Screen Sharing running just fine, though maybe at a little slower speed than the more direct method with the VPN disabled. I guess I'm asking, is there a reason not to do it this way? Am I compromising my security in some manner? I'm a bit of a noob with regards to VPNs so if I'm missing anything obvious, please advise.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...