Jump to content
Not connected, Your IP: 54.198.139.112
diver3923

Intermittant failure to resolve (DNS) www.airvpn.org with pfSense

Recommended Posts

I've recently started using AirVPN.  I am connecting to AirVPN with a pfSense router (v2.3 using the DNS resolver). 

 

The problem I'm having is an intermittent failure to resolve www.airvpn.org from any device on the network.  airvpn.org seems to be the only site impacted.  When I try to go to the AirVPN site it will timeout.  If I wait a minute or so, I am able to successfully load the AirVPN site.  The next time I tried to go to the site, it times out again....wait a minute than I can get in again.  This occurs over and over again.

 

When the site won't load, nslookup fails, but a DNS query from the pfSense box succeeds, showing a response from the AirVPN DNS server.  My pfSense is setup with two VLANS - one VLAN directing traffic to AirVPN and another VLAN that routes traffic out the standard WAN port (using OpenDNS DNS servers).  This problem only happens on the VPN VLAN, using the other (non-VPN) VLAN works correctly.  All of this makes me think the problem is somewhere in the pfSense configuration, but the fact that it only impacts airvpn.org when using the AirVPN DNS server makes me think I should start here.

 

I've tried several different servers (Metallah, Rasalas, Pollux, Azha, Acamar, Zosma) with no change in the issue.

 

If I try to go to the site using the IP address returned by nslookup I get a browser warning "Your connection is not secure".  To connect I have to create a security exception in the browser.  I don't get this error when I am able to browse the site using the name instead of the IP.

 

If it matters, I'm using pfBlockerNG on the pfSense box, but I have this problem even when pfBlockerNG is disabled or even uninstalled.

 

Has anyone ever seen this behavior or have any ideas how to resolve it?

Share this post


Link to post

I have found a workaround to this issue, but not a solution.  I can use airvpn.info without any issues.  I'm not sure what is causing the issue with airvpn.org, but since it is the only domain that doesn't work, I'll just use the .info option for now.

Share this post


Link to post
Guest

Same issue here, tried different servers (within UK) same issue occur. Also using pfsense 2.3. 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...