Jump to content
Not connected, Your IP: 54.236.35.159
journey6

accessing web server on local PC with portforwarding and airvpn

Recommended Posts

Hi

 

I have airvpn installed on PC whiich has web server running on port 80

I don't what to put on port forwarding page and what ip should I use to access the web server from outside world internet

 

EzYn6qz.png

 

 

what should I use in picture is it 1 or 2?

and does the other client from outside internet need to connect to airvpn too?

Share this post


Link to post

You should use the exit IP of the server you are currently connected to, in this case 213.152.161.133

(Tarazed) and the port you have forwarded, i.e. 12345.

 

So your server will be accessible on http://213.152.161.133:12345


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post

You should use the exit IP of the server you are currently connected to, in this case 213.152.161.133

(Tarazed) and the port you have forwarded, i.e. 12345.

 

So your server will be accessible on http://213.152.161.133:12345

 

I am aware that my exitIP has changed because I connected to other vpn server

but I still cannot browse the page of webserver running on my local pc

I put the exitIp:port <- port it the ranfomly generated

 

what is wrong I still cannot access it?

does the other client trying to access the webserver have to connect to airvpn too?

Share this post


Link to post

The port is not randomly generated, it is a port that you choose (in case it is available).

That port is not changed and it is bound to your account as long as you are on a Premium plan.

 

Users who want to access your port do not have to be connected to Air, only you.


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.

Share this post


Link to post

The port is not randomly generated, it is a port that you choose (in case it is available).

That port is not changed and it is bound to your account as long as you are on a Premium plan.

 

Users who want to access your port do not have to be connected to Air, only you.

 

I choose a local port but the remote port is generated randomly once then it is fixed

Share this post


Link to post

 

The port is not randomly generated, it is a port that you choose (in case it is available).

That port is not changed and it is bound to your account as long as you are on a Premium plan.

 

Users who want to access your port do not have to be connected to Air, only you.

 

I choose a local port but the remote port is generated randomly once then it is fixed

 

If you do not specify the remote port you want it is generated. Your issue baffles me a bit and quite confused but I wanna help if I can, perhaps try and change it so local port and remote port match and change the port in your web server settings too to match.

Share this post


Link to post

 

 

The port is not randomly generated, it is a port that you choose (in case it is available).

That port is not changed and it is bound to your account as long as you are on a Premium plan.

 

Users who want to access your port do not have to be connected to Air, only you.

 

I choose a local port but the remote port is generated randomly once then it is fixed

 

If you do not specify the remote port you want it is generated. Your issue baffles me a bit and quite confused but I wanna help if I can, perhaps try and change it so local port and remote port match and change the port in your web server settings too to match.

 

Thank you it works now I changed web server port other than 80 and used same port for local and remote port for port forwarding. Although ddns doesn't work with some servers but it is okay at least solved the main issue

Share this post


Link to post

 

 

 

The port is not randomly generated, it is a port that you choose (in case it is available).

That port is not changed and it is bound to your account as long as you are on a Premium plan.

 

Users who want to access your port do not have to be connected to Air, only you.

 

I choose a local port but the remote port is generated randomly once then it is fixed

 

If you do not specify the remote port you want it is generated. Your issue baffles me a bit and quite confused but I wanna help if I can, perhaps try and change it so local port and remote port match and change the port in your web server settings too to match.

 

Thank you it works now I changed web server port other than 80 and used same port for local and remote port for port forwarding. Although ddns doesn't work with some servers but it is okay at least solved the main issue

 

Glad you managed to get it working.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...