Jump to content
Not connected, Your IP:

Network Lock: No private trackers and no TCP port

Recommended Posts

Hi all,


I've just started using eddie (windows) and I use Vuze as my bittorrent client. I have a binding to the interface responsible for TAP-Windows Adapter V9 for added security.


Two issues arise when Network Lock is active:


1) TCP port test fails with "Testing port 36391 ... Unable to test: Invalid port given, or test service failed. Another application may already be using this port.. (Error: Unexpected end of file from server).


2) All torrents from private trackers error out with the tracker status of "Error (Permission denied: connect) Even the ubuntu torrent falls back to DHT backup only. The only torrents that give an "OK" are public ones from places like kat


When Network Lock is not engaged (but binding is still in place) both problems go away. In fact, even the UDP port test passes more quickly.


Any advice would be greatly welcomed.


Thank you



P.S. I don't know if this makes a difference, but for completeness' sake, I am connected to Rana.





Share this post

Link to post
  • Incoming TCP/UDP listen port This is index number of the port to 'open' in your firewall or 'forward' in your router, if you go through any to the Internet. Azureus only uses one port for all torrents.
  • From a Tracker
  • Decentralized Tracking
  • Supplied by another peer
  • Added by a plugin
  • Incoming connection (If you disable this, your Vuze will not accept remote connections)
  • PublicIP Network
  • I2P Network see http://www.i2p.net or Wikipedia
  • The Onion Router (Tor) see http://tor.eff.org or Wikipedia




Could be more of a firewall or router problem according to vuze wiki.

Share this post

Link to post

Incoming TCP/UDP listen port This is index number of the port to 'open' in your firewall or 'forward' in your router, if you go through any to the Internet. Azureus only uses one port for all torrents.


Actually, this isn't true on two counts. One, I have always used different ports for udp and tcp with no issue... I always thought that was how it was supposed to be done (why else would there be two fields to fill in?) Also, every time you do a network lock, (as I understand it) the firewall rules are overwritten with its own. So, if you changed them to include specific ports, those rules would be ignored upon lock. (Correct me if I am wrong.)


No idea what is causing this... perhaps I'll try a reinstall of eddie.


Any other clues would be welcome.




Share this post

Link to post


I run the same vuse client and the VPN helper in vuse said every thing was ok  but my torrents stay yellow and i fail the nat/firewall test what i did to fix it was go to windows firewall ( with network lock enabled ) > allow app or feature > change settings > and allow vuse launcher on private and public , then D/L and seeded torrents go green. 

I dont know how to make this change permanent thats what i came here to find out, hope this helps

Share this post

Link to post

I just tried qBittorrent and got the same results so it seems this isn't specific to Vuze. The only change I did notice was a massive download speed improvement under qBittorrent (with network lock off, but bound to the correct network connection). Unfortunately, when I use qBittorrent, the upload speed stays at zero, thus killing my ratios.

Share this post

Link to post

I am stumped.


When I installed both torrent clients, as administator; I was asked by Win 7 to give them permission through Windows Firewall.

In Network Lock, I use "automatic".  


When I know I am going to be away for hours.  I will turn Eddie client off; then back on and turn on Network Lock.

I know if there is a disconnection, the clients will be turned off.


This happened once.


There are quirks in software so you might have to write your own rules in the Network Lock program.


I have seen one or two articles, in the forum. on writing your own firewall/Network Lock rules.


This writing of rules of programming Firewalls. is unknown to me.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image

  • Create New...