Jump to content
Not connected, Your IP: 3.81.28.94

Recommended Posts

Hello everyone.

I had a question for the forums today. Is it possible to run Eddie (or any other way to connect to AirVPN) on Tails OS? For those who do not know, Tails is a Linux based OS that is very secure and routes all connections through Tor. However, if I am not mistaken, since there is no VPN in that setup, the operator of the Tor relay node can see your actual IP, yes? So, is it possible to use AirVPN on Tails? I tried earlier but it gave me some sort of error when I tried to run the Eddie client's file.

 

Also, will using a VPN on Tails make me more secure? If so, what are the benefits of doing so?

Share this post


Link to post

 

sudo apt-get install openvpn

After that, what is the path to put the OVPN files in?

Should be installed in /etc/openvpn/ Honestly though, the client doesn't need the files anywhere specifically as when you connect via CLI, you tell the client where the file is and exactly which one to use.

Share this post


Link to post

 

 

sudo apt-get install openvpn

After that, what is the path to put the OVPN files in?

Should be installed in /etc/openvpn/ Honestly though, the client doesn't need the files anywhere specifically as when you connect via CLI, you tell the client where the file is and exactly which one to use.

Oh okay, how do I connect via the CLI?

Share this post


Link to post

 

 

 

sudo apt-get install openvpn

After that, what is the path to put the OVPN files in?

Should be installed in /etc/openvpn/ Honestly though, the client doesn't need the files anywhere specifically as when you connect via CLI, you tell the client where the file is and exactly which one to use.

Oh okay, how do I connect via the CLI?

Linux noob here!

 

I tried 'sudo apt-get install openvpn' then I get this:

 

Reading package lists... Done

Building dependency tree       

Reading state information... Done

E: Unable to locate package openvpn

 

Then when I try 'sudo openvpn foo.ovpn' I get:

 

sudo: openvpn: command not found

 

Any Ideas?

Share this post


Link to post

 

 

 

 

sudo apt-get install openvpn

After that, what is the path to put the OVPN files in?

Should be installed in /etc/openvpn/ Honestly though, the client doesn't need the files anywhere specifically as when you connect via CLI, you tell the client where the file is and exactly which one to use.

Oh okay, how do I connect via the CLI?

Linux noob here!

 

I tried 'sudo apt-get install openvpn' then I get this:

 

Reading package lists... Done

Building dependency tree       

Reading state information... Done

E: Unable to locate package openvpn

 

Then when I try 'sudo openvpn foo.ovpn' I get:

 

sudo: openvpn: command not found

 

Any Ideas?

I have the same problem.

Share this post


Link to post

Run sudo apt-get update && sudo apt-get install openvpn

 

You need to update the repository first. Also, TAILS allows you to run a root terminal to avoid having to sudo everything. I'd recommend using that instead.

Share this post


Link to post

Run sudo apt-get update && sudo apt-get install openvpn

 

You need to update the repository first. Also, TAILS allows you to run a root terminal to avoid having to sudo everything. I'd recommend using that instead.

I tried apt-get update. It gave me an error.

How do I run a tails root terminal?

Share this post


Link to post

The red root terminal, in the same Applications tab.

I managed to install the OpenVPN package, and I have all the necessary OVPN files.

But when I cd to the directory that the OpenVPN files are in and I run (from the root terminal)

 

sudo openvpn AirVPN_CA-Toronto-Ontario_Lesath_UDP-443.ovpn

 

It gives me an error. Here are my logs.

 

Mon Apr  4 20:01:19 2016 OpenVPN 2.3.4 i586-pc-linux-gnu [sSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [iPv6] built on Nov 19 2015

Mon Apr  4 20:01:19 2016 library versions: OpenSSL 1.0.1k 8 Jan 2015, LZO 2.08

Mon Apr  4 20:01:19 2016 Control Channel Authentication: tls-auth using INLINE static key file

Mon Apr  4 20:01:19 2016 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication

Mon Apr  4 20:01:19 2016 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication

Mon Apr  4 20:01:19 2016 Socket Buffers: R=[212992->131072] S=[212992->131072]

Mon Apr  4 20:01:19 2016 UDPv4 link local: [undef]

Mon Apr  4 20:01:19 2016 UDPv4 link remote: [AF_INET]184.75.221.2:443

Mon Apr  4 20:01:19 2016 write UDPv4: Operation not permitted (code=1)

Mon Apr  4 20:01:21 2016 write UDPv4: Operation not permitted (code=1)

Mon Apr  4 20:01:25 2016 write UDPv4: Operation not permitted (code=1)

Mon Apr  4 20:01:33 2016 write UDPv4: Operation not permitted (code=1)

 

Share this post


Link to post

Okay. I tried again this time with a TCP OVPN file.

Tails does not work with UDP.

You have to read their project FAQ.

I cd'd to the directory that the file was in and I typed (from the root terminal)

 

sudo openvpn AirVPN_US-Miami_Yildun_TCP-443.ovpn

 

It gives me this error, here are the logs.

 

Tue Apr  5 19:51:53 2016 OpenVPN 2.3.4 i586-pc-linux-gnu [sSL (OpenSSL)] [LZO] [EPOLL] [PKCS11] [MH] [iPv6] built on Nov 19 2015
Tue Apr  5 19:51:53 2016 library versions: OpenSSL 1.0.1k 8 Jan 2015, LZO 2.08
Tue Apr  5 19:51:53 2016 Control Channel Authentication: tls-auth using INLINE static key file
Tue Apr  5 19:51:53 2016 Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Apr  5 19:51:53 2016 Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
Tue Apr  5 19:51:53 2016 Socket Buffers: R=[87380->131072] S=[16384->131072]
Tue Apr  5 19:51:53 2016 Attempting to establish TCP connection with [AF_INET]173.44.55.178:443 [nonblock]
Tue Apr  5 19:51:54 2016 TCP: connect to [AF_INET]173.44.55.178:443 failed, will try again in 5 seconds: Connection refused
Tue Apr  5 19:52:00 2016 TCP: connect to [AF_INET]173.44.55.178:443 failed, will try again in 5 seconds: Connection refused
Tue Apr  5 19:52:06 2016 TCP: connect to [AF_INET]173.44.55.178:443 failed, will try again in 5 seconds: Connection refused
Tue Apr  5 19:52:12 2016 TCP: connect to [AF_INET]173.44.55.178:443 failed, will try again in 5 seconds: Connection refused

 

I even tried two different OVPN files, same error.
 

Share this post


Link to post

After doing some reading, it may be because of the fact that by default, TAILS blocks all network traffic not going through TOR. There are ways to bypass the firewall apparently, but it is not an easy process. There's a clearnet browser that bypasses TOR, but the OS is preconfigured to allow it.

Share this post


Link to post

After doing some reading, it may be because of the fact that by default, TAILS blocks all network traffic not going through TOR. There are ways to bypass the firewall apparently, but it is not an easy process. There's a clearnet browser that bypasses TOR, but the OS is preconfigured to allow it.

So, I would be wasting my time trying to make VPN work on Tails?

Share this post


Link to post

Depends on how deep you wanna go down the rabbit hole. TAILS runs very compartmentalized now. It seeks to keep everything separated from everything else and unless you specifically input the proper rules, it routes all traffic through TOR and any traffic attempting to bypass that gets dropped.

Share this post


Link to post

Thanks for the all the info. One reason I thought it might be good to use a VPN with Tor is to protect yourself against snoopers when using public wifi hotspots, but does Talis on its own eliminate this possibility and protect yourself against potential hackers on the same wifi network?

Share this post


Link to post

As far as I understand its routing, unless the traffic comes in via the TOR tunnel or its allowed by default through an installed program, it blocks incoming and outgoing traffic. The short answer is yes and no. Is it still possible, almost always if the attacker is determined enough. Under most circumstances and with default settings, no.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...