Jump to content
Not connected, Your IP: 18.208.187.169
TheLastCheck

Google almost always in German by servers in the Netherlands

Recommended Posts

Once I got the Seychelles regional version of Google while using a Canadian server.

Share this post


Link to post

i'm a duckduckgo user and have the same odd language come up from time to time.

as my browser deletes all cookies on exiting, it can't remember the settings.

that's logical and i don't see it as a big problem.

Share this post


Link to post

Try going to google.com/ncr

It disables the country specific Google pages (for example google.ca and google.de, etc)

 

 

Sent from my iPhone using Tapatalk

Share this post


Link to post

I would add that; i never chosed a language for google. My default language is english. And sometimes when i'm over netherlands server i recive doich result. Simply wanted to ask why. Now the problem seems solved, thanks for the reply. ^^

 

If you are connected, let say in the Hong Kong IP Airvpn and when you go on google.com, redirect to google.com.hk with the chiness language, it's actually a good thing : It's mean google doesn't know who you are and set the engine base on your location IP.

 

Now if on the Hk IP, you are redirected to google germany, it's mean google identify you by cookie, which make the use of the VPN kind of useless since it's possible to identify you easily. On this case, deleted all history / cookie / cache, close the browser, changing IP is the solution for avoid to be track

 

Thanks for the sharing of https://www.google.com/ncr, didn't know this one

 

https://encrypted.google.com is indeed a solution, thanks for the remind

 

But before to use those links, always make check on google.com first look where it's going to redirect you (which country version of google...), if you care about your privacy.

Share this post


Link to post

This issue likely is due to their DNS settings since when using the UK servers I've ended up with belgium google(being redirected from google.com) so I wouldn't fret too much on it.

Share this post


Link to post

It 'happened today, start firefox without cookies etc. and google gives me results in German, I do not think is a cookie problem.
but as the saying EdensSpire probably  is a dns issue.
I will use just https://encrypted(dot)google(dot)com to temporarily solve the problem.
 
###update###
Fresh installation. Linux Mint Rosa.
Only to ensure that the problem is not the browser settings. The same problem is with youtube.b85f99cfccd3bfaf9fc9d4f9be6c8145.png
 
https://encrypted(dot)google(dot)com remains the best solution.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...