Jump to content
Not connected, Your IP: 54.236.35.159
J0hnny5

Installing AirVPN in Kali Linux - Need help please

Recommended Posts

Hi everyone,

I'm trying to install AirVPN linux in Kali

I searched online and on this forum, i found this useful post:

https://airvpn.org/topic/12509-kali/

 

but I'm still having problems installing.

 

I ran this first:as root:

apt-get -f install

then:

dpkg -i airvpn_linux_x86_debian.deb

but i'm getting an error:

 

Selecting previously unselected package airvpn.
(Reading database ... 322200 files and directories currently installed.)
Unpacking airvpn (from airvpn_linux_x86_debian.deb) ...
dpkg: dependency problems prevent configuration of airvpn:
 airvpn depends on libmono-system-runtime2.0-cil; however:
  Package libmono-system-runtime2.0-cil is not installed.
 airvpn depends on libmono-winforms2.0-cil; however:
  Package libmono-winforms2.0-cil is not installed.

dpkg: error processing airvpn (--install):
 dependency problems - leaving unconfigured
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Processing triggers for gnome-menus ...
Errors were encountered while processing:
 airvpn
 

Am I missing a command similar to this?

apt-get install libmono-winforms2.0-cil

 

I tried this first apt-get install mono-runtime but that did not work

thanks guys!

Share this post


Link to post

Just download the .deb file and use gdebi to install it. I just did it and it worked perfectly

Share this post


Link to post

Thanks for the answers, really appreciate it.

 

I have two Kali installs, one on a older Thinkpad laptop and the other is a VM on a different laptop . Same image used for both. I tried both suggestions above, and in the VM everything works great. Initially I only had one instance but after I ran across some issues, I decided to install Kali in a VM to see how I would fair.

 

Instructions I followed for the VM:

 

download .deb package
sudo apt-get install gdebi-core
sudo gdebi packageName.deb
cmd:
airvpn

********

However, on the laptop install, I cant get neither options (portable AirVPN client or gdebi .deb) to work.

 

The portable AirVPN is giving me an issue of memory usage. It launches ok  but when i select a VPN server and connect, I see the AirVPN client connecting but then the Memory usage goes from about 25% to upper 95% until the client crashes.

I put that to the side and tried the gdebi suggestion but gdebi was not recognized. I'm not a linux guru so i dont know why it would work in the VM but not on the Laptop install when i updated both, and the should be identical.

Instead of using gdebi i found dpkg worked ok for the .deb file except I'm getting two errors, and I'm hoping one of you Linux gurus might have a suggestion:

two errors, package libmono-system-runtime2.0-cil  and libmono-winforms2.0-ci is not installed.

I tried:

sudo apt-get -f install

(this installs some libmono packages but not the 2 I need)

and

sudo apt-get install libmono-winforms1.0-cil

error:  Unable to locate package libmono....

to recap, i'm trying to install the 32bit .deb package on a Laptop and I"m getting an error saying i'm missing two packages.

I looked online and found mono-3.2.8+dfsg but I'm not sure if this is what I need or what I should do next.

 

Any helps would be greatly appreciated

 

Share this post


Link to post

I had a similar problem with similar error messages on Ubuntu Mate. In the end the only thing that worked was going to the file browser to find the .deb, then right clicking and "Running as Admin". I know that's not the exact wording - but it's something like that. Maybe "Install as Admin"? I tried "sudo gdebi airvpn.deb" as well as a feww other commands, but it all gave me the same errors about dependencies. I'm not too familiar with Kali - but if there is a file explorer of some sort, maybe give that a try.

Share this post


Link to post

I'm getting the same error mentioned by the OP. A dependency failure. Mind that it occurs after attempting the mono-runtime solution (one that the staff was helpful enough to put up):

 

  airvpn depends on libmono-system-runtime2.0-cil; however:
  Package libmono-system-runtime2.0-cil is not installed.
  airvpn depends on libmono-winforms2.0-cil; however:...
  airvpn depends on libmono-corlib2.0-cil; however..

 

dependency correction via "sudo apt-get -f install" tells me that the dependencies will never be installed  A further look backwards into DDL hell produces happy terms like uninstallable ("Depends: libmono-system-runtime2.0-cil but it is not installable" etc.).

The Super-Cow suggests that I delete airvpn. I hold off on that and try to install gdebi::

 

 You might want to run 'apt-get -f install' to correct these:
 The following packages have unmet dependencies:
 airvpn : Depends: libmono-system-runtime2.0-cil but it is not installable...

 

Removal of airvpn allows for the installation of gdebi. Attempting to use gdebi, however produces this response:

 

  Error dependency is not satisfiable, libmono-system-runtime2.0-cil

 

The staff's solution was circa 2014, before the rolling-dist variant of kali thats currently in use. Not surprising that a new fix is in order.

 

Does anyone (especially staff ) care to say anything on the subject? I think it would be appropriate and helpful at this juncture, all things considered.

 

An aside @2Girls1CPU: I had a similar situation with Ubuntu, a manual setup was the only working solution of those I tried.

 

Share this post


Link to post

Same issue for me.

 

In my ubuntu AND my kali.

 

Portable AND .deb doesn't work.

 

I'm paying a service I cannot use... Like the network lock who still is not supported with VPN through TOR.

 

Is here any staff member please???

Share this post


Link to post
Guest

I have had this same issue for months. As far as I know for the time being there is nothing you can do. Your best options are to use airvpn through the terminal or use the fruho application.

 

For a while I was able to use the airvpn portable app, but even that doesn't work properly. It remains stuck on checking authorisation/checking route.

 

Using airvpn through terminal on kali will most likely result in a dns leak. I tried adding the recommended script to the ovpn config files but this does not solve the problem. For this reason, I would recommend using fruho, though it is not as good as the airvpn client, as you have to manually add each server, it does prevent dns leaks.

Share this post


Link to post

i have it working on the latest kali2.0 by doing the next steps :

 

 

(Before installing airvpn)

1- sudo apt-get upgrade

2- sudo apt-get dist-upgrade

3- sudo apt-get update

4- sudo apt-get install monodevelop

5- apt-get -f install

6- dpkg -i airvpn_linux_x64_debian.deb

( you will get the error at the end but it still works, but in case it doesn't do again the step (5- apt-get -f install) and step (6- dpkg -i airvpn_linux_x64_debian.deb)

 

This worked for me, hope i works for u guys, by the way if u want to avoid the Ipv6 leaks i recommend activating the network lock on Airvpn in the login screen u have the option.

 

Stay Safe, Stay in the Shadows, Be Free.

 

 

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image

×
×
  • Create New...