Jump to content
Not connected, Your IP:

Recommended Posts

Hey guys,


So I spent the last few hours or so trying to figure out this bug I was getting while starting AirVPN, and I wanted to share my results in case some poor soul comes across this seemingly obscure situation in the future. I'll do bullet points as to try not to talk too much:

  • AirVPN was working great
  • I installed Visual Studio 2013 Pro
  • AirVPN then stops working immediately after install
  • I notice there are a few new network adapters
  • MUCH MUCH later I found that by uninstalling a feature called Hyper-V, which (I'm only guessing) came with Visual Studio, did the "Driver installation failed" error stop and I was able to connect

So yeah... I spent some time digging through the source and then utilizing the newly installed VS to compile and debug the lines surrounding the error. Well, I had never heard of Hyper-V before and so all I wanted was AirVPN to work with my current adapter situation. I thought it was because one C# library function was returning adapter descriptions that AirVPN wasn't expecting. But even when I tried forcing it to one of the 10 available adapters (some of which were labelled TAP) yieled pretty much the same result every time. I now think it was due to the bridging that Hyper-V forced upon me, and since my issue is resolved I don't care to look into this further.


Tl;dr: Check if Hyper-V is installed in your Windows features. If so, uninstall it, reboot, and re-run AirVPN. If Hyper-V isn't installed try this: https://airvpn.org/topic/13126-driver-installation-failed/


Here's what my adapters looked like before uninstalling Hyper-V:



Here's an image that shows how to uninstall Hyper-V:


Share this post

Link to post

I have hyper v installed on every box I've ever installed Eddie on without issue. Uninstalling Hyper-V while I'm glad it worked in your case, isn't really a solution to recommend as most people who are going to have it installed not only know they have it installed, have installed cause they need it.


Hyper-V is part of the OS (It's the subsystem that lets you run virtual machines) not part of Visual Studio.  Sounds to me like you just needed to setup\define\configure a virtual network in hyper-v properly and maybe it would have equally resolved the issue.



Share this post

Link to post

I completely agree with you knighthawk. I just assumed it was Visual Studio as that was the only major change I made to my system that seemingly resulted in AirVPN no longer working. Now I have no idea how Hyper-V was installed unless it was an extra option in the install as I have a habit of installing *all* features when setting up software - even if I don't know what they are.


Thank you for your reply, btw. Maybe this will help someone that accidentally installed Hyper-V in the future like me.

Share this post

Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

  • Create New...