Jump to content
Not connected, Your IP: 3.209.80.87
Sign in to follow this  
tmimiTw

ANSWERED Trouble setting up airVPN on dd-wrt router

Recommended Posts

Looking to set up my Asus RT-N16 router to use AirVPN to appear to be in the US while travelling abroad.

 

It has v24-sp2 (mega) firmware installed.

 

I have attempted to follow the directions here, however there are several of these intructions that I cannot follow because they are not options presented to me.

 

Specifically, I cannot follow the directions below:

 

Set Hash Algorithm to "SHA1"

Select "Enable" Advanced Options

Select "Enable" LZO Compression

Select "Enable" NAT

Set Local IP Address to the router's local IP address found earlier.

Select TLS Cipher to "TLS-DHE-RSA-WITH-AES-256-CBC-SHA"

 

There is no option to select "advanced options" or any of the other things above.

 

Screen shots below.

 

What am I missing?

 

 

Share this post


Link to post

Thanks for your reply, but I haven't even gotten that far.

 

My dd-wrt build, that I believe is the most recent for my router, does not have anywhere (that I can find) to select adanced options for OpenVPN.  Therefore I cannot complete the instructions for installation.

 

I have the biggest, most recent dd-wrt build installed.  I have also tried the smaller, more specific "VPN" build with the same results...no option to select "advanced options"

Share this post


Link to post

Hi,

 

the version of dd-wrt you flashed might be the problem, I am not speaking of v24-sp2 (mega), which is ok, but of the release itself (date, router type).

 

Which router do you have? (the chipset is the important information to give: Broadcom or another).

From where did you download your version of dd-wrt? (give me the link).

With dd-wrt the best advice is: do not follow what is indicated on the router database regarding which version you should use for your router, it is outdated.

Share this post


Link to post

then yes this is the problem, if you look at the release date of the file you see 2010-08-09, 4 years ago...

A lot of development and security fixes have been done since then.

 

There is a wiki page for your router, where you can find more information: http://dd-wrt.com/wiki/index.php/Asus_RT-N16

So your router has a CPU Broadcom 4716 and it requires the K26 Firmware builds.

Here you can read that they recommand the build R18024 which has been released on 2011-12-20, 3 years ago...

Link with openvpn

ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2011/12-20-11-r18024/broadcom_K26/dd-wrt.v24-18024_NEWD-2_K2.6_openvpn.bin

 

To be on the safe side (no brick possible and high stability, the recommanded build is mentionned on the forum:

http://www.dd-wrt.com/phpBB2/viewtopic.php?t=52043

which R14929, released on 2010-08-15

Link with openvpn (you can also take the "big" one where openvpn is included, just check)

ftp://ftp.dd-wrt.com/others/eko/BrainSlayer-V24-preSP2/2010/08-12-10-r14929/broadcom_K26/dd-wrt.v24-14929_NEWD-2_K2.6_openvpn.bin

 

To be on the up-to-date side (latest binaries, new options, security fixes,...) but not so safe (brick possible, potential stability issues,...)

use the "Beta" versions

Now you have 2 choices: using the Brainslayer beta builds or the Kong beta builds,

they are 2 dd-wrt developers, Kong focuses on a smaller number of routers, he actually modifies Brainslayer builds to add some options and bring more stability taking into account the specific architecture of the router.

Yet he has recently announced that due to work and family responsabllities he is slowing down development, yet his builds are still good (but do not expect releases as often as before unless someone steps in to take over).

 

Brainslayer beta builds:

ftp://ftp.dd-wrt.com/betas/2014/

 

Kong beta builds:

http://www.desipro.de/ddwrt-ren/K26/

But always read the readme file http://www.desipro.de/ddwrt-ren/K26/ReadMe

(Builds based on r20780 or newer: Builds labeled kingkong nv32k are suitable for Asus RT-N16)

 

 

I personally use the Beta builds (Brainslayer and Kong), no brick and good stability.

 

Remember the following is my opinion, if you follow it I cannot in any way be held liable if you brick your router, loose data, or damage your hardware or what so ever. You are on your own and I am not an IT guru and will not be able to provide technical assistance.

 

This being said, if I had your router I would go with the kong build:

Before flashing the kong build it is advised to flash the corresponding Brainslayer one first:

So if I would like to flash the following

http://www.desipro.de/ddwrt-ren/K26/r22000++/kingkong-nv32k-broadcom.bin released on 2014-06-07

I would first flash

ftp://ftp.dd-wrt.com/betas/2014/06-23-2014-r24461/broadcom_K26/dd-wrt.v24-24461_NEWD-2_K2.6_mini.bin released on 2014-06-23

 

 

Try it if you wish and let me know how it went,

Good luck

 

 

 

 

 

Share this post


Link to post

Thanks, this looks to be exactly what I was looking for.  Since I'm currently out of the country with no good option to replace the router in the event that I brick it, I'll go with the "safe" option.

 

I'll let you know how it goes.

Share this post


Link to post

Mr. Hdafdnmu6h4wdtezjqikdfmdno,

 

Thank you very much. I installed the R10824 build that you suggested and everything worked as it should.

 

I did have to turn off Windows Firewall to get my PC connected, but my Roku3 connects just fine and can access all of my U.S. Based content (which was really my goal anyway).

 

Many thanks, cheers to you.

Share this post


Link to post

Great that it solved your Problem!

You could then mark this topic as "answered" so that other people with the same issue find it.

Share this post


Link to post

Hi there,

 

I know this is an old post, but I found it via google, so I figure maybe others have the same issue. I have the latest Brainslayer build - the mega version build 14929 for my Linksys WRT600N, but I still don't have access to any of those advanced options... I am missing quite a few of those options and I cannot get the VPN working on the router.

 

Maybe there is a newer version that I do not know about that works - but I remember reading on the peacock thread on DD-WRT that build 14929 is the most stable and recommended.

 

Any help is greatly appreciated. Thanks!

Share this post


Link to post

Hi there,

 

I know this is an old post, but I found it via google, so I figure maybe others have the same issue. I have the latest Brainslayer build - the mega version build 14929 for my Linksys WRT600N, but I still don't have access to any of those advanced options... I am missing quite a few of those options and I cannot get the VPN working on the router.

 

Maybe there is a newer version that I do not know about that works - but I remember reading on the peacock thread on DD-WRT that build 14929 is the most stable and recommended.

 

Any help is greatly appreciated. Thanks!

 

For anyone looking for this in the future - I just needed to update to a newer version of dd-wrt. Here is the forum post with a link to the latest update: http://www.dd-wrt.com/phpBB2/viewtopic.php?p=955090

 

If you don't want to visit that or the link is broken, here is a direct link: ftp://ftp.dd-wrt.com/betas/2015/03-05-2015-r26446/broadcom/dd-wrt.v24_mega_wrt600n.bin

 

This build includes all the options needed to set up the VPN pass-through in your router.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...