Jump to content
Not connected, Your IP: 34.231.247.139
Sign in to follow this  
bubbelbabbel

Slow connection using vpn

Recommended Posts

Just to add to my post #23...I only experienced speed problems with my Windows 7 -X64 desktop using the default protocol. On my Windows 8.1 laptop running concurrently, I had no speed issues using the default AirVPN UDP protocol.  Go figure!

Share this post


Link to post

Just to add to my post #23...I only experienced speed problems with my Windows 7 -X64 desktop using the default protocol. On my Windows 8.1 laptop running concurrently, I had no speed issues using the default AirVPN UDP protocol.  Go figure!

That is very strange.  Could there be some throttling being done by Windows 7?  I would expect the behavior to be independent of the OS, as openvpn would be sending the same traffic either way.

 

I only have Win7 systems at this time.  Perhaps I'll get a Linux laptop set up and try some experiments one of these days...

Share this post


Link to post

If you're using the AirVPN client, try going into Preferences, Protocols, and try using SSL Tunnel Port 443 (bottom right). 

 That gives me never ending  "restart in 3 sec." loop to all servers..

Share this post


Link to post

 

If you're using the AirVPN client, try going into Preferences, Protocols, and try using SSL Tunnel Port 443 (bottom right). 

 That gives me never ending  "restart in 3 sec." loop to all servers..

That is something it should not be doing.  Perhaps support could help out if that's the case.

Share this post


Link to post

 

 

I'll answer my own request.. 

 

I figured out why it's so damn slow.. It's all OpenVPN's fault!

The latest version of the TAP driver they bundle with the software, (which also AirVPN bundle with your software), does not work like it should, and completely messes up when trying to transfer anything.

I installed a previous version of the TAP driver, and boom, all is back to normal with proper speeds.

 

Hello!

 

Thank you for the report. Some documentation about the bug? Ways to reproduce it?

 

Kind regards

 

As far as I can tell it's like this with every win7x64 or win server2012 x64 I've tried it on. You can attempt to install the latest TAP drivers, I think this one is the latest: http://swupdate.openvpn.org/community/releases/tap-windows-9.21.0.exe

Remember to choose "uninstall the driver" when you remove the old TAP-Windows network card. I've tried installing the latest openVPN (http://swupdate.openvpn.org/community/releases/openvpn-install-2.3.4-I603-x86_64.exe) on 2 computers that has not had any vpn software installed before, and both show the same problems.

 

im new here and wondering why on my mac speed was good but not on windows

and this solve my problem on win7 64bit -previously using pia- not sure if this related.

first uninstall old driver TAP-Windows Provider V9

reboot and install latest tap-windows-9.21.0.exe from link above just works, good speed now.

Share this post


Link to post

Glad to see that worked for you.  Appears Comcast is doing the same thing as Verizon FiOS.  It's too bad the major ISPs are resorting to tactics like this in an attempt to control content.  But thanks to AirVPN's flexibility, we are able to get around it with SSL on top of OpenVPN.

 

On comcast as well - have noticed over the last week or two, the VPN slowing down significantly (was running vanilla UDP 443).  Based on this thread, ran some numbers as below.  Provided both speedtest.net numbers (understand caveats of those numbers) and the airvpn test data.  

 

In summary, UDP 443 about half as slow as SSL on top of OpenVPN for download, upload is always ~100%.  To my non-trained eye, this is pretty good proof for significant shaping, and like I said, new at least to my area.

 

Not showing data, but similar trends on another Windows 7 laptop with 2.7 client, a linux laptop with no client and just openvpn, and a chromebook with openvpn only.   

 

Environment
I 2014.11.29 19:52:37 - AirVPN client version: 2.4, System: Windows, Architecture: x64
. 2014.11.29 19:52:37 - Reading options from C:\Users\REMOVED\AppData\Local\AirVPN\AirVPN.xml
. 2014.11.29 19:52:39 - Data Path: C:\Users\REMOVED\AppData\Local\AirVPN
. 2014.11.29 19:52:39 - App Path: C:\Program Files\AirVPN
. 2014.11.29 19:52:39 - Executable Path: C:\Program Files\AirVPN\AirVPN.exe
. 2014.11.29 19:52:39 - Command line arguments: path="home"
. 2014.11.29 19:52:41 - Operating System: Microsoft Windows NT 6.1.7601 Service Pack 1
I 2014.11.29 19:52:46 - OpenVPN Driver - TAP-Windows Adapter V9
I 2014.11.29 19:52:46 - OpenVPN - Version: OpenVPN 2.3.4 (C:\Program Files\AirVPN\openvpn.exe)
I 2014.11.29 19:52:46 - SSH - Version: plink 0.63 (C:\Program Files\AirVPN\plink.exe)
I 2014.11.29 19:52:46 - SSL - Version: stunnel 4.56 (C:\Program Files\AirVPN\stunnel.exe)
I 2014.11.29 19:52:46 - IPV6: Available
 
! 2014.11.29 20:15:49 - Connecting to Pollux (United States, Jacksonville, Florida)
. 2014.11.29 20:15:49 - OpenVPN > OpenVPN 2.3.4 x86_64-w64-mingw32 [sSL (OpenSSL)] [LZO] [iPv6] built on Aug 18 2014
. 2014.11.29 20:15:49 - OpenVPN > library versions: OpenSSL 1.0.1i 6 Aug 2014, LZO 2.05
. 2014.11.29 20:15:55 - OpenVPN > TAP-Windows Driver Version 9.9
 
Comcast 30/6
Pollux load during these tests 7-20%, 20-35 ms latency, 35-42 users
 
No VPN
Speedtest.net
ping 20 ms
Download/upload speed 30.11/6.08 Mbps
 
Pollux (UDP 443)
Speedtest.net
ping 35
Download/upload speed 14.31/5.65  Mbps
 
Airvpn
Down: 15.804 Mbit/s Out, 6.725 Mbit/s In (42%), 20MB - Up: 5.522 Mbit/s Out, 5.292 Mbit/s In (95%), 20MB - Date: Sun, 30 Nov 2014 01:39:59 GMT - Buffers: 20MB/20MB - Laps: 3, Time: 146.16 secs
 
Pollux (TCP 443)
Speedtest.net
ping 38
Download/upload speed 13.14/5.34 Mbps
 
Airvpn
Down: 16.281 Mbit/s Out, 12.527 Mbit/s In (76%), 20MB - Up: 4.905 Mbit/s Out, 4.678 Mbit/s In (95%), 20MB - Date: Sun, 30 Nov 2014 01:45:55 GMT - Buffers: 20MB/20MB - Laps: 3, Time: 141.33 secs
 
Pollux (UDP 80)
Speedtest.net
ping 35
Download/upload speed 17.56/5.65  Mbps
 
Airvpn
Down: 14.710 Mbit/s Out, 5.515 Mbit/s In (37%), 20MB - Up: 5.101 Mbit/s Out, 4.870 Mbit/s In (95%), 20MB - Date: Sun, 30 Nov 2014 02:19:35 GMT - Buffers: 20MB/20MB - Laps: 3, Time: 164.28 secs
 
Pollux (TCP 80)
Speedtest.net
ping 36
Download/upload speed 14.99/5.81  Mbps
 
Airvpn
Down: 18.473 Mbit/s Out, 11.453 Mbit/s In (61%), 20MB - Up: 5.137 Mbit/s Out, 4.801 Mbit/s In (93%), 20MB - Date: Sun, 30 Nov 2014 02:25:16 GMT - Buffers: 20MB/20MB - Laps: 3, Time: 137.71 secs
 
Pollux (SSH 80)
Speedtest.net
ping 40
Download/upload speed 17.13/5.28 Mbps
 
Airvpn
Down: 13.961 Mbit/s Out, 10.816 Mbit/s In (77%), 20MB - Up: 4.728 Mbit/s Out, 4.761 Mbit/s In (100%), 20MB - Date: Sun, 30 Nov 2014 01:52:42 GMT - Buffers: 20MB/20MB - Laps: 3, Time: 152.98 secs
 
 
Pollux (SSL 443)
Speedtest.net
ping 34
Download/upload speed 18.78/5.47 Mbps
 
Airvpn
Down: 13.379 Mbit/s Out, 12.581 Mbit/s In (94%), 20MB - Up: 4.854 Mbit/s Out, 4.857 Mbit/s In (100%), 20MB - Date: Sun, 30 Nov 2014 02:08:47 GMT - Buffers: 20MB/20MB - Laps: 3, Time: 143.51 secs
 
 
To compare again and confirm with additional laps -
 
Pollux (UDP 443)
Down: 15.179 Mbit/s Out, 7.205 Mbit/s In (47%), 20MB - Up: 5.106 Mbit/s Out, 4.413 Mbit/s In (86%), 20MB - Date: Sun, 30 Nov 2014 02:31:07 GMT - Buffers: 20MB/20MB - Laps: 10, Time: 526.75 secs
 
Pollux (SSL 443)
Down: 14.513 Mbit/s Out, 11.730 Mbit/s In (80%), 20MB - Up: 4.782 Mbit/s Out, 4.853 Mbit/s In (101%), 20MB - Date: Sun, 30 Nov 2014 02:42:20 GMT - Buffers: 20MB/20MB - Laps: 10, Time: 471.32 secs

Share this post


Link to post

I know im replying to an old post but I just changed from another VPN provider beause all I could get is 5mbps. Still having the same problem with airvpn on a fresh windows 7 install. I gave up and loaded a ubuntu vm installed the client and works perfect maxing out my connection. I turned on vpn lock and to my suprise 5mbps max. Went back to windows turned off network lock and dns leak protection and once again maxing my connection. Is there something I'm missing or not doing right? I leave the computer on all the time and really want network lock to work without killing the speed.

Share this post


Link to post

Hello All,

I am new here as well. I have a 150Mbps Download and 15Mbps Upload internet plan, I achieve speeds above that without VPN. I can achieve 180Mbps Download and 17Mbps Upload. Since I have been using AirVPN I have been able to achieve maybe half that at my best peak and average much lower speeds. I will give that SSL Tunnel 443 option a shot that was mentioned above. Any and all help is welcomed. Looking to set up for optimal speed

Share this post


Link to post

New here as well, without a VPN I was getting about 30 down/5 up, but now the most I'm getting is 6mb/s down. I tried the SSL tunnel suggestion above but found no difference/maybe 1mb/s faster.

Share this post


Link to post

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
  • Security Check
    Play CAPTCHA Audio
    Refresh Image
Sign in to follow this  

×
×
  • Create New...