Jump to content


Photo
- - - - -

uTorrent - error 404 while downloading URL


  • Please log in to reply
11 replies to this topic

#1 Mikester

Mikester

    Member

  • Members
  • PipPip
  • 10 posts

Posted 09 February 2013 - 04:12 PM

Hi,

I just signed up and I'm trying to configure uTorrent. I went to the member area and configured port forwarding (port 42373, TCP and UDP). I set the port used for incoming connections to 42373 as well, and unchecked "Enable uPNP..."

When I try to add a torrent URL, it gives me 'HTTP Error 404 while downloading URL.'

If I turn off the VPN, then I am able to start the torrent - no error.

I've read a bit around (FAQ and forum) and I don't think I missed anything, but obviously, I must have. :)

Setup: Windows Home Server v1. I installed OpenVPN and copied the AirVPN configuration files as indicated in the instructions - that seems to work fine. I started with two servers and they both started without errors. I'm able to visit web sites, and "whatismyip.com" reports an IP address different from mine. Dnsleaktest.com is reporting a leak, however, but one problem at a time. :) (I'm currently slooowly downloading Comodo Firewall), so I'll address that once it's installed, replacing Windows Firewall.

Any ideas? I'm new to the whole VPN thing.

Thanks!

#2 athelstan

athelstan

    Member

  • Members
  • PipPip
  • 26 posts

Posted 09 February 2013 - 06:53 PM

Hi Mikester

Be very careful with Comodo Firewall. I can't speak to the current version, but in the past, it defaulted to blocking all traffic after installation. As your server is headless and you're relying on a remote connection, this would leave you locked out. See http://forums.comodo.com/help/how_can_i_start_comodo_firewall_to_allow_all_connections-t9496.0.html;msg68775#msg68775 .

You might consider instead doing one of the following:

Use the firewall on your router to block all outbound internet traffic from WHS except to the entry IP addresses of the Air severs you're using.

Use the method discussed in this thread https://airvpn.org/index.php?option=com_kunena&func=view&catid=3&id=6573&Itemid=142

To stop DNS leaks, manually configure your physical network adaptor https://airvpn.org/index.php?option=com_kunena&func=view&catid=2&id=7462&limit=6&limitstart=6&Itemid=142#7529

For your connectivity problem, you might test the VPN connection using a web browser to see if the problem is specific to uTorrent. You could also try disabling temporarily the Windows Firewall, and checking the OpenVPN log file to see if any errors occur during connection.

#3 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7339 posts

Posted 09 February 2013 - 07:11 PM

Hi,

I just signed up and I'm trying to configure uTorrent. I went to the member area and configured port forwarding (port 42373, TCP and UDP). I set the port used for incoming connections to 42373 as well, and unchecked "Enable uPNP..."

When I try to add a torrent URL, it gives me 'HTTP Error 404 while downloading URL.'



Hello!

Apparently the URL you're inserting in the torrent client points to a .torrent file which can't be located anymore by the destination server.

What if you try to access the URL from your browser (still while connected to a VPN server)?

Kind regards

#4 Mikester

Mikester

    Member

  • Members
  • PipPip
  • 10 posts

Posted 09 February 2013 - 07:29 PM

Hi,

I just signed up and I'm trying to configure uTorrent. I went to the member area and configured port forwarding (port 42373, TCP and UDP). I set the port used for incoming connections to 42373 as well, and unchecked "Enable uPNP..."

When I try to add a torrent URL, it gives me 'HTTP Error 404 while downloading URL.'



Hello!

Apparently the URL you're inserting in the torrent client points to a .torrent file which can't be located anymore by the destination server.

What if you try to access the URL from your browser (still while connected to a VPN server)?

Kind regards



I finally got it working, just as I got a notification of the two replies. :) Looks like some U.S.-related censorship and the torrent has been removed. I picked two servers located in the U.S. I grabbed the torrent file from my main computer, which is not running AirVPN. Pasted the URL on WHS and got the error. I could swear I had tried both servers earlier, but apparently not so... Next step: I did the search for the torrent from the browser in WHS, and it did not find anything. So I decided to test the other server (or I should say, to make sure I didn't pick the same server :)), did the search again from what I thought was the second server and got some results. Then put the URL in uTorrent and it worked. THEN I realized that the connection to the second server had actually failed, and I was doing this without the VPN (talk about having a bad day - lol!) Stopped the torrent, made sure the VPN connection was successful this time, restarted uTorrent and somehow it picked up where it had started.

I guess I'll have to look into overseas servers.

#5 Mikester

Mikester

    Member

  • Members
  • PipPip
  • 10 posts

Posted 09 February 2013 - 07:35 PM

Hi Mikester

Be very careful with Comodo Firewall. I can't speak to the current version, but in the past, it defaulted to blocking all traffic after installation. As your server is headless and you're relying on a remote connection, this would leave you locked out. See http://forums.comodo.com/help/how_can_i_start_comodo_firewall_to_allow_all_connections-t9496.0.html;msg68775#msg68775 .

You might consider instead doing one of the following:

Use the firewall on your router to block all outbound internet traffic from WHS except to the entry IP addresses of the Air severs you're using.

Use the method discussed in this thread https://airvpn.org/index.php?option=com_kunena&func=view&catid=3&id=6573&Itemid=142

To stop DNS leaks, manually configure your physical network adaptor https://airvpn.org/index.php?option=com_kunena&func=view&catid=2&id=7462&limit=6&limitstart=6&Itemid=142#7529

For your connectivity problem, you might test the VPN connection using a web browser to see if the problem is specific to uTorrent. You could also try disabling temporarily the Windows Firewall, and checking the OpenVPN log file to see if any errors occur during connection.



Turns out Comodo Firewall is not compatible with WHS v1 - it wouldn't even install, just a message saying the platform is not supported (that's better than it installing and screwing things up!) I'll look into my router's configuration to block the outbound traffic - thanks for the tip.

I've managed to stop the DNS leaks by using a little utility from dnsleaktest.com located at: http://www.dnsleaktest.com/how-to-fix-a-dns-leak.php Now the test reports only U.S. addresses, and checkmytorrentip is not reporting my true address either. Do you think this is sufficient, or should I go ahead with the manual network adapter configuration instructions you linked to?

Thanks!

#6 athelstan

athelstan

    Member

  • Members
  • PipPip
  • 26 posts

Posted 09 February 2013 - 09:51 PM

Hi Mikester

The dnsleaktest.com utility you installed is more convenient if you want to be able to connect to the internet sometimes from WHS without using the VPN. If you don't, then manual configuration of your network adaptor's DNS servers is simpler. Both methods are basically doing the same thing, so there's no gain from using both at the same time.

The leakage of other traffic can occur if the VPN connection fails. Either of the two blocking solutions I suggested should work; using the second option - manually configuring the default gateway and adding static routes - has the convenience of allowing all the VPN configuration to be done on your server.

#7 Mikester

Mikester

    Member

  • Members
  • PipPip
  • 10 posts

Posted 10 February 2013 - 02:44 PM

Hmmm yeah that's not going too well for me. Unless I'm reading it wrong, my router (D-Link DIR-655) allows me to block access to a range of IPs, instead of "allow" access to a range of IPs. I kind of got lost reading those threads.

I've added this to the "Custom List" of allowed IPs for uTorrent in the Windows Firewall exceptions:

10.4.0.0/16,10.4.0.0/255.255.0.0

However if I stop the AirVPN connection, uTorrent is able to reconnect (I assume using my normal IP) and keep going as if nothing happened.

#8 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7339 posts

Posted 10 February 2013 - 02:51 PM

Hmmm yeah that's not going too well for me. Unless I'm reading it wrong, my router (D-Link DIR-655) allows me to block access to a range of IPs, instead of "allow" access to a range of IPs. I kind of got lost reading those threads.

I've added this to the "Custom List" of allowed IPs for uTorrent in the Windows Firewall exceptions:

10.4.0.0/16,10.4.0.0/255.255.0.0

However if I stop the AirVPN connection, uTorrent is able to reconnect (I assume using my normal IP) and keep going as if nothing happened.



Hello!

There's something wrong, if the allowed destination IP addresses for uTorrent are in the range 10.4.0.0/16 (10.4.0.0 / 255.255.0.0 is just the same with a different notation) uTorrent should NEVER work, regardless of your computer being connected to a VPN server or not, because that IP range is not public. You might like to install Comodo firewall (free edition is just fine).

Kind regards

#9 Mikester

Mikester

    Member

  • Members
  • PipPip
  • 10 posts

Posted 10 February 2013 - 05:24 PM

Still no luck. I tried adding a rule for the port itself and that didn't even work. Very, very odd.

Unfortunately Comodo Firewall is not compatible with WHS v1.

#10 athelstan

athelstan

    Member

  • Members
  • PipPip
  • 26 posts

Posted 10 February 2013 - 07:49 PM

Hi Mikester

I think we already established that you can't use Comodo in this setup.

I'm sorry for muddying the water by suggesting multiple options. The following is the configuration I use on WHS, it doesn't leak, and I've tested that it can be set up safely using only a remote connection from your LAN. You might want to work your way through it before making any changes.

Remove the Windows Firewall exception you just added for 10.4.0.0/16 and check that you can still connect to AirVPN and use uTorrent. Stop uTorrent and stop your AirVPN connection. Disable the utility you downloaded from dnsleaktest. On your router, make sure that any port forwarding you set up in the past for uTorrent is disabled.

Open a Command Prompt on WHS and type ipconfig /all, then Enter (note there is space before /all). Make a note of the local IP address of WHS (192.168.0.???).

Go to Start>Control Panel>Network Connections and double-click it to open the Network Connections folder. You should see two connections listed, one for your LAN and one (disconnected) for OpenVPN's TAP-Windows Adapter V9. Right-click and rename the TAP adapter to AirVPN to avoid confusion.

Double-click the LAN connection then choose Properties. Choose Internet Protocol (TCP/IP) then Properties.
Click Use the following IP address, for IP address enter WHS's IP address which you noted earlier. Be very careful not to make any typos in this dialog. The subnet mask should set itself automatically to 255.255.255.0. For Default gateway, again enter WHS's IP address. Click Use the following DNS server addresses and enter 10.4.0.1 and 10.5.0.1. OK and Close out of these dialogs. As you do this, your remote desktop connection will drop momentarily, but will reconnect.

At this stage, you should NOT be able to connect to AirVPN. Check that this is the case. Use Notepad to open the .ovpn files for the Air servers you plan to use, and make a note of the entry IP address of each server (remote a.b.c.d) ignoring the port number.

At the Command prompt, enter the following command
route add -p IPaddress mask 255.255.255.255 192.168.0.1
where IPaddress is the Air server entry address and 192.168.0.1 is assumed to be the IP address of your D-Link router. Repeat this command with the IPaddress of each Air server you want to use. The -p in the route add command is important. To view your routing table, use the command route print . To delete a route, use the command route delete IPaddress .

You should now be able to connect to your chosen AirVPN servers and use uTorrent, confirm this. Visit dnsleaktest and whatsmytorrentip and make sure they show what you expect. Fire up a torrent, then disconnect from AirVPN and confirm that the torrent traffic stops.

With this configuration, WHS will not be able to connect to the internet unless you are connected to AirVPN. Remember to add a new route if you want to use a new Air server.

#11 Mikester

Mikester

    Member

  • Members
  • PipPip
  • 10 posts

Posted 10 February 2013 - 11:03 PM

athelstan, you rock! Finally got this baby to purr. WHS now doesn't connect to anything if AirVPN is disconnected - web browsing doesn't work, and uTorrent stops dead until I restart the service. Dnsleaktest is reporting German addresses.

Thank you so much for the detailed instructions - much appreciated! I've saving those in case I ever need to do it again. I'm sure this will also be helpful to someone else at some point.

#12 athelstan

athelstan

    Member

  • Members
  • PipPip
  • 26 posts

Posted 11 February 2013 - 01:19 PM

You're welcome, Mikester. I'm glad to hear it's all working for you.





Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 13521 - BW: 42586 Mbit/sYour IP: 54.81.254.212Guest Access.