Jump to content


Photo

[MacOS mojave, 10.14.1, latest] NO Network anymore without Eddie connected

macos mojave no network without eddie

  • Please log in to reply
5 replies to this topic

#1 idefix

idefix

    Newbie

  • Members
  • Pip
  • 4 posts

Posted 19 November 2018 - 05:22 PM

Hi everybody,

 

I have a strange problem: I can't access any site with my cable provider until I start a VPN using Eddie :-(

 

I usually use Eddie permanently but in some cases (system diagnostics) I have to switch off VPN and deactivate network lock.

 

It seems to lock the network even when closed now for me :-(

 

restarted a few times and tried different browsers and email.

 

hope you can help

 

thank you very much!

 

 

best tom



#2 giganerd

giganerd

    I shall have no title

  • Members2
  • PipPipPip
  • 2687 posts
  • LocationGermany

Posted 20 November 2018 - 10:30 AM

Update your client, if necessary.


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs helps us read your thread.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

Instead of writing me a personal mail, consider contacting me via XMPP at gigan3rd@xmpp.airvpn.org or join the lounge@conference.xmpp.airvpn.org. I might read the mail too late whereas I'm always available on XMPP ;)


#3 tea420

tea420

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 21 January 2019 - 08:36 PM

I got the same problem. i got Mac OS Mojave 10.14.2 and the newest  Eddie client. what now? 
I really don't like to re-install all the time my OS completly from a bootable os sierra usb stick, because a reinstall from a backup has not solved the problem. the problem occours still after an re installation from a backup. now i cant use your services. Or is there maybe a way to use the vpn service without the client?



#4 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7801 posts

Posted 22 January 2019 - 11:52 AM

I got the same problem. i got Mac OS Mojave 10.14.2 and the newest  Eddie client. what now? 
I really don't like to re-install all the time my OS completly from a bootable os sierra usb stick, because a reinstall from a backup has not solved the problem. the problem occours still after an re installation from a backup. now i cant use your services. Or is there maybe a way to use the vpn service without the client?

 

 

Hello!

 

You can run Tunnnelbick for example, instructions are included in the Mac page https://airvpn.org/macosx

 

If you close Eddie improperly, it will have no chance to restore system settings, but it will do it at the first proper shut down. If something goes wrong, check your DNS settings: it's the most common cause of apparent loss of connectivity and it can be fixed in a few seconds. You don't need to reinstall the whole system to set DNS properly.

 

Kind regards



#5 Monotremata

Monotremata

    Advanced Member

  • Members2
  • PipPipPip
  • 68 posts

Posted 30 January 2019 - 06:32 AM

Usually Eddie crashing will do this.. In this case its not the clients fault though. I was connected to Phoenix when I read the thread, but Im disconnected now and Eddie is closed and Im replying from my actual ISP connection. Just opened a couple other sites to make sure it was still on. Running Mojave as well, 10.14.3 as of the update yesterday, and its worked fine since I installed the OS last month. Ive been running the latest beta of Eddie since it came out.

 

The only issue Im having with it on 10.14 is it keeps setting off Lulu the network monitor trying to connect to one of the Air servers constantly. I shouldn't be getting a notification as I allowed the Eddie.app any outgoing connection. Lulu is an open source Little Snitch alternative btw.. 

 

Try deleting the preferences in the ~/.airvpn folder. Mojave has a handy shortcut now to show you the hidden directories. Open your home folder, hit CMD+Shift+period, delete the now visible .airvpn folder and start from scratch. Occasionally the prefs just go bad. This has fixed 99% of any issues Ive had with Eddie.



#6 draya

draya

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 07 February 2019 - 08:28 AM

Hi, I've deleted the hidden folder, restarted, still unable to connect without running Eddie. Running latest everything. I have 2 user accounts on the machine that run Eddie when I log into them (I usually disconnect Eddie in one account, before connecting in the other), so I deleted the hidden folders on both accounts and then restarted and ran Eddie on both accounts. Still unable to connect without running Eddie. Any additional help with fixing this issue would be greatly appreciated. While I do mostly connect via AirVPN, there are times I'd like to connect via my ISP directly. Thank you so much!







Similar Topics Collapse


2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

Servers online. Online Sessions: 13670 - BW: 51201 Mbit/sYour IP: 34.229.175.129Guest Access.