Jump to content


Photo

Ubuntu - Tunnel direct not found?


  • Please log in to reply
8 replies to this topic

#1 adamcor

adamcor

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 01 August 2018 - 03:43 AM

I successfully installed Eddie on my Debian 16.04 VPS but unfortunately whenever I attempt to connect to a server I immediately get an error saying Tunnel direct not found and can’t be installed.
I’ve been looking online and can’t seem to find anyone else running into this problem. Does anyone have any suggestions?
Thanks!

#2 nick75

nick75

    Advanced Member

  • Members
  • PipPipPip
  • 159 posts

Posted 01 August 2018 - 05:40 PM

Hello,

 

Download a config file and try and connect to a server using openvpn directly. If you still have the same error, it means that the tun/tap driver has been disabled.

Then ask your VPS provider to activate it if possible as some do disable it for some reason.



#3 adamcor

adamcor

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 02 August 2018 - 02:35 AM

Hello,
 
Download a config file and try and connect to a server using openvpn directly. If you still have the same error, it means that the tun/tap driver has been disabled.
Then ask your VPS provider to activate it if possible as some do disable it for some reason.


You are correct. I messaged them and they did have the tun/tap driver disabled and have now enabled it. Unfortunately, I continued messing with Eddie and now the GUI won’t even come up for me. I’ve tried uninstalling it with sudo apt-get remove eddie-ui and then reinstalling it. But still nothing pops up. I’m getting close to doing a full os reinstall at this point.
Any ideas?

#4 nick75

nick75

    Advanced Member

  • Members
  • PipPipPip
  • 159 posts

Posted 02 August 2018 - 06:22 PM

Type this in a terminal and post its output:

eddie-ui


#5 adamcor

adamcor

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 02 August 2018 - 10:24 PM


 

Type this in a terminal and post its output:

eddie-ui

Here is the output. I've actually went ahead and completely reinstalled my VPS with Debian 8 64bit and I'm having the exact same problem as Ubuntu. Seems like maybe it's trying to install a windows version instead of linux?

~$ . 2018.08.02 18:18:29 - Eddie version: 2.15.2 / linux_x64, System: Linux, Name: Debian GNU/Linux 9 \n \l, Version: Linux kimbo 2.6.32-042stab132.1 #1 SMP Wed Jul 11 13:51:30 MSK 2018 x86_64 GNU/Linux, Mono/.Net: 4.6.2 (Debian 4.6.2.7+dfsg-1); Framework: v4.0.30319
. 2018.08.02 18:18:29 - Reading options from /root/.airvpn/default.xml
. 2018.08.02 18:18:29 - Profile options not found, using defaults.
  at System.Windows.Forms.Control..ctor () [0x00014] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.ScrollableControl..ctor () [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.ContainerControl..ctor () [0x0000e] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.Form..ctor () [0x00012] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at Eddie.Forms.Form..ctor () [0x00000] in <a072f3e9330d45d4b32086ebe292ac9f>:0
  at Eddie.Forms.Forms.Main..ctor () [0x0003f] in <a072f3e9330d45d4b32086ebe292ac9f>:0
  at (wrapper remoting-invoke-with-check) Eddie.Forms.Forms.Main:.ctor ()
  at Eddie.Forms.Linux.Program.Main () [0x00092] in <3af9a54737b4455081258379cf57b863>:0

Unhandled Exception:
System.TypeInitializationException: The type initializer for 'System.Windows.Forms.WindowsFormsSynchronizationContext' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.Windows.Forms.XplatUI' threw an exception. ---> System.ArgumentNullException: Could not open display (X-Server required. Check your DISPLAY environment variable)
Parameter name: Display
  at System.Windows.Forms.XplatUIX11.SetDisplay (System.IntPtr display_handle) [0x00435] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.XplatUIX11..ctor () [0x00077] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.XplatUIX11.GetInstance () [0x0001c] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.XplatUI..cctor () [0x0007d] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
   --- End of inner exception stack trace ---
  at System.Windows.Forms.Theme.get_MenuAccessKeysUnderlined () [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.SystemInformation.get_MenuAccessKeysUnderlined () [0x00005] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.Control..ctor () [0x000ea] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control:.ctor ()
  at System.Windows.Forms.WindowsFormsSynchronizationContext..cctor () [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
   --- End of inner exception stack trace ---
  at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_generic_class_init (intptr)
  at System.Windows.Forms.WindowsFormsSynchronizationContext.get_AutoInstall () [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.Control..ctor () [0x00014] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.ScrollableControl..ctor () [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.ContainerControl..ctor () [0x0000e] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.Form..ctor () [0x00012] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.MessageBox+MessageBoxForm..ctor (System.Windows.Forms.IWin32Window owner, System.String text, System.String caption, System.Windows.Forms.MessageBoxButtons buttons, System.Windows.Forms.MessageBoxIcon icon, System.Boolean displayHelpButton) [0x0000c] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.MessageBox+MessageBoxForm..ctor (System.Windows.Forms.IWin32Window owner, System.String text, System.String caption, System.Windows.Forms.MessageBoxButtons buttons, System.Windows.Forms.MessageBoxIcon icon) [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.MessageBox+MessageBoxForm:.ctor (System.Windows.Forms.IWin32Window,string,string,System.Windows.Forms.MessageBoxButtons,System.Windows.Forms.MessageBoxIcon)
  at System.Windows.Forms.MessageBox.Show (System.String text, System.String caption, System.Windows.Forms.MessageBoxButtons buttons, System.Windows.Forms.MessageBoxIcon icon) [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at Eddie.Forms.Linux.Program.Main () [0x000dc] in <3af9a54737b4455081258379cf57b863>:0
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'System.Windows.Forms.WindowsFormsSynchronizationContext' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.Windows.Forms.XplatUI' threw an exception. ---> System.ArgumentNullException: Could not open display (X-Server required. Check your DISPLAY environment variable)
Parameter name: Display
  at System.Windows.Forms.XplatUIX11.SetDisplay (System.IntPtr display_handle) [0x00435] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.XplatUIX11..ctor () [0x00077] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.XplatUIX11.GetInstance () [0x0001c] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.XplatUI..cctor () [0x0007d] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
   --- End of inner exception stack trace ---
  at System.Windows.Forms.Theme.get_MenuAccessKeysUnderlined () [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.SystemInformation.get_MenuAccessKeysUnderlined () [0x00005] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.Control..ctor () [0x000ea] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.Control:.ctor ()
  at System.Windows.Forms.WindowsFormsSynchronizationContext..cctor () [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
   --- End of inner exception stack trace ---
  at (wrapper managed-to-native) System.Object:__icall_wrapper_mono_generic_class_init (intptr)
  at System.Windows.Forms.WindowsFormsSynchronizationContext.get_AutoInstall () [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.Control..ctor () [0x00014] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.ScrollableControl..ctor () [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.ContainerControl..ctor () [0x0000e] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.Form..ctor () [0x00012] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.MessageBox+MessageBoxForm..ctor (System.Windows.Forms.IWin32Window owner, System.String text, System.String caption, System.Windows.Forms.MessageBoxButtons buttons, System.Windows.Forms.MessageBoxIcon icon, System.Boolean displayHelpButton) [0x0000c] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at System.Windows.Forms.MessageBox+MessageBoxForm..ctor (System.Windows.Forms.IWin32Window owner, System.String text, System.String caption, System.Windows.Forms.MessageBoxButtons buttons, System.Windows.Forms.MessageBoxIcon icon) [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at (wrapper remoting-invoke-with-check) System.Windows.Forms.MessageBox+MessageBoxForm:.ctor (System.Windows.Forms.IWin32Window,string,string,System.Windows.Forms.MessageBoxButtons,System.Windows.Forms.MessageBoxIcon)
  at System.Windows.Forms.MessageBox.Show (System.String text, System.String caption, System.Windows.Forms.MessageBoxButtons buttons, System.Windows.Forms.MessageBoxIcon icon) [0x00000] in <d5b72d15d4f7424c8a1538e3f19ec2e3>:0
  at Eddie.Forms.Linux.Program.Main () [0x000dc] in <3af9a54737b4455081258379cf57b863>:0



#6 nick75

nick75

    Advanced Member

  • Members
  • PipPipPip
  • 159 posts

Posted 02 August 2018 - 10:57 PM

Weird, it can't find the X graphics server. Is it a headless server (meaning no GUI, just command line)? If so you need to download eddie-cli



#7 adamcor

adamcor

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 02 August 2018 - 11:26 PM

Weird, it can't find the X graphics server. Is it a headless server (meaning no GUI, just command line)? If so you need to download eddie-cli


I normally connect to my server via a VPN, with a desktop and everything haha. So I don’t believe it’s headless. Do I need to install something else for Eddie-cli though? Unfortunately apt-get install eddie-cli cannot locate any package.
Thanks for the help by the way!

#8 nick75

nick75

    Advanced Member

  • Members
  • PipPipPip
  • 159 posts

Posted 03 August 2018 - 07:15 PM

Post the output of these commands:

echo $DISPLAY
env | grep XDG

Also the previous output shows that you're logged in as root, not a good idea. I don't know if it's related to your issue.



#9 corrado

corrado

    Advanced Member

  • Members
  • PipPipPip
  • 195 posts

Posted 06 August 2018 - 10:47 AM

Also the previous output shows that you're logged in as root

 

Most likely, Eddie was started from a root shell - this should never be done with a graphical application. Default configurations in most distributions block access to the X server for root users for security reasons. The accepted way for graphical applications to gain privileges (where this cannot be avoided) is via pkexec. 







Similar Topics Collapse

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 14460 - BW: 55232 Mbit/sYour IP: 54.162.159.33Guest Access.