Jump to content


Photo

No Internet after using eddie


Best Answer Britman, 14 June 2018 - 02:22 PM

Thank you so much, changing the DNS settings to renaming has worked. :asd:

Go to the full post


  • Please log in to reply
7 replies to this topic

#1 Britman

Britman

    Member

  • Members
  • PipPip
  • 13 posts

Posted 13 June 2018 - 07:36 PM

So I installed eddie on Ubuntu 18.04 and it all seemed to go well.

however when I disconnect the VPN my Internet no longer works, even if I leave eddie running or close the program. I can still access my local network but pinging Google fails. This has only been happening since I first tried the GUI, I normally connect via the terminal. I was always able to reconnect to my ISP after ending the VPN session. But now, even connecting via the terminal and after ending a VPN session (ctrl+C) the Internet is still no longer accessible.

 

 

 

Thanks.



#2 giganerd

giganerd

    I shall have no title

  • Members
  • PipPipPip
  • 2452 posts
  • LocationGermany

Posted 13 June 2018 - 07:45 PM

That is because Eddie does more than simply establish a tunnel. It also disables IPv6, changes DNS settings, enables NetLock and some more things.

 

It looks like a DNS or NetLock issue, so check if iptables are empty and resolv.conf is back to normal.

$ sudo iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
$ less /etc/resolv.conf

resolv.conf should not contain comments from Eddie.


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs is the proper way to heaven.
Same issues are rare! Search for solutions and if not successful open your own threads.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

 


#3 Britman

Britman

    Member

  • Members
  • PipPip
  • 13 posts

Posted 13 June 2018 - 08:02 PM

Hi, thanks for the fast reply.

sudo iptables -L gave the same result as you quoted. However less /etc/resolv.conf gave this result.

 

# Generated by Eddie v2.13.6 | https://eddie.website

nameserver 10.4.0.1

I set my IP, Netmask and gateway manually if that has any bearing on the matter



#4 giganerd

giganerd

    I shall have no title

  • Members
  • PipPipPip
  • 2452 posts
  • LocationGermany

Posted 13 June 2018 - 10:05 PM

Seems like the original resolv.conf is not being restored, allowing the conclusion that it is indeed a DNS issue. This is, if my memory serves me right, known but I've known it only in older versions. You could try a connection with one of the two methods selected manually in Preferences > DNS > Mode - I think your current setting is Automatic. Try them both, Renaming and Resolv.conf sound very similar. :D

Also, check if there is an Eddie update available. The most recent version seems to be 2.14.5. Update and repeat the procedure with Automatic setting. Tell us about the results.

 

As a workaround, set the DNS of your primary network interface statically to 10.4.0.1 and in the preferences, set the DNS changing mode to None. Linux gives you much more control over network settings than Windows, so it should be possible to create a second profile in your network manager. For example, I've got one for complete DHCP and one with the aforementioned static DNS entry. This works for me seamlessly.


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs is the proper way to heaven.
Same issues are rare! Search for solutions and if not successful open your own threads.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

 


#5 Britman

Britman

    Member

  • Members
  • PipPip
  • 13 posts

Posted 14 June 2018 - 02:22 PM   Best Answer

Thank you so much, changing the DNS settings to renaming has worked. :asd:



#6 robertoohoho

robertoohoho

    Member

  • Members
  • PipPip
  • 10 posts

Posted 15 June 2018 - 04:52 PM

So I installed eddie on Ubuntu 18.04 and it all seemed to go well.

however when I disconnect the VPN my Internet no longer works, even if I leave eddie running or close the program. I can still access my local network but pinging Google fails. This has only been happening since I first tried the GUI, I normally connect via the terminal. I was always able to reconnect to my ISP after ending the VPN session. But now, even connecting via the terminal and after ending a VPN session (ctrl+C) the Internet is still no longer accessible.

 

 

 

Thanks.

I have the same problem using OS X High Sierra and it's a recent issue. I updated to Eddie 2.14.5, no change. I reversed to the default settings, same problem.

I checked the solution given here but, for what I understand (little) it doesn't apply to OS X.

 

Any idea?


#7 giganerd

giganerd

    I shall have no title

  • Members
  • PipPipPip
  • 2452 posts
  • LocationGermany

Posted 18 June 2018 - 08:07 PM

Please open your own thread for this, append logs and other useful info if you need to do so. Since OP marked this thread as solved, chances are your inquiry will be blatantly ignored. :)

 

Also, the fact you are using macOS, another OS with other things to look out for, makes your issue distinct from OP's.


Always remember:
There's a guide to AirVPN,

Amazon IPs are not dangerous here,
running TOR exits is discouraged,

using spoilers for your logs is the proper way to heaven.
Same issues are rare! Search for solutions and if not successful open your own threads.

~ Furthermore, I propose that your paranoia is to be destroyed. ~

 


#8 robertoohoho

robertoohoho

    Member

  • Members
  • PipPip
  • 10 posts

Posted 18 June 2018 - 09:13 PM

I did, thanks.







Similar Topics Collapse

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 14553 - BW: 47972 Mbit/sYour IP: 54.145.103.69Guest Access.