Jump to content


Photo

Torrent on AirVPN : speed is very poor


Best Answer Monotremata, 15 June 2018 - 10:11 PM

I can assure you port forward is not necessary when using a torrent client with AirVPN - have you tried different torrents? For example:

 

http://releases.ubuntu.com/18.04/ubuntu-18.04-desktop-amd64.iso.torrent

 

I'd also try a variety of settings in Eddie and different servers too - screenshots would be useful so we can get an understanding of your setup and possibly better guide you (the more info you give us the more useful our responses might be). For example, what server are you using? Any latency (ping) problems? Assuming regular browser downloads work fine and it's just torrents?

 

Also, you must ensure you are not capping upload speed in any way, as clients can snub those who limit it.

 

Yes port forwarding is necessary, otherwise leechers won't be able to connect to your client so you can't seed. You'll definitely see the pool of them, but none of them will be able to see you. One of my torrent sites puts up a big red warning when you go to it, if the tracker can't connect to your client. Thats how I figured out FrootVPN doesn't allow any sort of port forwarding whatsoever and I moved over here to AirVPN. Once I setup my port in the Client Area, and set it again in my torrent client, that message at the tracker's site goes right away and I can seed again.

Go to the full post


  • Please log in to reply
8 replies to this topic

#1 PsyKOrion

PsyKOrion

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 13 June 2018 - 07:38 AM

Hello

 

I have recently, speed which I would quote "catastrophic" when I use torrent clients.

 

OS : Windows 10
AirVPN : Eddie last version
Torrent Clients tested : qBitorrent, Transmission or Deluge.

 

Speed test : 50Mbps download/upload on VPN

 

Without AirVPN, the torrent download speed can reach 60/80 Mbps.
With AirVPN, the torrent download speed can reach 100/200 Kbps.

 

The port is set on torrent client and configured on AIRVPN port forwarding.
Checked that this port is considered open.

 



#2 Monotremata

Monotremata

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts

Posted 13 June 2018 - 08:55 PM

I would say its probably the torrent you're downloading. Its possible, the seeders just have their transfer speeds limited or maybe they're on a crappy network. It all depends on the peers and how they have their client set thats doing the sharing. I take a little bit of a hit when Im on AirVPN but I get just about my full 110+ Mbps and I always have qBitTorrent running. 



#3 PsyKOrion

PsyKOrion

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 14 June 2018 - 08:04 AM

Thx Monotremata for your answer.

Unfortunately it does not depend on torrent or seeders. I've tested with the same torrent. AirVPN on : 150kbps - AirVPN off : 50Mbps - AirVPN on : 100kbps - AirVPN off : 50Mbps. With AirVPN on, the leechers can't etablish a connection with me. Without VPN they can.
 



#4 5YmkoLQZ

5YmkoLQZ

    Advanced Member

  • Members
  • PipPipPip
  • 202 posts

Posted 14 June 2018 - 09:17 AM

I can assure you port forward is not necessary when using a torrent client with AirVPN - have you tried different torrents? For example:

 

http://releases.ubuntu.com/18.04/ubuntu-18.04-desktop-amd64.iso.torrent

 

I'd also try a variety of settings in Eddie and different servers too - screenshots would be useful so we can get an understanding of your setup and possibly better guide you (the more info you give us the more useful our responses might be). For example, what server are you using? Any latency (ping) problems? Assuming regular browser downloads work fine and it's just torrents?

 

Also, you must ensure you are not capping upload speed in any way, as clients can snub those who limit it.



#5 monstrocity

monstrocity

    Member

  • Members
  • PipPip
  • 18 posts

Posted 14 June 2018 - 01:34 PM

Have you tried TCP protocol (port 443) in Eddie?



#6 Monotremata

Monotremata

    Advanced Member

  • Members
  • PipPipPip
  • 65 posts

Posted 15 June 2018 - 10:11 PM   Best Answer

I can assure you port forward is not necessary when using a torrent client with AirVPN - have you tried different torrents? For example:

 

http://releases.ubuntu.com/18.04/ubuntu-18.04-desktop-amd64.iso.torrent

 

I'd also try a variety of settings in Eddie and different servers too - screenshots would be useful so we can get an understanding of your setup and possibly better guide you (the more info you give us the more useful our responses might be). For example, what server are you using? Any latency (ping) problems? Assuming regular browser downloads work fine and it's just torrents?

 

Also, you must ensure you are not capping upload speed in any way, as clients can snub those who limit it.

 

Yes port forwarding is necessary, otherwise leechers won't be able to connect to your client so you can't seed. You'll definitely see the pool of them, but none of them will be able to see you. One of my torrent sites puts up a big red warning when you go to it, if the tracker can't connect to your client. Thats how I figured out FrootVPN doesn't allow any sort of port forwarding whatsoever and I moved over here to AirVPN. Once I setup my port in the Client Area, and set it again in my torrent client, that message at the tracker's site goes right away and I can seed again.



#7 clayvligon

clayvligon

    Newbie

  • Members
  • Pip
  • 9 posts
  • LocationCanada

Posted 18 September 2018 - 12:11 PM

I download mostly kickass torrents and have never gone wrong with airvpn. The speed drops are not by too much and it seeds the torrent very well. 



#8 russellgill

russellgill

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 09 October 2018 - 04:18 PM

Some torrents sites are slow, because of more load time, try these kickass mirror sites all are working well



#9 serenacat

serenacat

    Advanced Member

  • Members
  • PipPipPip
  • 238 posts

Posted 10 October 2018 - 05:38 AM

You can check that port forwarding is working, and not blocked by ISP/router firewall/system firewall/antivirus using:

http://canyouseeme.org/

You can try to avoid throttling by ISP detection of VPN using Deep Packet Inspection by trying Eddie Settings/Protocols/SSL443 for an outer covering which looks like common https webpage access.







Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14719 - BW: 57087 Mbit/sYour IP: 54.144.82.216Guest Access.