Jump to content


Photo

Eddie 2.14.5 released


  • Please log in to reply
52 replies to this topic

#41 greerd

greerd

    Advanced Member

  • Members
  • PipPipPip
  • 46 posts

Posted 12 June 2018 - 08:32 PM

i'm running eddie on linux mint 18.2 cinnamon and have it in my repositories, so the update to 2.14.5. went through automatically. everything works fine, except for one thing:

under preferences, the protocols tab says "30 protocol modes not available due to your OpenVPN version".

does that mean that i must update my openvpn version? do i have to re-install eddie manually to achieve that or is there another way?

Unless you need one of those protocols, why bother updating openvpn? You never had the option for those protocols before, it just never told you they were available with a newer openvpn. 

 

I got that same message when using Mint 18.3 but I only use UDP port 443 so I never bothered to update onpenvpn.

 

I'm now using Mint 19 beta which uses openvpn 2.4.4 so no more warnings, but I'm still only using UDP port 443 so it doesn't really matter to me, it wasn't the reason for me updating to Mint 19 beta. (I like shiny new things!) 

 

Mint 19 should be out by the end of the month although I'm finding the beta very stable, normally Mint beta's move directly to stable releases via update manager, if you're interested in updating to the beta now.



#42 jesus2

jesus2

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 13 June 2018 - 12:24 PM

Is anyone using ubuntu 16.04 here? If so, can you run eddie/airvpn by using the launcher/icon? I can only run it by using terminal, and I can't make it auto-startup.



#43 hanswurst77

hanswurst77

    Advanced Member

  • Members
  • PipPipPip
  • 35 posts

Posted 13 June 2018 - 03:15 PM

@greerd:

i have used ssh/ssl protocol in the past, although to be honest i'm not sure whether it was on said machine or on my laptop (which still runs on 17.3).

thanks for the 19 info anyway. i usually like to wait for the point releases, which i will also do in this case if the need for more protocols shouldn't become urgent.



#44 Monotremata

Monotremata

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 13 June 2018 - 08:21 PM


 

Is anyone using ubuntu 16.04 here? If so, can you run eddie/airvpn by using the launcher/icon? I can only run it by using terminal, and I can't make it auto-startup.

 

 

Worked great just like it does on my Mac on Mint 18.3, which is Ubuntu 16.04. Only thing I had to use the terminal for was to install openvpn.



#45 Clodo

Clodo

    AirVPN Team

  • Staff
  • PipPipPip
  • 288 posts
  • LocationItaly

Posted 13 June 2018 - 09:42 PM

I'm using Eddie-2.14.5 on Arch Linux, and eddie-tray doesn't work.

...

(eddie-tray:1400): libappindicator-WARNING **: 11:58:20.851: Unable to get the session bus: Address element “False” does not contain a colon (:)

(eddie-tray:1400): LIBDBUSMENU-GLIB-WARNING **: 11:58:20.851: Unable to get session bus: Address element “False” does not contain a colon (:)

...
 
In Eddie-2.14.4 it worked like a charm.
 
It doesn't matter, which package I use. Arch, portable, mono, it's always the same.
 
I did notice, that the name was changed from eddie_tray to eddie-tray. What else has been changed, I wonder.

Issue detected and resolved, will be fixed in the next release, few days.

#46 radolkin

radolkin

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 14 June 2018 - 10:51 AM

It doesn't matter, which package I use. Arch, portable, mono, it's always the same.
 
I did notice, that the name was changed from eddie_tray to eddie-tray. What else has been changed, I wonder.

 

Issue detected and resolved, will be fixed in the next release, few days.

Thanks, very much appreciated. You and your colleagues are the best. :good:



#47 Clodo

Clodo

    AirVPN Team

  • Staff
  • PipPipPip
  • 288 posts
  • LocationItaly

Posted 14 June 2018 - 11:53 AM

Is anyone using ubuntu 16.04 here? If so, can you run eddie/airvpn by using the launcher/icon? I can only run it by using terminal, and I can't make it auto-startup.

Just installed from scratch Ubuntu 16.04, open Firefox, https://airvpn.org/linux, click .deb, click to install, launch by icon, works.
https://www.clodo.it/files/temp/ubuntu1604.mp4

Please try to install .deb edition and write only "eddie-ui" in terminal, and post here the result. Thanks.

#48 ironmikezero

ironmikezero

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 14 June 2018 - 05:16 PM

Jesus2, did you solve your issue?

 

Newbie here, too. I'm running Eddie on Ubuntu 16.04LTS with no problems--nor do I have to use the terminal to initiate Eddie. I don't use auto-start for various reasons; choosing when to engage Eddie is my preference. For convenience I locked the AIR/Eddie icon (white cloud in blue circle) to the launch bar. Clicking it opens Eddie. Once initiated (server selected), minimizing Eddie's window puts a smaller icon in the working tray (upper rt-hand screen corner); click it to pull down the menu. You can disconnect here. Keeping the AIR/Eddie icon locked to the launch bar is a convenient shortcut for me; I don't have to resort to using the terminal (although even that's not a big deal).



#49 Clodo

Clodo

    AirVPN Team

  • Staff
  • PipPipPip
  • 288 posts
  • LocationItaly

Posted 15 June 2018 - 02:26 PM

It doesn't matter, which package I use. Arch, portable, mono, it's always the same.
 
I did notice, that the name was changed from eddie_tray to eddie-tray. What else has been changed, I wonder.

Issue detected and resolved, will be fixed in the next release, few days.

Thanks, very much appreciated. You and your colleagues are the best. :good:

Please test the latest experimental 2.15.1 (just released), it contains the fix.

#50 Monotremata

Monotremata

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 17 June 2018 - 09:10 AM

Keep frequently getting disconnected using the latest one on MacOS 10.13.5. Sometimes it reconnects, sometimes I have to cancel it cause it gets stuck and reconnect, other times it seems the only thing thats fixed it and let it reconnect was either restarting Eddie or turning off my wi-fi and turning it back on.

Still not sure if its my Mac or Eddie, but it wasn't happening until 2.14.5, and I haven't changed anything in the rest of the system for awhile now. 



#51 radolkin

radolkin

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 17 June 2018 - 09:51 AM

Please test the latest experimental 2.15.1 (just released), it contains the fix.

Yep, it certainly does. The tray icon is working fine in version 2.15.1. Thanks a bunch!



#52 user972512

user972512

    Member

  • Members
  • PipPip
  • 15 posts

Posted 17 June 2018 - 01:28 PM

Thanks for the new version.

 

Note: Tray icon finally worked in 2.14.3. Then in 2.14.4 it was gone again. I was hoping it would be back in 2.14.5 but it is not.

 

XUbuntu 16.04 LTS x86



#53 ezd

ezd

    Member

  • Members
  • PipPip
  • 17 posts

Posted 17 June 2018 - 04:19 PM

I used to use the cli version but 2.14.5 seems different. I can't restart with `n` or exit with `x`. 






1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 14110 - BW: 41373 Mbit/sYour IP: 54.80.58.121Guest Access.