Jump to content


Photo

Eddie 2.14.5 released


  • Please log in to reply
52 replies to this topic

#1 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7568 posts

Posted 06 June 2018 - 01:16 PM

Hello!

We're very glad to inform you that a new Eddie Air client version has been released: 2.14.5

Eddie 2.14.5 includes many important bug fixes and changes. You can see them all on the changelog here; https://airvpn.org/services/changelog.php?software=client&format=html.

 

As usual, Eddie is released as free and open source software under GPLv3.

 

New important features have been added. Now Eddie includes a full, seamless and integrated IPv6 support, as well as new features which will let you use our latest service additions (including IPv6 and tls-crypt).

 

Users who have only IPv4 connectivity will be able to access IPv6 services, At the same time users who have only IPv6 (and not IPv4) connectivity, will be able to use our service without limitations.

 

tls-crypt implementation provides a new, interesting way to efficiently bypass blocks and throttling against OpenVPN.

 

This version has been released GNU/Linux, OS X (Mavericks or higher is required), macOS and Windows (Vista or higher is required).

2.14.5 version is compatible with several Linux distributions. For important notes about environments, please read here:

https://airvpn.org/topic/27259-status-of-eddie-on-linux-distributions/

Due to the large amount of bug fixes and changes, as well as the addition of new features, upgrade is strongly recommended.

Just like previous versions, Eddie implements direct Tor support for OpenVPN over Tor connections. Eddie makes OpenVPN over Tor easily available to Linux, OS X and macOS users: no needs for Virtual Machines, middle boxes or other special configurations. Windows users will find a more friendly approach as well. This mode is specifically designed for Tor and therefore solves multiple issues, especially in Linux and OS X/macOS, including the "infinite routing loop" problem (see for example http://tor.stackexchange.com/questions/1232/me-tor-vpn-how/1235#1235 )

As far as we know, Eddie is the first and currently the only OpenVPN wrapper that natively allows OpenVPN over Tor connections for multiple Operating Systems. https://airvpn.org/tor This is the first stable version which sends a NEWNYM signal to Tor to ensure the use of a new circuit in every connection.

We recommend that you upgrade Eddie as soon as possible.

Eddie 2.14.5 for GNU/Linux can be downloaded here: https://airvpn.org/linux
Eddie 2.14.5 for Windows can be downloaded here: https://airvpn.org/windows
Eddie 2.14.5 for OS X Mavericks, Yosemite, El Capitan and macOS Sierra and High Sierra can be downloaded here: https://airvpn.org/macosx

PLEASE NOTE: Eddie 2.14 package includes an OpenVPN version re-compiled by us from OpenVPN 2.4 source code with OpenSSL 1.0.2k for security reasons and to fix this bug: https://community.openvpn.net/openvpn/ticket/328

Eddie overview is available here: https://airvpn.org/software
Eddie includes a Network Lock feature: https://airvpn.org/faq/software_lock
Eddie is free and open source software released under GPLv3. GitHub repository: https://github.com/AirVPN/airvpn-client

Kind regards & datalove
AirVPN Staff



#2 6V3T8Z35t4KVP1aRtR8i

6V3T8Z35t4KVP1aRtR8i

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 06 June 2018 - 02:18 PM

Excited to check this out! Can you expand a bit more on tls-crypt? What is it? How does it provide better throttling defence? Does it only work in combination with ipv6? Thanks!

#3 NaDre

NaDre

    Advanced Member

  • Members
  • PipPipPip
  • 415 posts

Posted 06 June 2018 - 02:47 PM

I believe that issues with Eddie were holding up the move of all servers to IPv6? Is that road block now removed so that full IPv6 support will soon be available on all servers? I see a couple more on the IPv6 over IPv6 configuration generator screen. But most are still not there.



#4 DarkSpace-Harbinger

DarkSpace-Harbinger

    Advanced Member

  • Members
  • PipPipPip
  • 74 posts

Posted 06 June 2018 - 04:41 PM

I believe that issues with Eddie were holding up the move of all servers to IPv6? Is that road block now removed so that full IPv6 support will soon be available on all servers? I see a couple more on the IPv6 over IPv6 configuration generator screen. But most are still not there.

 

Most servers still don't support IPV6 nor tls-crypt. There are only twelve "generation two" servers out of 219 servers that currently support them.

 

That's only 5.47% of the total AirVPN network

 

It will probably take months before the full network updates unless @staff proves me wrong.



#5 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7568 posts

Posted 06 June 2018 - 04:50 PM

Excited to check this out! Can you expand a bit more on tls-crypt? What is it? How does it provide better throttling defence? Does it only work in combination with ipv6? Thanks!

 

Hello and thank you!

 

Please see here:

https://build.openvpn.net/doxygen/html/group__tls__crypt.html

 

IPv6 is not necessary for tls-crypt. IPv6 and tls-crypt are often cited together by us only because the upgrade to IPv6 of servers also includes upgrade to tls-crypt support, and vice-versa, but that's only an internal method of working.

 

Kind regards



#6 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7568 posts

Posted 06 June 2018 - 04:58 PM

I believe that issues with Eddie were holding up the move of all servers to IPv6? Is that road block now removed so that full IPv6 support will soon be available on all servers? I see a couple more on the IPv6 over IPv6 configuration generator screen. But most are still not there.

 

 

 

Hello!

 

Exactly. As you may have read in the announcement of the IPv6 experimental phase, such phase could not be closed before the release of some stable release of Eddie 2.14. Now that we have a stable Eddie which fully supports IPv6, the 12 servers will provide us with a massive amount of connections and therefore we will receive meaningful feedbacks is something goes wrong.

 

If nothing goes wrong then the migration will continue as programmed and most of our infrastructure will support IPv6 (not all, because we still have 2 datacenters that do not support IPv6). Note that all servers are already "gen 2" ready (meaning that they have both full IPv6 support from the datacenter AND enough IPv4 addresses to support all the different, new connection modes regardless of IPv6), so the time consuming procedure in this phase is the testing, not the final steps of the migration in themselves, even because the critical ones (including pre-planning, requests to datacenters for IPv6 support, deployment of new configurations) were performed between late 2016 and the beginning of 2018.

 

Kind regards



#7 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7568 posts

Posted 06 June 2018 - 05:03 PM

I believe that issues with Eddie were holding up the move of all servers to IPv6? Is that road block now removed so that full IPv6 support will soon be available on all servers? I see a couple more on the IPv6 over IPv6 configuration generator screen. But most are still not there.

 

Most servers still don't support IPV6 nor tls-crypt. There are only twelve "generation two" servers out of 219 servers that currently support them.

 

That's only 5.47% of the total AirVPN network

 

It will probably take months before the full network updates unless @staff proves me wrong.

 

Hello!

 

The final step of the upgrade in itself is not very time consuming, see the previous message to NaDre, however what we can't foresee is whether unexpected problems will come out now that Gen 2 servers will be massively used, and if they do (of course we are confident they will not), how much time we would need to resolve them.

 

Kind regards



#8 abrakadot2000

abrakadot2000

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 06 June 2018 - 05:43 PM

I have a problem on linux debian newest verision..eddie connect to server if I am not using network lock but if I use this option I cant connect to server(its trying to connect and restarting process all the time..) Is there any solution for this?



#9 puff-m-d

puff-m-d

    Advanced Member

  • Members
  • PipPipPip
  • 50 posts

Posted 06 June 2018 - 06:08 PM

Hello Staff,

 

Just a quick note: the link to the changelog from the "Enter" (download) page seems to be broken. Not a big deal deal to me as I was able to access the changelog from the link in your first post above but it may make it hard to find for others trying to access it from the "Enter" page.



#10 1865915941

1865915941

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 06 June 2018 - 06:28 PM

Staff, do you have any news on Eddie version 3? You seriously need to get rid of all these Mono dependencies:

The following NEW packages will be installed:
  binfmt-support ca-certificates-mono cli-common curl easy-rsa eddie-ui
  libappindicator1 libccid libcurl3 libdbusmenu-glib4 libdbusmenu-gtk4
  libgdiplus libindicator7 libmono-accessibility4.0-cil libmono-corlib4.5-cil
  libmono-data-tds4.0-cil libmono-i18n-west4.0-cil libmono-i18n4.0-cil
  libmono-posix4.0-cil libmono-security4.0-cil
  libmono-system-configuration4.0-cil libmono-system-core4.0-cil
  libmono-system-data4.0-cil libmono-system-drawing4.0-cil
  libmono-system-enterpriseservices4.0-cil libmono-system-numerics4.0-cil
  libmono-system-runtime-serialization-formatters-soap4.0-cil
  libmono-system-security4.0-cil libmono-system-transactions4.0-cil
  libmono-system-windows-forms4.0-cil libmono-system-xml4.0-cil
  libmono-system4.0-cil libmono-webbrowser4.0-cil libmonoboehm-2.0-1
  libpkcs11-helper1 mono-4.0-gac mono-gac mono-runtime mono-runtime-common
  mono-runtime-sgen mono-utils opensc opensc-pkcs11 openvpn pcscd stunnel4


#11 omnipotent93x

omnipotent93x

    Member

  • Members
  • PipPip
  • 18 posts

Posted 06 June 2018 - 08:18 PM

i still get webrtc leaks,  the weird thing is it's only on certain  servers.  i've finally gave in and installed the extension to the chrome browser but if anything it's putting a very bad impression on the software client now, since i see that it can't function at 100 percent on it's own.  it's a shame really, i was hoping that this would be fixed with this update. i geuss air will have to be a secondary for now on if this can't be resolved, i've used other software clients and don't run into this problem at all.  

Attached Files



#12 Mad_Max

Mad_Max

    Advanced Member

  • Members
  • PipPipPip
  • 42 posts

Posted 06 June 2018 - 10:51 PM

Im getting an error "( Cannot login.key 'Default' not found)."

 

I have attached the logs in this post, please help me:

https://airvpn.org/topic/27828-error-with-latest-eddie-2145-cannot-loginkey-default-not-found/



#13 whiskey_76

whiskey_76

    Advanced Member

  • Members
  • PipPipPip
  • 51 posts

Posted 07 June 2018 - 12:51 AM

i still get webrtc leaks,  the weird thing is it's only on certain  servers.  i've finally gave in and installed the extension to the chrome browser but if anything it's putting a very bad impression on the software client now, since i see that it can't function at 100 percent on it's own.  it's a shame really, i was hoping that this would be fixed with this update. i geuss air will have to be a secondary for now on if this can't be resolved, i've used other software clients and don't run into this problem at all.  

WebRTC leaks are not the Eddlie Client's fault but rather the web browser you are using. If you are using Chrome or Chromium you will need the web-rtc block extension, and to have it set where it redirects the webrtc request. Otherwise you need a browser like Firefox where you can disable WebRTC in the about:config options. If you have network lock enabled and are using Firefox or Chromium with the blocker extension you will not have any WebRtc leaks. I always check everytime I use Eddie and have never had any leak problems that way.

 

Edit: Also I have found using the Brave web browser with fingerprinting protection on to show no WebRTC leaks on ipleak.net as well.



#14 DarkSpace-Harbinger

DarkSpace-Harbinger

    Advanced Member

  • Members
  • PipPipPip
  • 74 posts

Posted 07 June 2018 - 02:58 AM

@Staff will we ever get VPN through Tor to work properly with the network lock somehow?

 

It's an awesome feature, but it fails when using bridges and you have to expose yourself to potential traffic leaks when you disable the network lock to use it.



#15 dschubba

dschubba

    Member

  • Members
  • PipPip
  • 16 posts

Posted 07 June 2018 - 05:10 AM

I'm using Windows 7 64bit and the "Start with Windows" feature isn't working anymore. 



#16 JSD

JSD

    Member

  • Members
  • PipPip
  • 19 posts

Posted 07 June 2018 - 05:10 AM

Thank you for your work! My impression is that my internet is faster with 2.14.5, but this may be subjective.

 

 

Is tls-crypt enabled by default? I did not find anything in the settings.

 

What does "Enable latency tests" mean, and is it security relevant (traffic outside the tunnel or something like that)?



#17 dschubba

dschubba

    Member

  • Members
  • PipPip
  • 16 posts

Posted 07 June 2018 - 05:16 AM

I'm using Windows 7 64bit and the "Start with Windows" feature isn't working anymore. 

 

I've just found a workaround :

1. Deactivate it (untick "Start with Windows" box in the menu)

2. Restart your PC

3. Reactivate it

4. It should start automatically on next reboot...



#18 JSD

JSD

    Member

  • Members
  • PipPip
  • 19 posts

Posted 07 June 2018 - 05:32 AM

In most instances, I start Eddie with Network Lock before I connect to the internet. I want to ensure that there is not more communication between my OS and the internet than really necessary before the VPN tunnel is working.

 

With the new version of Eddie, it still works, but I always get a problem report saying that Eddie could not connect to the internet (what is logical since I start Eddie before my internet connection). Not a big deal, but a little annoying, Can I get rd of this problem report popping up each time?   



#19 davidcrickett

davidcrickett

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 07 June 2018 - 06:16 AM

In most instances, I start Eddie with Network Lock before I connect to the internet. I want to ensure that there is not more communication between my OS and the internet than really necessary before the VPN tunnel is working.

 

With the new version of Eddie, it still works, but I always get a problem report saying that Eddie could not connect to the internet (what is logical since I start Eddie before my internet connection). Not a big deal, but a little annoying, Can I get rd of this problem report popping up each time?

 

 


 

 

I get 'unidentified network No internet access' with the new Eddie... a yellow exclamation point on the Internet access icon in the taskbar but Eddie works alright... (Windows 10)...



#20 jeuia3e9x74uxu6wk0r2u9kdos

jeuia3e9x74uxu6wk0r2u9kdos

    Member

  • Members
  • PipPip
  • 29 posts

Posted 07 June 2018 - 06:56 AM

Thank you for your work! My impression is that my internet is faster with 2.14.5, but this may be subjective.

 

 

Is tls-crypt enabled by default? I did not find anything in the settings.

 

What does "Enable latency tests" mean, and is it security relevant (traffic outside the tunnel or something like that)?

 

https://airvpn.org/topic/27448-explanation-of-protocols-tab-under-settings/?p=73383

 

1 and 2 are tls-auth, 3 and 4 are tls-crypt.

 

The reason for having two of each is in case one is blocked by ....  ISP or something.

 

If you resolve a server name, for example, "nslookup leo.airvpn.org", it'll resolve to its #1 IP.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14207 - BW: 42353 Mbit/sYour IP: 54.145.83.79Guest Access.