Jump to content


Photo

Eddie beta 2.14.2 - Hangs on Starting . . . - SSL Not available

eddie beta linux manjaro ssl hang

  • Please log in to reply
12 replies to this topic

#1 smoresel

smoresel

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 11 March 2018 - 11:28 PM

. 2018.03.11 19:21:26 - Eddie version: 2.14.2 / linux_x64, System: Linux, Name: Manjaro Linux \r  (\n) (\l), Version: Linux my-manjaro 4.14.24-1-MANJARO #1 SMP PREEMPT Sun Mar 4 21:28:02 UTC 2018 x86_64 GNU/Linux, Mono/.Net Framework: v4.0.30319
. 2018.03.11 19:21:26 - Reading options from /home/smoresel/.airvpn/AirVPN.xml
. 2018.03.11 19:21:26 - Command line arguments (3): path="/home/smoresel/.airvpn" path.resources="/usr/share/AirVPN" console.mode="none"
. 2018.03.11 19:21:28 - OpenVPN Driver - Found, /dev/net/tun
. 2018.03.11 19:21:28 - OpenVPN - Version: 2.4.5 - OpenSSL 1.1.0g  2 Nov 2017, LZO 2.10 (/sbin/openvpn)
. 2018.03.11 19:21:28 - SSH - Version: OpenSSH_7.6p1, OpenSSL 1.1.0g  2 Nov 2017 (/sbin/ssh)

When starting Eddie, under Overview, I see Starting with a progress bar that appears to move but no progress is made.  I've waited at least ten minutes in the past.



#2 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1839 posts

Posted 12 March 2018 - 12:04 AM

Hello!

 

Is that the entire log?

 

Are you missing stunnel?


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.

#3 smoresel

smoresel

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 12 March 2018 - 12:28 AM

I could have sworn stunnel was installed, it was not.  I installed stunnel.

 

After this, I no longer receive the SSL error, although it was hanging on Logout with the same progress bar as before.  I killed the two PIDs for airvpn (mono requires kill -9 as root).  Renamed the AirVPN.xml file so that Eddie would regenerate another XML file.  I input the username and password and click Login and accept the EULA but after this, I can no longer press Login.  Activate Network Lock also doesn't appear to do anything.

 

Previously, I was never able to reach the preferences menu although now I can.  I'm still unable to exit without killing the PIDs.

 

. 2018.03.11 20:31:21 - Eddie version: 2.14.2 / linux_x64, System: Linux, Name: Manjaro Linux \r  (\n) (\l), Version: Linux my-manjaro 4.14.24-1-MANJARO #1 SMP PREEMPT Sun Mar 4 21:28:02 UTC 2018 x86_64 GNU/Linux, Mono/.Net Framework: v4.0.30319
. 2018.03.11 20:31:21 - Reading options from /home/smoresel/.airvpn/AirVPN.xml
. 2018.03.11 20:31:21 - Command line arguments (3): path="/home/smoresel/.airvpn" path.resources="/usr/share/AirVPN" console.mode="none"
. 2018.03.11 20:31:22 - OpenVPN Driver - Found, /dev/net/tun
. 2018.03.11 20:31:22 - OpenVPN - Version: 2.4.5 - OpenSSL 1.1.0g  2 Nov 2017, LZO 2.10 (/sbin/openvpn)
. 2018.03.11 20:31:22 - SSH - Version: OpenSSH_7.6p1, OpenSSL 1.1.0g  2 Nov 2017 (/sbin/ssh)
. 2018.03.11 20:31:22 - SSL - Version: stunnel 5.44 (/sbin/stunnel)
. 2018.03.11 20:31:22 - curl - Version: 7.58.0 (/sbin/curl)
. 2018.03.11 20:31:22 - Certification Authorities: /usr/share/AirVPN/cacert.pem


#4 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1839 posts

Posted 12 March 2018 - 12:44 AM

Is that the entire log from Eddie>Logs tab? It would be useful to see what Eddie is actually doing.


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.

#5 smoresel

smoresel

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 12 March 2018 - 12:58 AM

Correct.  That's the entire logs tab.  If there are other locations for logs, let me know.

 

Also, I'm no longer being prompted for the EULA, but am still not able to click Login button.  Activate Network Lock is clickable and asks if I'm sure I want to activate the mode.  I click Yes but nothing happens.  I would expect to see the red icon become a green icon.



#6 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1839 posts

Posted 12 March 2018 - 01:22 AM

You may be able to extract some more logs if you go to Eddie Preferences>Logging.

 

Maybe you should try reinstalling the client, but this time with stunnel as well, before starting. You could also try out a portable release :).

 

It may also be suitable to post in the corresponding client Beta thread, if this persists.


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.

#7 expatmog

expatmog

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 13 March 2018 - 01:30 AM

Hi, I need some help here with the same problem in Arch with Eddie. Although I've been using Airvpn for almost three years, this is my first time writing about a problem, everything has just worked for me. A recent Arch update seems to have broken Eddie, and I'm not knowledgeable enough to give much information.

 

Like Smoresel, I first couldn't start Eddie with the "SSL not available" message. I don't know how he got logs, because I had to shut the system down to close Eddie, it wouldn't close, just hung there. Following LZ1's advice, I installed something called "Stunnel," which I never heard of or installed before. I have used Eddie on Arch for a couple of years without a problem.

 

Before reinstalling Eddie, I removed it with the -Rsn command, so I would get everything and any config files. Upon reinstall of the beta client, Eddie started and now goes right to "logout," where it hangs. I can't get into it at all to get any information or configure the stunnel as LZ1 suggested.

 

I'm kind of stuck trying to make this work. Any suggestions would be greatly appreciated.

 

UPDATE: I reinstalled the distro (Antergos), installed Stunnel, then Eddie. This time, the main screen came up, I entered my info and it took me to the commit screen. I accepted the terms, then it returned me to the main screen and the system froze. Had to turn the power off to reboot. Looks like the beta will no longer work with Arch.

 

Pete



#8 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1839 posts

Posted 13 March 2018 - 03:03 AM

Hi, I need some help here with the same problem in Arch with Eddie. Although I've been using Airvpn for almost three years, this is my first time writing about a problem, everything has just worked for me. A recent Arch update seems to have broken Eddie, and I'm not knowledgeable enough to give much information.

 

Like Smoresel, I first couldn't start Eddie with the "SSL not available" message. I don't know how he got logs, because I had to shut the system down to close Eddie, it wouldn't close, just hung there. Following LZ1's advice, I installed something called "Stunnel," which I never heard of or installed before. I have used Eddie on Arch for a couple of years without a problem.

 

Before reinstalling Eddie, I removed it with the -Rsn command, so I would get everything and any config files. Upon reinstall of the beta client, Eddie started and now goes right to "logout," where it hangs. I can't get into it at all to get any information or configure the stunnel as LZ1 suggested.

 

I'm kind of stuck trying to make this work. Any suggestions would be greatly appreciated.

 

Pete

Cool. Maybe it's just a GUI problem, so did you consider trying

airvpn -cli

in the terminal? This all certainly sounds like something worth posting in the Eddie Beta thread, once there's more information; at least we may be able to see if you go through a proper connection sequence. Also, which DS are you using? If it's Wayland, that can also be a cause for some issues, but since you said it worked in the past, I doubt it. (Just working in the dark here without logs, so I'm counting anything I can think of).

 

Maybe he got Logs because he's using Manjaro, which while based on Arch, isn't all the same either and as such neither are the ways Eddie acts for you, I suppose :).

 

If you wanted to enable the Preferences>Logging option, you could also download an earlier client that worked for you and enable it. Then upgrade again. The setting should remain in the Air.xml

 

By the way, Staff, it doesn't seem like there's an entry for enabling logging through cli. If that's the case, could that be added please? Thank you.


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.

#9 expatmog

expatmog

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 13 March 2018 - 02:18 PM

I'm pretty sure this problem is due to a recent Arch update. I have three machines with different Arch OS's running in VB's. None work with Eddie now, but they do if I restore them to earlier snapshots.Problem is, I don't have a snapshot for every darn update.

 

Pete



#10 smoresel

smoresel

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 13 March 2018 - 09:33 PM

LZ1, I can't find the "beta" Eddie client subforum.  I would prefer that you move this thread there if you are able to since I'd rather not re-explain everything that has been documented here.
 

Like Smoresel, I first couldn't start Eddie with the "SSL not available" message. I don't know how he got logs, because I had to shut the system down to close Eddie, it wouldn't close, just hung there. Following LZ1's advice, I installed something called "Stunnel," which I never heard of or installed before. I have used Eddie on Arch for a couple of years without a problem.

Pete, I was eventually able to get to the categories on the lefthand side and chose Logs.  From there, you have a small button with an icon of a floppy disk to save the output to.  I edited mine not to reveal the local username and hostname but that's really up to you.

#11 smoresel

smoresel

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 13 March 2018 - 09:36 PM

I uninstalled/reinstalled without any change for Eddie (GUI). Then I tried with the cli option

This is the same result using sudo or not
airvpn -cli
Unhandled Exception:
System.TypeInitializationException: The type initializer for 'System.Console' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.ConsoleDriver' threw an exception. ---> System.Exception: Magic number is wrong: 542
  at System.TermInfoReader.ReadHeader (System.Byte[] buffer, System.Int32& position) [0x00028] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.TermInfoReader..ctor (System.String term, System.String filename) [0x0005f] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.TermInfoDriver..ctor (System.String term) [0x00055] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.ConsoleDriver.CreateTermInfoDriver (System.String term) [0x00000] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.ConsoleDriver..cctor () [0x0004d] in <a84b655e5e6a49ee96b338ec792f5580>:0 
   --- End of inner exception stack trace ---
  at System.Console.SetupStreams (System.Text.Encoding inputEncoding, System.Text.Encoding outputEncoding) [0x00007] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.Console..cctor () [0x0008e] in <a84b655e5e6a49ee96b338ec792f5580>:0 
   --- End of inner exception stack trace ---
  at Eddie.Forms.Linux.Program.Main () [0x000d1] in <7dfcf011e3ff4e82838474e627718575>:0 
[ERROR] FATAL UNHANDLED EXCEPTION: System.TypeInitializationException: The type initializer for 'System.Console' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.ConsoleDriver' threw an exception. ---> System.Exception: Magic number is wrong: 542
  at System.TermInfoReader.ReadHeader (System.Byte[] buffer, System.Int32& position) [0x00028] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.TermInfoReader..ctor (System.String term, System.String filename) [0x0005f] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.TermInfoDriver..ctor (System.String term) [0x00055] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.ConsoleDriver.CreateTermInfoDriver (System.String term) [0x00000] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.ConsoleDriver..cctor () [0x0004d] in <a84b655e5e6a49ee96b338ec792f5580>:0 
   --- End of inner exception stack trace ---
  at System.Console.SetupStreams (System.Text.Encoding inputEncoding, System.Text.Encoding outputEncoding) [0x00007] in <a84b655e5e6a49ee96b338ec792f5580>:0 
  at System.Console..cctor () [0x0008e] in <a84b655e5e6a49ee96b338ec792f5580>:0 
   --- End of inner exception stack trace ---
  at Eddie.Forms.Linux.Program.Main () [0x000d1] in <7dfcf011e3ff4e82838474e627718575>:0 


#12 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1839 posts

Posted 13 March 2018 - 10:23 PM

Here's the Beta thread, there's no beta subforum, apologies for ambiguity.

 

You could just link to this thread if you want; at this point it's more to help keep it collected in one place and not because Staff didn't probably already notice this thread :).

 

Thanks for running the command too. At least those errors are some hint.


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.

#13 expatmog

expatmog

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 13 March 2018 - 10:51 PM

I don't know what's going on, but I just did a bare metal install of Manjaro KDE, and after I installed Eddie beta from the AUR, everything is working perfectly. Updated the system, still works. I don't understand it, yesterday I couldn't get it to work with any Arch distro.

 

Thanks for help, good to know I don't have to twist in the wind.

 

Smoresel, thanks for the log info, hope you fix whatever is going on. I noticed you're using Manjaro as well. I tried with Manjaro, Netrunner (same thing), and Antergos, couldn't get any of them to work yesterday, then today I reverted back to an earlier snapshot with Netrunner in a VM and it worked. Yet today fully upgraded Manjaro works fine. Perhaps because I installed Eddie before I upgraded? I don't know Arch well enough to know if that makes a difference. Good luck!

 

Pete







Similar Topics Collapse


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14569 - BW: 46606 Mbit/sYour IP: 54.198.55.167Guest Access.