Jump to content


Photo

Eddie 2.14beta released


  • Please log in to reply
205 replies to this topic

#201 l3o

l3o

    Member

  • Members
  • PipPip
  • 10 posts

Posted 23 May 2018 - 09:30 AM

I find Eddie - OpenVPN UI in dmenu but it doesn't run (nothing happens if I select it). I have to run eddie-ui from terminal with root privileges.
Cheers leo

Please try to launch "eddie-ui" from terminal as normal user, and post here the log. And try also "pkexec eddie-ui". Thanks.

 
Here the outpup of "eddie-ui":

eddie-ui
[leo@mousy ~]$ . 2018.05.23 11:23:05 - Eddie version: 2.14.4 / linux_x64, System: Linux, Name: Debian GNU/Linux buster/sid \n \l, Version: Linux mousy 4.16.0-1-amd64 #1 SMP Debian 4.16.5-1 (2018-04-29) x86_64 GNU/Linux, Mono/.Net: 4.6.2 (Debian 4.6.2.7+dfsg-1); Framework: v4.0.30319
. 2018.05.23 11:23:05 - Restarting with admin privileges (method:pkexec-policy)
==== AUTHENTICATING FOR com.eddie.linux.ui.policy ===
Authentication is required to run the Eddie - OpenVPN UI
Authenticating as: leo,,, (leo)
Password: PASSWORD
bash: PASSWORD: comando non trovato
[leo@mousy ~]$

 
Where PASSWORD is my password;)
 
And this  for pkexec eddie-ui

pkexec eddie-ui
==== AUTHENTICATING FOR com.eddie.linux.ui.policy ===
Authentication is required to run the Eddie - OpenVPN UI
Authenticating as: leo,,, (leo)
Password:
polkit-agent-helper-1: error response to PolicyKit daemon: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: No session for cookie
==== AUTHENTICATION FAILED ===
Error executing command as another user: Not authorized

This incident has been reported.



#202 183aTr78f9o

183aTr78f9o

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts

Posted 04 June 2018 - 01:36 PM

i've just updated to 2.14.5-1 via AUR (Arch Linux / KDE Plasma).

 

The system tray icon works, but it's invisible. The context menu works if I right click on the invisible tray icon. No issue with other app icons...

 

It happens regarldess of the system theme (Breeze, materia-kde...). Maybe it was already invisible with previous build, I can't tell since I switched to Qomui a few weeks ago and was using MATE Desktop before.



#203 meelosh

meelosh

    Member

  • Members
  • PipPip
  • 18 posts

Posted 05 June 2018 - 04:01 PM

i've just updated to 2.14.5-1 via AUR (Arch Linux / KDE Plasma).

 

The system tray icon works, but it's invisible. The context menu works if I right click on the invisible tray icon. No issue with other app icons...

 

It happens regarldess of the system theme (Breeze, materia-kde...). Maybe it was already invisible with previous build, I can't tell since I switched to Qomui a few weeks ago and was using MATE Desktop before.

You need to have either libappindicator-gtk2 or libappindicator-gtk3 installed for tray icon. It's under optional depencencies on AUR page.



#204 183aTr78f9o

183aTr78f9o

    Advanced Member

  • Members
  • PipPipPip
  • 56 posts

Posted 05 June 2018 - 04:38 PM

 

You need to have either libappindicator-gtk2 or libappindicator-gtk3 installed for tray icon. It's under optional depencencies on AUR page.

 

I know. Both libappindicator-gtk2 and libappindicator-gtk3 are installed on my machine, of course.

 

libappindicator-gtk2 is a required dependency though, not optional.

 

A.png

 

It's not a problem related to the system tray icon itself. It's there since I can get the context menu with a right click on it. it's just a graphical glitch or something with KDE Plasma. Maybe it's because of 2.14.5-1, maybe it's something on my end.

 

The system tray icon worked fine on MATE Desktop with previous 2.14 build as far as I'm concerned.



#205 meelosh

meelosh

    Member

  • Members
  • PipPip
  • 18 posts

Posted 05 June 2018 - 08:28 PM

 

You need to have either libappindicator-gtk2 or libappindicator-gtk3 installed for tray icon. It's under optional depencencies on AUR page.

 

I know. Both libappindicator-gtk2 and libappindicator-gtk3 are installed on my machine, of course.

 

libappindicator-gtk2 is a required dependency though, not optional.

 

attachicon.gifA.png

 

It's not a problem related to the system tray icon itself. It's there since I can get the context menu with a right click on it. it's just a graphical glitch or something with KDE Plasma. Maybe it's because of 2.14.5-1, maybe it's something on my end.

 

The system tray icon worked fine on MATE Desktop with previous 2.14 build as far as I'm concerned.

 

Then it's strange because I use Arch with KDE too and tray icon is displayed properly.



#206 user972512

user972512

    Member

  • Members
  • PipPip
  • 15 posts

Posted 07 June 2018 - 02:18 PM

Thanks for the new version.

 

Note: Tray icon finally worked in 2.14.3. Then in 2.14.4 it was gone again. I was hoping it would be back in 2.14.5 but it is not.

 

XUbuntu 16.04 LTS x86






2 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users


    Bing (1)
Servers online. Online Sessions: 14460 - BW: 55232 Mbit/sYour IP: 54.162.159.33Guest Access.