Jump to content


Photo

Eddie using port 89 even after specifying TCP port 443 in preferences

firewall; proxy; corporate network

  • Please log in to reply
3 replies to this topic

#1 arjubaburaj

arjubaburaj

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 19 December 2017 - 07:32 AM

Hey, I'm trying out Eddie to try and get out from a internal network. The complication is that only port 443 is allowed in the firewall. Even after configuring Eddie to use TCP 443, in the logs I noticed that Eddie is trying to access port 89 of the remote server which obviously will be blocked. Any workarounds.?

 

*I tried it out on a test environment. Apparently, this issue is only for the connection establishment phase. Once established, Eddie can happily take the traffic out through whatever ports is specified in the preferences.

 

 



#2 go558a83nk

go558a83nk

    Advanced Member

  • Members
  • PipPipPip
  • 1351 posts

Posted 19 December 2017 - 07:19 PM

AirVPN servers don't use port 89.  Post a log here so we can see what's up.



#3 arjubaburaj

arjubaburaj

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 21 December 2017 - 01:54 AM

here:
 
. 2017.12.19 15:23:13 - OpenVPN > ROUTE: CreateIpForwardEntry succeeded with dwForwardMetric1=20 and dwForwardType=4
. 2017.12.19 15:23:13 - OpenVPN > Route addition via IPAPI succeeded [adaptive]
. 2017.12.19 15:23:13 - Interface Local Area Connection 2 metric changed from Automatic to 3, layer IPv4
. 2017.12.19 15:23:13 - Interface Local Area Connection 2 metric changed from Automatic to 3, layer IPv6
. 2017.12.19 15:23:13 - DNS leak protection with packet filtering enabled.
. 2017.12.19 15:23:14 - Flushing DNS
I 2017.12.19 15:23:17 - Checking route
. 2017.12.19 15:23:17 - curl: (7) Failed to connect to hydra_exit.airservers.org port 89: Bad access
. 2017.12.19 15:23:17 - Checking route (2° try)
. 2017.12.19 15:23:18 - curl: (7) Failed to connect to hydra_exit.airservers.org port 89: Bad access
. 2017.12.19 15:23:18 - Checking route (3° try)
. 2017.12.19 15:23:21 - curl: (7) Failed to connect to hydra_exit.airservers.org port 89: Bad access
E 2017.12.19 15:23:21 - Checking route failed.
. 2017.12.19 15:23:21 - OpenVPN > Initialization Sequence Completed
! 2017.12.19 15:23:21 - Disconnecting
. 2017.12.19 15:23:21 - Sending management termination signal
. 2017.12.19 15:23:21 - Management - Send 'signal SIGTERM'
. 2017.12.19 15:23:21 - Connection terminated.


#4 go558a83nk

go558a83nk

    Advanced Member

  • Members
  • PipPipPip
  • 1351 posts

Posted 21 December 2017 - 02:44 AM

oh, you're connected just fine.  it's checking route that's failing.

 

In advanced settings disable the option to "check if the tunnel works" but I suggest you do use network lock, if you're not already.







Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14538 - BW: 48365 Mbit/sYour IP: 23.22.240.119Guest Access.