Jump to content


Photo

Ubuntu: Cant connect without VPN

Ubuntu linux iptables networkLock DNS Eddie trouble network-lock

  • Please log in to reply
6 replies to this topic

#1 Oberst

Oberst

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 28 October 2017 - 01:34 PM

Since yesterday I cant connect to any address without using Eddie. I deactivated network lock but I'm still not able to connect.

 

IPtables state:

sudo iptables --list
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

 

sudo ip6tables --list
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination

 

Content of /etc/resolv.conf:

# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
# 127.0.0.53 is the systemd-resolved stub resolver.
# run "systemd-resolve --status" to see details about the actual nameservers.

nameserver 127.0.0.53

 

Also ping to any address isnt working:

ping: google.com: Name or service not known

 

 

The connection through Eddie in any server of airVPN works without any troubles. Any ideas what is wrong?
 



#2 greerd

greerd

    Advanced Member

  • Members
  • PipPipPip
  • 50 posts

Posted 28 October 2017 - 08:58 PM

Can you ping an ip address? For example   ping 5.196.64.52    (from nslookup airvpn.org).

If so it sounds like your nameserver, you could try setting it to 8.8.8.8 for a test.



#3 Oberst

Oberst

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 31 October 2017 - 12:34 PM

Yeah it's an DNS Problem.

If I add Google DNS Servers in /etc/resolv.conf, all works fine.

But a new one appears. If I reboot Ubuntu, the resolv.conf file resets the original one again. (#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN)

Also I have no Idea why the DNS from my Provider doesn't work.

Any Idea?

 

# Google IPv4 nameservers
nameserver 8.8.8.8
nameserver 8.8.4.4

# Google IPv6 nameservers
nameserver 2001:4860:4860::8888
nameserver 2001:4860:4860::8844

 



#4 greerd

greerd

    Advanced Member

  • Members
  • PipPipPip
  • 50 posts

Posted 31 October 2017 - 08:04 PM

I think it depends on what you're running, if it's Ubuntu 16.10 or 17.04, take a look here.

 

https://superuser.com/questions/1153203/ubuntu-17-04-systemd-resolved-dns-lookups-randomly-fail



#5 jeffintexas

jeffintexas

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 02 November 2017 - 12:25 PM

A possible workaround is to lookup DNS servers addresses for your internet service provider.  Then, go to Network Connections and add a new network connection.

 

For the new network connection, under the IPv4 Settings, put a reliable DNS servers address for the internet service provider into the field for "DNS servers:" and save the new network connection.

 

Hopefully, when you switch to the new network connection, you will have non Eddie access to the internet.  The legacy network connection can be utilized to connect via Eddie.



#6 magnumpi

magnumpi

    Member

  • Members
  • PipPip
  • 24 posts

Posted 04 December 2017 - 03:47 PM

A possible workaround is to lookup DNS servers addresses for your internet service provider.  Then, go to Network Connections and add a new network connection.

 

For the new network connection, under the IPv4 Settings, put a reliable DNS servers address for the internet service provider into the field for "DNS servers:" and save the new network connection.

 

Hopefully, when you switch to the new network connection, you will have non Eddie access to the internet.  The legacy network connection can be utilized to connect via Eddie.

 

Dumb question (actually on Linux Mint) with same issue - how do you do this with a wifi connection? When I add the new connection do I need to set it up like a new wifi? The VPN is using that wifi?



#7 mvulpes

mvulpes

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 09 May 2018 - 03:40 PM

Since yesterday I cant connect to any address without using Eddie. I deactivated network lock but I'm still not able to connect.

 

The connection through Eddie in any server of airVPN works without any troubles. Any ideas what is wrong?
 

 

I had the same problem (under Ubuntu 17.10) and I managed to fix it using the first answer from this page, that is:

sudo rm -f /etc/resolv.conf
sudo dpkg-reconfigure resolvconf

Now everything works fine again.







Similar Topics Collapse


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14817 - BW: 58309 Mbit/sYour IP: 54.82.10.219Guest Access.