Jump to content


Photo

Torrent download speed went from 3~4mb/s (NO Airvpn connection) to 300~1000kb/s (Airvpn connected)

airvpn torrent BitTorrent noobie

  • Please log in to reply
No replies to this topic

#1 8b7q7JIwn3

8b7q7JIwn3

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 20 July 2017 - 04:12 AM

Hi, AirVPN Community

 

I just join the AirVPN community. I choose AirVPN becomes its open privacy policies and some advance features like SSL over VPN.

 

However, the Torrent download speed got me disappointed a little.

 

I did some speed test before I used Torrent client.  My Wifi Download speed was around 50 mbps and it dropped to 38~ mbps after I connected to AirVPN.

 

This is understandable since I know using VPN is bound to have some performance hit. At the end of the day, I was still able to stream 4k. So, it was all good.

 

Yet, when I tried BitTorrent to download something.  The difference was too drastic.  I could go from a download speed of 3~4 Mbyte/s when I NOT connected to AirVPN to somewhere around 300~1000 Kbyte/s when I connected.  The maximum torrent download speed with AirVPN connection I have seems was only around 1.2 Mbyte/s. That was about 80% drop in performance.

 

I have set up remote port forwarding, disable UPnP port mapping and NAT-PMP.  It didn't help.

 

I think since I could reach to 38~ mbps on Youtube with AirVPN, the only two explanations will be either AirVPN is not friendly to p2p, or my Torrent client and setting is not friendly to AirVPN.

 

I have tried pBittorrent but It was the same story.

 

Could you please share your thoughts on why would this happen?

 

Thank you very much!

 

=======================================================================================================================================================================

Update#1

 

I followed this post:https://airvpn.org/topic/23389-p2p-connection-slow-no-matter-what-i-do/

 

I changed the protocols to SSL:443, and used Ubuntu torrent to test the speed. It's working perfectly and I can see my speed went up to 8 Mbyte/s.

 

I don't know why it needs to be obfuscated with SSL.  If anyone knows the reason, please let me know.

 

Thank you!

=======================================================================================================================================================================

Update#2

 

The bottleneck seems came from UDP Protocols.  TCP Protocols is working fine as well.  My guess is UDP Protocol drops too many packets between me and vpn server.  I cannot get those losing packets from vpn server due to its UDP. So I had to keep requesting for losing packets from peers which makes other peers less likely to passing me more packets, or some of them simply just got timeout.







Similar Topics Collapse


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 14922 - BW: 47441 Mbit/sYour IP: 34.229.194.198Guest Access.