Jump to content


Photo

Network lock blocks access to sites with routing rules.

routes routing network lock eddie windows

Best Answer Staff, 09 June 2017 - 12:52 PM

For the readers: resolved. Customer was running a competing firewall simultaneously.

 

Kind regards

Go to the full post


  • This topic is locked This topic is locked
4 replies to this topic

#1 shivadiva

shivadiva

    Member

  • Members2
  • PipPip
  • 23 posts

Posted 07 June 2017 - 08:42 PM

Hi.

I configured Eddie so that the IPs of certain websites are accessed only from outside the VPN tunnel. (Settings -> Routes)

 

These routing rules work just fine, but as soon as I activate network lock I can't access the specified sites anymore.

 

I can ping them, but I can't access them inside the browser. They basically get blocked.

 

I tried multiple versions of Eddie (2.12.4, 2.11.15, 2.10.39, various protocols and ports and of course various websites.

I also tried both methods for network lock (Windows Firewall & Windows Filtering Platform).

 

I'm having this issue on both Windows 7 and Windows 10.

 

Any ideas how to fix this?

Anyone else having this problem?

 

Please, if you have any idea at all on how to fix this, let me know.

 

I really need both network lock and routing rules to work simultaneously.



#2 shivadiva

shivadiva

    Member

  • Members2
  • PipPip
  • 23 posts

Posted 09 June 2017 - 08:17 AM

I can't be the only one using both the Network Lock & Routes feature inside Eddie, can I?

Or am I really the only one who's having problems with it?

 

If someone reading this is currently using both features successfully on Windows, please let me know.

Then at least I'd know for sure it's something on my end.



#3 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7796 posts

Posted 09 June 2017 - 09:27 AM

Hello,

 

that was a bug affecting 2.10.3 and 2.11.x, but it has been fixed in 2.12.4. Can you please describe exactly the IP addresses combination/setup that causes the issue? A system report generated by Eddie will let us see the exact Eddie configuration and could provide precious clues. Click "Logs" tab, click the life belt icon and paste into your message.

 

Kind regards



#4 shivadiva

shivadiva

    Member

  • Members2
  • PipPip
  • 23 posts

Posted 09 June 2017 - 10:15 AM

Sure, I attached the log as .txt file.

Hopefully you'll spot something. Fingers crossed :)

 

I'm definitely using 2.12.4 though and it was also the first version I installed.

 

 

Attached Files

  • Attached File  log.txt   41.22K   217 downloads


#5 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7796 posts

Posted 09 June 2017 - 12:52 PM   Best Answer

For the readers: resolved. Customer was running a competing firewall simultaneously.

 

Kind regards







Similar Topics Collapse


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 15069 - BW: 50840 Mbit/sYour IP: 54.197.24.206Guest Access.