Jump to content


Photo

Windows 10 creator update Airvpn DNS slow ?


Best Answer Staff, 15 April 2017 - 04:34 PM

Hello!

 

EDIT: Eddie 2.13.2beta automatically lowers the tun/tap interface metric to fix the problems caused by the wrong DNS implementation by Microsoft. If you run Windows Creator please upgrade to Eddie 2.13. to solve the problem.

 

https://airvpn.org/topic/13002-experimentalbeta-release/

 

===

 

 

EDIT: After a deeper investigation the workaround published in this post might be not proper. If it does not work successfully for you, please consider to lower the metric of the tap adapter:

https://airvpn.org/topic/22650-windows-10-creator-update-airvpn-dns-slow/page-3#entry61332

 

 

Temporary workaround, until we release an update of Eddie

 

1. Disable IPv6
Control Panel\Network and Internet\Network Connections, Properties of your real (not TAP) network interface, uncheck Ipv6.

 

2. Disable SmartNameResolution
Run this .reg file: https://airvpn.org/repository/DisableSmartNameResolution.zip


Explanation

The same issue occurs also on plain OpenVPN 2.4 with directive block-outside-dns

From https://sourceforge.net/p/openvpn/mailman/message/35789733/

 

 

Windows 10 Anniversary Update changed the way DNS works. It used to resolve qualified names using all available adapters and IP addresses in parallel, now it still resolves addresses using all available adapters but in sequence, beginning with random adapter.
This interferes with how --block-outside-dns currently works. Sometimes OS chooses VPN TAP adapter and things work as intended, sometimes the other adapter and user have to wait until DNS request times out and name resolution goes via VPN DNS.

This behavior introduces significant lag for web browsing.

 

Eddie uses the same approach than ValdikSS "block-outside-dns" directive of OpenVPN: it blocks DNS query with WFP filters. With Windows 10 Creator build (1703) DNS resolution waits for the timeout of IPv6 resolutions (blocked by Eddie) and non-tunneled resolutions (also blocked by Eddie to prevent DNS leaks).

 

This issue will be addressed shortly by a new Eddie release.

 

Kind regards

Go to the full post


  • This topic is locked This topic is locked
53 replies to this topic

#21 JemTheWire

JemTheWire

    Member

  • Members2
  • PipPip
  • 21 posts
  • LocationUK

Posted 14 April 2017 - 06:42 AM

Work round didn't work for me either. As you commented, UL/DL speeds are good, DNS is soooo slooooow it completely spoils it.

Wish Staff would at least say they know about it and are working on a solution.

Asus RT-AC88U [Hardware:A2] Mode: Wireless Router

Firmware by @RMerlin


#22 kiwi

kiwi

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 14 April 2017 - 07:23 AM

i'm sorry, that it doesn't work for you.

i'm fine with no dns entry. when entering 10.4.x.x or my router adress (192.168.x.x) i have to wait up to 10 sec or more for a website to open.

 

by the way: with no pre-entered dns adress in the network adapter eddie doesn't enter the 10.4..x.x either, when started - but i'm in the tunnel ....

 

 

ps: even mac users seem to have dns problems right now ...

https://airvpn.org/topic/22679-checking-dns-dont-match-os-x/



#23 U&^TUB&NI

U&^TUB&NI

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 14 April 2017 - 08:01 PM

I submitted this as a support ticket and was told they "couldn't reproduce the problem". So those of us who continue using AirVPN may be on our own.

 

Just as an update, I have also tried using a non-VPN DNS resolver address (Google's) entered explicitly in the IPv4 config for the TAP device. This does not solve the problem of DNS resolution taking ten seconds each.

 

Any other workarounds till they get this fixed?



#24 trev

trev

    Member

  • Members
  • PipPip
  • 19 posts

Posted 14 April 2017 - 11:45 PM

I was concerned when I read this Thread, but on the one PC that upgraded to the Creator's Update, I am having no speed problems with Air. using Eddie latest, portable.



#25 Bong_Marley

Bong_Marley

    Newbie

  • Members
  • Pip
  • 8 posts

Posted 15 April 2017 - 05:13 AM

Been havin' the same problem since I updated, but I managed to solve it by reinstalling Eddie:

 

* Uninstall Eddie through Apps & Features (formerly Programs & Features)

* Uninstall TAP-Windows through Apps & Features

* Open Windows Powershell (Admin) or a Command Prompt (Admin) and type: 'netsh winsock reset' en hit enter

* Open Windows Firewall and click 'Restore defaults'

* Restart the computer

* Download the latest version of Eddie

* Install it and your good to go :)

 

Eddie is btw the name of the AirVPN client ;).



#26 kbps

kbps

    Advanced Member

  • Members2
  • PipPipPip
  • 99 posts

Posted 15 April 2017 - 07:51 AM

Been havin' the same problem since I updated, but I managed to solve it by reinstalling Eddie:

 

* Uninstall Eddie through Apps & Features (formerly Programs & Features)

* Uninstall TAP-Windows through Apps & Features

* Open Windows Powershell (Admin) or a Command Prompt (Admin) and type: 'netsh winsock reset' en hit enter

* Open Windows Firewall and click 'Restore defaults'

* Restart the computer

* Download the latest version of Eddie

* Install it and your good to go :)

 

Eddie is btw the name of the AirVPN client ;).

 

 

Has anybody else tried this??  Does it work?



#27 kiwi

kiwi

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 15 April 2017 - 08:16 AM

@ U&^TUB&NI

thanks for your efforts! i really don't know where to search for the solution, because i didn't change anything in my setup - - just made the creators update/upgrade ...

 

@ kbps

i have been running eddie portable before and after the upgrade, so this will not work for me.



#28 kadett

kadett

    Newbie

  • Members
  • Pip
  • 1 posts

Posted 15 April 2017 - 09:13 AM

Hi

 

I have the same problem using another VPN client. And found this site searching for a solution so I guess it affect other VPN as well.

Anyway I found out that if I give the metric cost for the TAP VPN network adaptor under IP advanced to a fixed cost 15 and change the cost on the standard network adapter to

25 everything works fine again. It might be a working solution for you as well.

 

141ocpi.jpg



#29 RobertM

RobertM

    Newbie

  • Members
  • Pip
  • 2 posts

Posted 15 April 2017 - 09:50 AM

Been havin' the same problem since I updated, but I managed to solve it by reinstalling Eddie:

 

* Uninstall Eddie through Apps & Features (formerly Programs & Features)

* Uninstall TAP-Windows through Apps & Features

* Open Windows Powershell (Admin) or a Command Prompt (Admin) and type: 'netsh winsock reset' en hit enter

* Open Windows Firewall and click 'Restore defaults'

* Restart the computer

* Download the latest version of Eddie

* Install it and your good to go :)

 

Eddie is btw the name of the AirVPN client ;).

 

Has anybody else tried this??  Does it work?

I tried this, but it didn't fix the problem.



#30 Obvious

Obvious

    Newbie

  • Members
  • Pip
  • 6 posts

Posted 15 April 2017 - 11:02 AM

Hi, as all of you since the upgrade of Windows 10 creator update, I too have very slow DNS lookup, and since many websites do lookup many domains at a single page like trackers or ads, loading takes significant time until the DNS cache on a local machine fills with DNS grabbed already.

 

But I know what causes this. The assumption is that it is Airvpn Client Eddie or Airvpn DNS doing this, however you can change your DNS even with Networklock Enabled into anything you like, and that is why I explain what is happening.

 

Almost all VPN providers rely on OpenVPN TAP Adapter, so does Eddie, but Airvpn does not create OpenVPN TAP Adapter Driver, currently TAP-Windows Provider V9, dated 21-4-2016, version 9.0.0.21 made and maintained for many Operating System platforms by OpenVPN Technologies, Inc.

 

You should therefore search at google for OpenVPN DNS slow after Windows 10 creator update, you will find unfortunately only a few topics but for me I place my findings here. The problem is, Microsoft on Windows has to Digital Sign and allow OpenVPN Technologies, Inc. to release a new OpenVPN TAP Adapter Driver that knows and is bug fixed (caused by Microsoft in my opinion) about how to handle Windows 10 Creator Update released in April 2017. 

 

So Airvpn can try whatever, but Eddie Client is just fine, the error is not in there. Nor in Airvpn DNS servers or any other DNS server you can configure.

 

It's Microsoft or OpenVPN Technologies, Inc. and I don't think Microsoft is in a hurry to not push their own VPN build into Windows 10.

 

It will be resolved, but now you know the cause, this is my first post, and I hope I answered your questions. So many people rely on OpenVPN TAP Adapter Driver, and latest driver signed by Microsoft is dated as I explained long ago in terms of computer science 21-4-2016.

 

But I hope all providers using OpenVPN will push the right buttons somewhere in rainbow computerland.



#31 raoulduke

raoulduke

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 15 April 2017 - 11:11 AM

Hi

 

I have the same problem using another VPN client. And found this site searching for a solution so I guess it affect other VPN as well.

Anyway I found out that if I give the metric cost for the TAP VPN network adaptor under IP advanced to a fixed cost 15 and change the cost on the standard network adapter to

25 everything works fine again. It might be a working solution for you as well.

 

141ocpi.jpg

 

 

And that worked for me ! Thank you @kadett :good:



#32 kiwi

kiwi

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 15 April 2017 - 11:40 AM

thank you, kadett!

unfortunately it doesn't work for me. still slow dns resolution.

i get the best results with 'my dns-workaround'.

 

by the way:

just did a clean install of the creators iso.

when starting eddie i get a 'checking route don't match loop'.



#33 FromtheWalls

FromtheWalls

    Advanced Member

  • Members
  • PipPipPip
  • 87 posts

Posted 15 April 2017 - 11:57 AM

@kadett That seems to work perfectly, thanks a lot for providing us the fix for this very frustrating problem, much appreciated! :good:



#34 kbps

kbps

    Advanced Member

  • Members2
  • PipPipPip
  • 99 posts

Posted 15 April 2017 - 12:15 PM

Been havin' the same problem since I updated, but I managed to solve it by reinstalling Eddie:

 

* Uninstall Eddie through Apps & Features (formerly Programs & Features)

* Uninstall TAP-Windows through Apps & Features

* Open Windows Powershell (Admin) or a Command Prompt (Admin) and type: 'netsh winsock reset' en hit enter

* Open Windows Firewall and click 'Restore defaults'

* Restart the computer

* Download the latest version of Eddie

* Install it and your good to go :)

 

Eddie is btw the name of the AirVPN client ;).

 

 

Has anybody else tried this??  Does it work?

 

 

Update.  I tried this and it didn't work for me.  



#35 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7801 posts

Posted 15 April 2017 - 04:34 PM   Best Answer

Hello!

 

EDIT: Eddie 2.13.2beta automatically lowers the tun/tap interface metric to fix the problems caused by the wrong DNS implementation by Microsoft. If you run Windows Creator please upgrade to Eddie 2.13. to solve the problem.

 

https://airvpn.org/topic/13002-experimentalbeta-release/

 

===

 

 

EDIT: After a deeper investigation the workaround published in this post might be not proper. If it does not work successfully for you, please consider to lower the metric of the tap adapter:

https://airvpn.org/topic/22650-windows-10-creator-update-airvpn-dns-slow/page-3#entry61332

 

 

Temporary workaround, until we release an update of Eddie

 

1. Disable IPv6
Control Panel\Network and Internet\Network Connections, Properties of your real (not TAP) network interface, uncheck Ipv6.

 

2. Disable SmartNameResolution
Run this .reg file: https://airvpn.org/repository/DisableSmartNameResolution.zip


Explanation

The same issue occurs also on plain OpenVPN 2.4 with directive block-outside-dns

From https://sourceforge.net/p/openvpn/mailman/message/35789733/

 

 

Windows 10 Anniversary Update changed the way DNS works. It used to resolve qualified names using all available adapters and IP addresses in parallel, now it still resolves addresses using all available adapters but in sequence, beginning with random adapter.
This interferes with how --block-outside-dns currently works. Sometimes OS chooses VPN TAP adapter and things work as intended, sometimes the other adapter and user have to wait until DNS request times out and name resolution goes via VPN DNS.

This behavior introduces significant lag for web browsing.

 

Eddie uses the same approach than ValdikSS "block-outside-dns" directive of OpenVPN: it blocks DNS query with WFP filters. With Windows 10 Creator build (1703) DNS resolution waits for the timeout of IPv6 resolutions (blocked by Eddie) and non-tunneled resolutions (also blocked by Eddie to prevent DNS leaks).

 

This issue will be addressed shortly by a new Eddie release.

 

Kind regards



#36 U&^TUB&NI

U&^TUB&NI

    Newbie

  • Members
  • Pip
  • 5 posts

Posted 15 April 2017 - 04:59 PM

Changing the metric (kadett's post) fixed the problem for me.

 

And in reference to an earlier post, I have assumed all along that this was a problem caused by Microsoft, not by AirVPN software.

 

AirVPN has listed a workaround and I'm sure will have a permanent fix in a future software release.

 

Thanks.



#37 kiwi

kiwi

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 15 April 2017 - 05:37 PM

Great news!

Thank you, staff! :good:



#38 JemTheWire

JemTheWire

    Member

  • Members2
  • PipPip
  • 21 posts
  • LocationUK

Posted 15 April 2017 - 05:47 PM

Doesn't work for me. I get 'DNS Don't Match' in Eddie. Even after a reboot. It's completely kill my AirVPN now!


Asus RT-AC88U [Hardware:A2] Mode: Wireless Router

Firmware by @RMerlin


#39 kiwi

kiwi

    Advanced Member

  • Members
  • PipPipPip
  • 62 posts

Posted 15 April 2017 - 06:26 PM

didn't work for me either.

you can make it undone by the following:

 

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\DNSClient]
"DisableSmartNameResolution"=dword:00000000

 

ps: don't forget to reboot



#40 JemTheWire

JemTheWire

    Member

  • Members2
  • PipPip
  • 21 posts
  • LocationUK

Posted 15 April 2017 - 06:34 PM

I did reboot. It's the registry entry that causes the 'DNS Don't Match' problem. It took it one step at a time. When I just disabled IPv6 Eddie still connected but after I made the registry entry, it killed it.

Asus RT-AC88U [Hardware:A2] Mode: Wireless Router

Firmware by @RMerlin






Similar Topics Collapse

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 13671 - BW: 52061 Mbit/sYour IP: 34.229.175.129Guest Access.