Jump to content


Photo

AirVPN works on WiFi NIC but not on LAN NIC


  • Please log in to reply
3 replies to this topic

#1 lyptow

lyptow

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 10 January 2017 - 12:13 PM

Hi Everybody !


I have some trouble to make AirVPN worked on Ethernet LAN NIC while it works on WiFi NIC. My Laptop (W10 64 bit Pro) have 2 NICs :


LAN (Ethernet 1 Gigabit) : Realtek PCIe GBE Family Controller - DHCP auto IP and DNS

WiFi  :  Qualcomm Atheros AR9485WB-EG Wireless Network Adapter - DHCP auto IP and DNS

TAP : TAP-Windows Adapter V9

My ISP : Orange (FR) FTTH 100 Mbps

My client : airvpn W10 64bit portable, protocol UDP 443

Test 1 : trying to connect on recommended server with LAN NIC


Spoiler


As you can see in the log, it doesn't work.

Test 2 : trying to connect on recommended server with WiFi NIC

Spoiler


On WiFi it works.

I think it's TAP NIC that screw up when i use Ethernet Cable on LAN NIC. Of course I uninstall my TAP and reinstall it, but it still doesn't work. I reseted W10 tcp ip stack but it changes nothing (by following https://community.openvpn.net/openvpn/wiki/reset-network-tcp-ip-stack).

I have no idea what's happening.
Ask me if you need more infos / log etc.

 

Thanks

 

EDIT 1 : in the log, we see "Le nom distant n'a pas pu être résolu ......... " (i.e The remote name could not be resolved ...) but my DNS are OK.



#2 LZ1

LZ1

    It's nice to be nice to nice people

  • Members
  • PipPipPip
  • 1375 posts

Posted 10 January 2017 - 01:54 PM

Hello!

 

Please feel free to disable IPv6 and also try the Beta client.


Open This Spoiler If: A Website Is Blocked, You Want To Help AirVPN, Find The Beta/Experimental Client Or You're A New User Wanting Help/Information

Spoiler

Did you make a guide or how-to for something? Then contact me if you want me to index it in my new user guide, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.


#3 zhang888

zhang888

    Donald Trump of IT/Security

  • Moderators
  • 1947 posts

Posted 10 January 2017 - 03:15 PM

Make sure your DNS are set to automatic in your LAN adapter.


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.


#4 lyptow

lyptow

    Newbie

  • New Members
  • Pip
  • 2 posts

Posted 10 January 2017 - 03:56 PM

My NICs are on DHCP (so it's automatic) for IP and DNS configuration. IPv6 is disabled on all NICs.

 

Edit 1 : I disabled all my Firewall and any kind of protection, I dowloaded Experimental Client Eddie, with default client configuration it doesn't work.

 

Edit 2 : I disabled DNS Switch Mode, it works

 

-> Conclusion : it's a DNS forcing issue

 

Edit 3 : is this a problem ? what is DNS Switch Mode ?

 

On ipleak.net, I can see that my DNS is the AIR server







Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Users: 13820 - BW: 46163 Mbit/sYour IP: 54.80.29.228Guest Access.