Jump to content


Setting up SSH on Linux with OpenVPN

linux ssh openvpn

  • Please log in to reply
3 replies to this topic

#1 Zosimos



  • Members
  • Pip
  • 7 posts

Posted 16 December 2016 - 01:42 AM

I am trying to use AirVPN to SSH into a computer. How do I do this?

I have tried the .sh file I got from the SSH tutorial, but when I try to connect to the computer running it, I can never log in (permission denied).

Trying to use OpenVPN as root with the .ovpn file caused errors about not being able to connect.

#2 cm0s


    Advanced Member

  • Members
  • PipPipPip
  • 288 posts
  • LocationClarion, PA

Posted 16 December 2016 - 12:55 PM

good to meet ya, yer first post

aaahhhhh the ssh joyz, i still get them myself

easiest way to get help with your ssh is post up some logs
use verbose blur out anything don't want others to read
or copy paste and use 'xxxxx' sumthin like that

here's a link to help with troubleshooting
but back to your question first it could literally be a number of things
why the logs will help so can at least narrow it down

for myself a lot of the times yeah it was permissions and i had my permissions set wrong
another time i forgot i had my firewall to allow only xyz ip addy and that was on my own
network, i literally spent a few hours 'troubleshooting' my own security i set in place

tbh what i basically did when starting out on ssh was dial into the box next to me and just kept tweaken it
till i got the security settings i liked and the configs i liked

one time i forgot to turn ssh on on the other box so can be many things
sometimes it'd work for me other times not you can copy id and it's automagical

anyway here's a link to help in the meantime:


#3 Zosimos



  • Members
  • Pip
  • 7 posts

Posted 28 December 2016 - 07:02 PM



I realized I was doing something wrong, and now I realize I probably should run the sh file on the target PC (one I want to connect to with SSH) and the ovpn file on the PC I am trying to connect with (the 'client'). Or maybe the other way around? Either way, I still get connection problems.


When running the ovpn file, I get "TCP: connect to [AF_INET] failed" on both client and target.


Using the sh file on the client machine I get prompted for sshtunnel@[target's AirVPN IP address]'s password, and on the target machine I get "ssh: connect to host [target's AirVPN IP address] port 22: No route to host"


The ssh daemon is turned on for the target, but not the client.

#4 dr_kristau



  • Members
  • PipPip
  • 15 posts
  • LocationUTC+01:00

Posted 29 December 2016 - 04:39 PM

anyway here's a link to help in the meantime:



Does this mean we need an SSH server and not just the client to get the AirVPN ovpn file to run? I'm still getting the " failed" error when I run it. Thanks!

Similar Topics Collapse

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 13335 - BW: 38152 Mbit/sYour IP: Access.