Jump to content


Photo

OSX Sierra: AirVPN Client connection issues

osx sierra airvpn disconnect client

  • Please log in to reply
7 replies to this topic

#1 underxposedbody

underxposedbody

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 08 December 2016 - 02:08 AM

Hi

 

I have never been able to connect with the AirVPN client on OSX Sierra.

 

It connects through the Windows client, Tunnelblick and OpenVPN but I would like to use the AirVPN client for more control.

 

Can someone please suggest something.

 

Here's my log:

 

 

I 2016.12.08 01:57:36 - AirVPN client version: 2.10.3 / x86, System: OSX, Name: 10.12.1 / x64
. 2016.12.08 01:57:36 - Reading options from /Users/XXX/.airvpn/AirVPN.xml
. 2016.12.08 01:57:36 - Data Path: /Users/XXX/.airvpn
. 2016.12.08 01:57:36 - App Path: /Applications/AirVPN.app/Contents/MacOS
. 2016.12.08 01:57:36 - Executable Path: /Applications/AirVPN.app/Contents/MacOS/AirVPN
. 2016.12.08 01:57:36 - Command line arguments (1): gui.osx.style="dark"
. 2016.12.08 01:57:36 - Updating systems & servers data ...
. 2016.12.08 01:57:36 - Operating System: Unix 16.1.0.0 - Darwin XXXXX.local 16.1.0 Darwin Kernel Version 16.1.0: Thu Oct 13 21:26:57 PDT 2016; root:xnu-3789.21.3~60/RELEASE_X86_64 x86_64
I 2016.12.08 01:57:36 - OpenVPN Driver - Expected
I 2016.12.08 01:57:36 - OpenVPN - Version: OpenVPN 2.3.8 (/Applications/AirVPN.app/Contents/MacOS/openvpn)
I 2016.12.08 01:57:36 - SSH - Version: OpenSSH_7.2p2, LibreSSL 2.4.1 (/usr/bin/ssh)
I 2016.12.08 01:57:36 - SSL - Version: stunnel 5.17 (/Applications/AirVPN.app/Contents/MacOS/stunnel)
I 2016.12.08 01:57:36 - Session starting.
. 2016.12.08 01:57:36 - Systems & servers data update completed
I 2016.12.08 01:57:40 - Checking authorization ...
! 2016.12.08 01:57:40 - Connecting to Alphard (Netherlands, Alblasserdam)
. 2016.12.08 01:57:40 - OpenVPN > OpenVPN 2.3.8 x86_64-apple-darwin14.4.0 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on Aug 13 2015
. 2016.12.08 01:57:40 - OpenVPN > library versions: OpenSSL 1.0.2d 9 Jul 2015, LZO 2.08
. 2016.12.08 01:57:40 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known
. 2016.12.08 01:57:40 - OpenVPN > Exiting due to fatal error
! 2016.12.08 01:57:40 - Disconnecting
. 2016.12.08 01:57:40 - Connection terminated.
I 2016.12.08 01:57:43 - Checking authorization ...
! 2016.12.08 01:57:44 - Connecting to Alphard (Netherlands, Alblasserdam)
. 2016.12.08 01:57:44 - OpenVPN > OpenVPN 2.3.8 x86_64-apple-darwin14.4.0 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on Aug 13 2015
. 2016.12.08 01:57:44 - OpenVPN > library versions: OpenSSL 1.0.2d 9 Jul 2015, LZO 2.08
. 2016.12.08 01:57:44 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known
. 2016.12.08 01:57:44 - OpenVPN > Exiting due to fatal error
! 2016.12.08 01:57:44 - Disconnecting
. 2016.12.08 01:57:44 - Connection terminated.
I 2016.12.08 01:57:45 - Cancel requested.
! 2016.12.08 01:57:45 - Session terminated.
I 2016.12.08 02:00:07 - Session starting.
I 2016.12.08 02:00:07 - Checking authorization ...
! 2016.12.08 02:00:07 - Connecting to Alphard (Netherlands, Alblasserdam)
. 2016.12.08 02:00:07 - OpenVPN > OpenVPN 2.3.8 x86_64-apple-darwin14.4.0 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on Aug 13 2015
. 2016.12.08 02:00:08 - OpenVPN > library versions: OpenSSL 1.0.2d 9 Jul 2015, LZO 2.08
. 2016.12.08 02:00:08 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known
. 2016.12.08 02:00:08 - OpenVPN > Exiting due to fatal error
! 2016.12.08 02:00:08 - Disconnecting
. 2016.12.08 02:00:08 - Connection terminated.
I 2016.12.08 02:00:11 - Checking authorization ...
! 2016.12.08 02:00:11 - Connecting to Alphard (Netherlands, Alblasserdam)
. 2016.12.08 02:00:11 - OpenVPN > OpenVPN 2.3.8 x86_64-apple-darwin14.4.0 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on Aug 13 2015
. 2016.12.08 02:00:11 - OpenVPN > library versions: OpenSSL 1.0.2d 9 Jul 2015, LZO 2.08
. 2016.12.08 02:00:11 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known
. 2016.12.08 02:00:11 - OpenVPN > Exiting due to fatal error
! 2016.12.08 02:00:11 - Disconnecting
. 2016.12.08 02:00:11 - Connection terminated.
I 2016.12.08 02:00:14 - Checking authorization ...
! 2016.12.08 02:00:14 - Connecting to Alphard (Netherlands, Alblasserdam)
. 2016.12.08 02:00:14 - OpenVPN > OpenVPN 2.3.8 x86_64-apple-darwin14.4.0 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on Aug 13 2015
. 2016.12.08 02:00:14 - OpenVPN > library versions: OpenSSL 1.0.2d 9 Jul 2015, LZO 2.08
. 2016.12.08 02:00:14 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known
. 2016.12.08 02:00:14 - OpenVPN > Exiting due to fatal error
! 2016.12.08 02:00:14 - Disconnecting
. 2016.12.08 02:00:14 - Connection terminated.
I 2016.12.08 02:00:17 - Checking authorization ...
! 2016.12.08 02:00:18 - Connecting to Alphard (Netherlands, Alblasserdam)
. 2016.12.08 02:00:18 - OpenVPN > OpenVPN 2.3.8 x86_64-apple-darwin14.4.0 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on Aug 13 2015
. 2016.12.08 02:00:18 - OpenVPN > library versions: OpenSSL 1.0.2d 9 Jul 2015, LZO 2.08
. 2016.12.08 02:00:18 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known
. 2016.12.08 02:00:18 - OpenVPN > Exiting due to fatal error
! 2016.12.08 02:00:18 - Disconnecting
. 2016.12.08 02:00:18 - Connection terminated.
I 2016.12.08 02:00:19 - Cancel requested.
! 2016.12.08 02:00:19 - Session terminated.
 
 


#2 Keksjdjdke

Keksjdjdke

    Advanced Member

  • Members
  • PipPipPip
  • 188 posts

Posted 08 December 2016 - 07:11 AM

Try updating to the latest beta of the Eddie client.

#3 Khariz

Khariz

    Advanced Member

  • Members
  • PipPipPip
  • 415 posts

Posted 08 December 2016 - 03:10 PM

underxposedbody,

 

You are having a DNS issue with Eddie.  The DNS lookup for the servers is failing.  Check the DNS settings on the adapter.  

 

But yeah, if you upgrade to the 2.11.9 experimental build, Eddie works okay in Siiera.  You get some odd errors, but it pushes through, and everything works properly.  



#4 underxposedbody

underxposedbody

    Newbie

  • New Members
  • Pip
  • 3 posts

Posted 13 December 2016 - 07:40 AM

Thanks for the tips.

 

I tried the experimental version but still nothing. Then checked my adapter settings and I had set the DNS to Google's 8.8.8.8 instead of leaving it as my ISP default.

 

Deleting this made the client work.  :)



#5 Shamerock

Shamerock

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 24 December 2016 - 01:09 AM

Not sure if I should start a new thread, but thought maybe you guys could help out if you had similar issues.  So I pretty recently introduced OSx into my life.  Still making adjustments, came from win where at a time I hadn't yet started to place as much on priv, anon, and security.  Used to torrent a lot, god knows how much a/v i had on my now bricked hp, after, you guessed it, upgrading to Windows10.  May revisit it down the line and run linux, some such.  Sorry, I digress.  SO, I am not sure what I'm doing wrong, and I've really been trying to beef up on reading in the forums, LZ's how to guides etc.  Yet to no avail do I find myself able to connect using the air over TOR protocol successfully.  I've really been trying not to ask questions since I joined the community and defer to the forums for when I do incur trouble, and as much I hate to admit it, I do need a little hand holding here.  Not sure if anyone else had problems when adjusting or if I'm that much of a fucktard.  Guessing its the latter.  Any help much appreciated



#6 LZ1

LZ1

    It's nice to be nice to nice people

  • Members
  • PipPipPip
  • 1476 posts

Posted 24 December 2016 - 01:22 AM

Not sure if I should start a new thread, but thought maybe you guys could help out if you had similar issues.  So I pretty recently introduced OSx into my life.  Still making adjustments, came from win where at a time I hadn't yet started to place as much on priv, anon, and security.  Used to torrent a lot, god knows how much a/v i had on my now bricked hp, after, you guessed it, upgrading to Windows10.  May revisit it down the line and run linux, some such.  Sorry, I digress.  SO, I am not sure what I'm doing wrong, and I've really been trying to beef up on reading in the forums, LZ's how to guides etc.  Yet to no avail do I find myself able to connect using the air over TOR protocol successfully.  I've really been trying not to ask questions since I joined the community and defer to the forums for when I do incur trouble, and as much I hate to admit it, I do need a little hand holding here.  Not sure if anyone else had problems when adjusting or if I'm that much of a fucktard.  Guessing its the latter.  Any help much appreciated

Hello!

 

Presuming you're using the Eddie 2.10 client, you go to the Protocols section, click Tor, save and then open the Tor browser. Then back to the client and click the "test" button in the same area. Or does this not work? Do you get any error messages or such?

 

No need to be so hard on yourself my friend. It can be confusing going to a different system :). Since you've tried to find the information you needed without luck, you already earned the right to ask for help, for sure ^^.


Open This Spoiler If: A Website Is Blocked, You Want To Help AirVPN, Find The Beta/Experimental Client Or You're A New User Wanting Help/Information

Spoiler

Did you make a guide or how-to for something? Then contact me if you want me to index it in my new user guide, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.


#7 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7022 posts

Posted 24 December 2016 - 08:42 AM

. 2016.12.08 01:57:40 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known

 

 

Hello!

 

The problem is showed in the quoted log entry: your system can't resolve "localhost". Somehow your system hosts file has been wrongly modified, or corrupted.

Please make sure that in your hosts file the first hosts block line is:
127.0.0.1 localhost

How to edit hosts file in various Mac systems:

https://www.tekrevue.com/tip/edit-hosts-file-mac-os-x/

 

Kind regards
 



#8 Shamerock

Shamerock

    Newbie

  • New Members
  • Pip
  • 4 posts

Posted 13 January 2017 - 09:12 PM

Not sure if I should start a new thread, but thought maybe you guys could help out if you had similar issues.  So I pretty recently introduced OSx into my life.  Still making adjustments, came from win where at a time I hadn't yet started to place as much on priv, anon, and security.  Used to torrent a lot, god knows how much a/v i had on my now bricked hp, after, you guessed it, upgrading to Windows10.  May revisit it down the line and run linux, some such.  Sorry, I digress.  SO, I am not sure what I'm doing wrong, and I've really been trying to beef up on reading in the forums, LZ's how to guides etc.  Yet to no avail do I find myself able to connect using the air over TOR protocol successfully.  I've really been trying not to ask questions since I joined the community and defer to the forums for when I do incur trouble, and as much I hate to admit it, I do need a little hand holding here.  Not sure if anyone else had problems when adjusting or if I'm that much of a fucktard.  Guessing its the latter.  Any help much appreciated

Hello!

 

Presuming you're using the Eddie 2.10 client, you go to the Protocols section, click Tor, save and then open the Tor browser. Then back to the client and click the "test" button in the same area. Or does this not work? Do you get any error messages or such?

 

No need to be so hard on yourself my friend. It can be confusing going to a different system :). Since you've tried to find the information you needed without luck, you already earned the right to ask for help, for sure ^^.

 

Hello my good man,

I much appreciate teh response, and I would have gotten back sooner but I've taken ill over the past several weeks.  Right around the time I made the post, and it has been a roller coaster since.  But the strange southwest weather and people can't kill me.  Anyway so following those steps, it reads in the initial start up status window: establishing an encrypted directory connection.  
Please wait while we establish a connection to the Tor network, this may take several minutes. 

browser logs -

 

 

Spoiler

1/13/17, 12:34:11.300 [NOTICE] Bootstrapped 5%: Connecting to directory server
1/13/17, 12:34:11.300 [NOTICE] Bootstrapped 10%: Finishing handshake with directory server
1/13/17, 12:36:11.700 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
1/13/17, 12:36:11.700 [WARN] Proxy Client: unable to connect to 171.25.193.77:443 ("TTL expired")
1/13/17, 12:36:12.700 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
1/13/17, 12:36:12.700 [WARN] Proxy Client: unable to connect to 46.28.110.244:443 ("TTL expired")
1/13/17, 12:36:16.700 [NOTICE] Tried for 120 seconds to get a connection to [scrubbed]:443. Giving up. (waiting for circuit)
1/13/17, 12:36:16.700 [WARN] Proxy Client: unable to connect to 195.154.79.128:443 ("TTL expired")
1/13/17, 12:36:23.100 [NOTICE] Closing no-longer-configured Socks listener on 127.0.0.1:9150
1/13/17, 12:36:23.100 [NOTICE] DisableNetwork is set. Tor will not make or accept non-control network connections. Shutting down all existing connections.
1/13/17, 12:36:23.100 [NOTICE] Closing old Socks listener on 127.0.0.1:9150
1/13/17, 12:36:23.100 [WARN] Tor cannot connect to the Internet if ReachableAddresses, ReachableORAddresses, or ReachableDirAddresses reject all addresses. Please accept some addresses in these options.
1/13/17, 12:36:23.700 [NOTICE] Delaying directory fetches: DisableNetwork is set.







Similar Topics Collapse


4 user(s) are reading this topic

0 members, 4 guests, 0 anonymous users

Servers online. Online Sessions: 14123 - BW: 45196 Mbit/sYour IP: 54.226.41.91Guest Access.