Jump to content


Photo

OpenVPN > RESOLVE: Cannot resolve host address


Best Answer Staff, 06 August 2016 - 07:05 PM

Yes, it's there the first line. Like I said, Tunnelblick and Viscocity there is no problems. But I want to be able to have network

lock in case of a disconnection.

It seems to me that this is an issue with the client.

 

Hello!

 

As you can see here:

. 2016.08.06 01:54:30 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known

 

the problem is in your system. A system MUST be able to resolve name "localhost".

 

You don't find this problem in Tunnelblick because it contacts OpenVPN management at 127.0.0.1, but Eddie approach is more correct. You might experience additional problems if you don't make your system capable to resolve localhost.

 

In El Capitan the hosts file is /private/etc/hosts

 

Quick guide to edit it: https://www.ihash.eu/2015/09/how-to-edit-hosts-file-in-mac-os-x-10-11-el-capitan/

 

Kind regards

Go to the full post


  • Please log in to reply
5 replies to this topic

#1 juancarlos101

juancarlos101

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 06 August 2016 - 06:08 AM

Everything was working well. Then updated my router, connected to the internet and no problem with my windows machines. However, none of my Mac ElCapitan work. If I use Viscosity, no problems.

I can't figure this out. Been at it for 5 hours.

Thank you in advance.

 

I 2016.08.06 01:53:53 - Eddie client version: 2.11.3 / x86, System: OSX, Name: 10.11.6 / x64
. 2016.08.06 01:53:53 - Reading options from /Users/johnr/.airvpn/AirVPN.xml
. 2016.08.06 01:53:53 - Data Path: /Users/johnr/.airvpn
. 2016.08.06 01:53:53 - App Path: /Applications/AirVPN.app/Contents/MacOS
. 2016.08.06 01:53:53 - Executable Path: /Applications/AirVPN.app/Contents/MacOS/AirVPN
. 2016.08.06 01:53:53 - Command line arguments (0):
. 2016.08.06 01:53:53 - Operating System: Unix 15.6.0.0 - Darwin MacBook-Pro.local 15.6.0 Darwin Kernel Version 15.6.0: Thu Jun 23 18:25:34 PDT 2016; root:xnu-3248.60.10~1/RELEASE_X86_64 x86_64
I 2016.08.06 01:53:53 - OpenVPN Driver - Expected
I 2016.08.06 01:53:53 - OpenVPN - Version: OpenVPN 2.3.11 (/Applications/AirVPN.app/Contents/MacOS/openvpn)
I 2016.08.06 01:53:53 - SSH - Version: OpenSSH_6.9p1, LibreSSL 2.1.8 (/usr/bin/ssh)
I 2016.08.06 01:53:53 - SSL - Version: stunnel 5.32 (/Applications/AirVPN.app/Contents/MacOS/stunnel)
! 2016.08.06 01:53:53 - Activation of Network Lock - OS X - PF
. 2016.08.06 01:53:53 - OS X - PF rules updated, reloading
! 2016.08.06 01:53:54 - Ready
. 2016.08.06 01:53:54 - Updating systems & servers data ...
. 2016.08.06 01:53:58 - Systems & servers data update completed
I 2016.08.06 01:53:59 - Session starting.
I 2016.08.06 01:53:59 - IPv6 disabled on network adapter (Ethernet)
I 2016.08.06 01:53:59 - IPv6 disabled on network adapter (FireWire)
I 2016.08.06 01:53:59 - IPv6 disabled on network adapter (Wi-Fi)
I 2016.08.06 01:53:59 - IPv6 disabled on network adapter (Thunderbolt Bridge)
I 2016.08.06 01:53:59 - Checking authorization ...
! 2016.08.06 01:54:00 - Connecting to Alya (Canada, Toronto, Ontario)
. 2016.08.06 01:54:00 - OpenVPN > OpenVPN 2.3.11 x86_64-apple-darwin15.5.0 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on May 19 2016
. 2016.08.06 01:54:00 - OpenVPN > library versions: OpenSSL 1.0.2h  3 May 2016, LZO 2.09
. 2016.08.06 01:54:30 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known
. 2016.08.06 01:54:30 - OpenVPN > Exiting due to fatal error
! 2016.08.06 01:54:30 - Disconnecting
. 2016.08.06 01:54:30 - Connection terminated.
I 2016.08.06 01:54:33 - Checking authorization ...
! 2016.08.06 01:54:33 - Connecting to Sadalbari (Canada, Toronto, Ontario)
. 2016.08.06 01:54:33 - OpenVPN > OpenVPN 2.3.11 x86_64-apple-darwin15.5.0 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on May 19 2016
. 2016.08.06 01:54:33 - OpenVPN > library versions: OpenSSL 1.0.2h  3 May 2016, LZO 2.09
. 2016.08.06 01:55:03 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known
. 2016.08.06 01:55:03 - OpenVPN > Exiting due to fatal error
! 2016.08.06 01:55:03 - Disconnecting
. 2016.08.06 01:55:03 - Connection terminated.
 



#2 juancarlos101

juancarlos101

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 06 August 2016 - 02:02 PM

I also tried Tunnenblick and I can connect perfectly. Why can I not connect with AirVpn client?



#3 zhang888

zhang888

    Donald Trump of IT/Security

  • Moderators
  • 2205 posts

Posted 06 August 2016 - 03:40 PM

RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known

 

Did you modify your hosts file?

You have to edit /etc/hosts and make sure that the first entry is:

127.0.0.1       localhost


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.


#4 juancarlos101

juancarlos101

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 06 August 2016 - 04:33 PM

Yes, it's there the first line. Like I said, Tunnelblick and Viscocity there is no problems. But I want to be able to have network

lock in case of a disconnection.

It seems to me that this is an issue with the client.



#5 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7333 posts

Posted 06 August 2016 - 07:05 PM   Best Answer

Yes, it's there the first line. Like I said, Tunnelblick and Viscocity there is no problems. But I want to be able to have network

lock in case of a disconnection.

It seems to me that this is an issue with the client.

 

Hello!

 

As you can see here:

. 2016.08.06 01:54:30 - OpenVPN > RESOLVE: Cannot resolve host address: localhost: nodename nor servname provided, or not known

 

the problem is in your system. A system MUST be able to resolve name "localhost".

 

You don't find this problem in Tunnelblick because it contacts OpenVPN management at 127.0.0.1, but Eddie approach is more correct. You might experience additional problems if you don't make your system capable to resolve localhost.

 

In El Capitan the hosts file is /private/etc/hosts

 

Quick guide to edit it: https://www.ihash.eu/2015/09/how-to-edit-hosts-file-in-mac-os-x-10-11-el-capitan/

 

Kind regards



#6 juancarlos101

juancarlos101

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 06 August 2016 - 07:48 PM

BINGO! 127.0.0.1 WAS in the hosts file but it was in correct.

Thanks a bunch for your help.







Similar Topics Collapse

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Sessions: 13957 - BW: 43671 Mbit/sYour IP: 54.81.254.212Guest Access.