Jump to content


Photo

So far, so Good

airvpn webrtc

  • Please log in to reply
5 replies to this topic

#1 vivekvp

vivekvp

    Advanced Member

  • Members2
  • PipPipPip
  • 56 posts

Posted 01 July 2016 - 07:03 PM

Hello,

This is my first VPN - so far so good.

 

The good - lots of servers!

The bad - sometimes have to log on more than once. (rare) - I get a connection, but no internet.  disconnect reconnect, I am usually good

 

I installed the TAP9 adapter, but still for browser that have webrtc that can't be disabled - Chrome.  My IP still comes through.

 

Is that just a browser issue?  Or can I do something about it.

 

I do not like that!!!!

 

Mr. V



#2 zhang888

zhang888

    Donald Trump of IT/Security

  • Moderators
  • 2219 posts

Posted 01 July 2016 - 08:12 PM

WebRTC can be disabled in Chrome using a 3d party extension.

Take a look at uBlock Origin, it is also a very functional lightweight ad-blocker:

 

https://github.com/gorhill/uBlock


Occasional moderator, sometimes BOFH. Opinions are my own, except when my wife disagrees.


#3 LZ1

LZ1

    It's nice to be nice to nice people

  • Moderators
  • 1950 posts

Posted 01 July 2016 - 08:31 PM

Hello !

 

If you take a look at the bottom of the page on ipleak.net there's a link to a Chrome extension that allows you to block WebRTC :)

You'd get the same leak in Firefox, until it gets plugged; also something you can see on ipleak.


Hi there, are you new to AirVPN? Many of your questions are already answered in this guide. Its Guides Section has guides on Linux/Torrenting/Blocked sites & many other topics too.
Moderators do not speak on behalf of AirVPN. Only the Official Staff account does. Please read the First Questions section in the link above for more details, thank you.
Did you make a guide or how-to for something? Then contact me to get it listed in my new user guide's Guides Section, so that the community can find it more easily.

Tired of Windows? Why Linux Is Better.

#4 go558a83nk

go558a83nk

    Advanced Member

  • Members2
  • PipPipPip
  • 1699 posts

Posted 01 July 2016 - 08:32 PM

and won't the network lock also help here?



#5 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7792 posts

Posted 02 July 2016 - 10:34 AM

and won't the network lock also help here?

 

Yes, and it is a much more general solution. Disabling WebRTC on a browser solves the issue on that browser only. Network Lock prevents traffic leak of any process binding to the "wrong" interface.

https://www.clodo.it/blog/an-alternative-approach-to-so-called-webrtc-leaks/

 

Kind regards



#6 vivekvp

vivekvp

    Advanced Member

  • Members2
  • PipPipPip
  • 56 posts

Posted 05 July 2016 - 01:44 AM

I found Edge and Firefox blocked it out of box.  Not sure I trust Edge.  Chromodo (Comodo browser) had an option to turn it off.  WebRTC - sinister....

 

 

and won't the network lock also help here?

Yes, and it is a much more general solution. Disabling WebRTC on a browser solves the issue on that browser only. Network Lock prevents traffic leak of any process binding to the "wrong" interface.

https://www.clodo.it/blog/an-alternative-approach-to-so-called-webrtc-leaks/

 

Kind regards

 

WebRTC can be disabled in Chrome using a 3d party extension.

Take a look at uBlock Origin, it is also a very functional lightweight ad-blocker:

 

https://github.com/gorhill/uBlock







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 13699 - BW: 49903 Mbit/sYour IP: 34.228.143.13Guest Access.