Jump to content


Photo

client remains stuck at checking authorization

linux eddie debian

  • Please log in to reply
10 replies to this topic

#1 coconuts

coconuts

    Member

  • Members
  • PipPip
  • 13 posts

Posted 11 May 2016 - 06:14 PM

hi, over the last two days i have had real difficulty using the airvpn client. it remains stuck on the checking authorization phase and does not progress. i have to keep killing the process and retrying it in order to get a secure connection.

 

anyone facing similar issues? any solutions?

 

thanks



#2 go558a83nk

go558a83nk

    Advanced Member

  • Members
  • PipPipPip
  • 1109 posts

Posted 11 May 2016 - 09:09 PM

does it try checking authorization several times?  I've seen in certain circumstances eddie trying several times for authorization and then moving on to connect.



#3 coconuts

coconuts

    Member

  • Members
  • PipPip
  • 13 posts

Posted 12 May 2016 - 03:59 PM

hi, yes it does, but it fails to connect. sometimes i can get to checking route, before it resets and starts the whole process again.



#4 go558a83nk

go558a83nk

    Advanced Member

  • Members
  • PipPipPip
  • 1109 posts

Posted 12 May 2016 - 08:34 PM

hi, yes it does, but it fails to connect. sometimes i can get to checking route, before it resets and starts the whole process again.

 

either open up a support ticket or be more detailed here.  paste eddie logs (in spoiler tags) and describe the situation that causes trouble.  Public wifi??



#5 coconuts

coconuts

    Member

  • Members
  • PipPip
  • 13 posts

Posted 17 May 2016 - 03:55 PM

here are the logs

 

I 2016.05.17 17:44:50 - AirVPN client version: 2.10.3 / x64
. 2016.05.17 17:44:50 - Reading options from /home/airvpn_linux_x64_portable/AirVPN.xml
. 2016.05.17 17:44:52 - Data Path: /home/airvpn_linux_x64_portable
. 2016.05.17 17:44:52 - App Path: /home/airvpn_linux_x64_portable
. 2016.05.17 17:44:52 - Executable Path: /home/airvpn_linux_x64_portable/airvpn
. 2016.05.17 17:44:52 - Command line arguments (0):
. 2016.05.17 17:44:52 - Updating systems & servers data ...
. 2016.05.17 17:44:52 - Operating System: Unix 4.5.0.1 - Linux 4.5.0--amd64 #1 SMP Debian 4.5.3-2
I 2016.05.17 17:44:53 - OpenVPN Driver - Found, /dev/net/tun
I 2016.05.17 17:44:53 - OpenVPN - Version: OpenVPN 2.3.8 (/home/airvpn_linux_x64_portable/openvpn)
I 2016.05.17 17:44:53 - SSH - Version: OpenSSH_7.2p2 Debian-5, OpenSSL 1.0.2h  3 May 2016 (/usr/bin/ssh)
I 2016.05.17 17:44:53 - SSL - Version: stunnel 5.06 (/home/airvpn_linux_x64_portable/stunnel)
! 2016.05.17 17:44:53 - Ready
I 2016.05.17 17:48:17 - Session starting.
W 2016.05.17 17:48:18 - Unable to understand if IPV6 is active.
I 2016.05.17 17:48:18 - Checking authorization ...
! 2016.05.17 17:48:18 - Connecting to Sheliak (Netherlands, Alblasserdam)
. 2016.05.17 17:48:18 - OpenVPN > OpenVPN 2.3.8 x86_64-unknown-linux-gnu [SSL (OpenSSL)] [LZO] [EPOLL] [MH] [IPv6] built on Aug 13 2015
. 2016.05.17 17:48:18 - OpenVPN > library versions: OpenSSL 1.0.2d 9 Jul 2015, LZO 2.08
. 2016.05.17 17:48:18 - OpenVPN > MANAGEMENT: TCP Socket listening on [AF_INET]127.0.0.1:3100
. 2016.05.17 17:48:18 - OpenVPN > Control Channel Authentication: tls-auth using INLINE static key file
. 2016.05.17 17:48:18 - OpenVPN > Outgoing Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
. 2016.05.17 17:48:18 - OpenVPN > Incoming Control Channel Authentication: Using 160 bit message hash 'SHA1' for HMAC authentication
. 2016.05.17 17:48:18 - OpenVPN > Socket Buffers: R=[212992->262144] S=[212992->262144]
. 2016.05.17 17:48:18 - OpenVPN > UDPv4 link local: [undef]
. 2016.05.17 17:48:18 - OpenVPN > UDPv4 link remote: [AF_INET]213.152.162.113:443
. 2016.05.17 17:48:18 - OpenVPN > TLS: Initial packet from [AF_INET]213.152.162.113:443, sid=bd69771a 973927ca
. 2016.05.17 17:48:18 - OpenVPN > VERIFY OK: depth=1, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=airvpn.org CA, emailAddress=info@airvpn.org
. 2016.05.17 17:48:18 - OpenVPN > Validating certificate key usage
. 2016.05.17 17:48:18 - OpenVPN > ++ Certificate has key usage  00a0, expects 00a0
. 2016.05.17 17:48:18 - OpenVPN > VERIFY KU OK
. 2016.05.17 17:48:18 - OpenVPN > Validating certificate extended key usage
. 2016.05.17 17:48:18 - OpenVPN > ++ Certificate has EKU (str) TLS Web Server Authentication, expects TLS Web Server Authentication
. 2016.05.17 17:48:18 - OpenVPN > VERIFY EKU OK
. 2016.05.17 17:48:18 - OpenVPN > VERIFY OK: depth=0, C=IT, ST=IT, L=Perugia, O=airvpn.org, CN=server, emailAddress=info@airvpn.org
. 2016.05.17 17:48:19 - OpenVPN > Data Channel Encrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
. 2016.05.17 17:48:19 - OpenVPN > Data Channel Encrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
. 2016.05.17 17:48:19 - OpenVPN > Data Channel Decrypt: Cipher 'AES-256-CBC' initialized with 256 bit key
. 2016.05.17 17:48:19 - OpenVPN > Data Channel Decrypt: Using 160 bit message hash 'SHA1' for HMAC authentication
. 2016.05.17 17:48:19 - OpenVPN > Control Channel: TLSv1.2, cipher TLSv1/SSLv3 DHE-RSA-AES256-GCM-SHA384, 4096 bit RSA
. 2016.05.17 17:48:19 - OpenVPN > [server] Peer Connection Initiated with [AF_INET]213.152.162.113:443
. 2016.05.17 17:48:22 - OpenVPN > SENT CONTROL [server]: 'PUSH_REQUEST' (status=1)
. 2016.05.17 17:48:22 - OpenVPN > PUSH: Received control message: 'PUSH_REPLY,redirect-gateway def1 bypass-dhcp,dhcp-option DNS 10.4.0.1,comp-lzo no,route-gateway 10.4.0.1,topology subnet,ping 10,ping-restart 60,ifconfig 10.4.43.86 255.255.0.0'
. 2016.05.17 17:48:22 - OpenVPN > OPTIONS IMPORT: timers and/or timeouts modified
. 2016.05.17 17:48:22 - OpenVPN > OPTIONS IMPORT: LZO parms modified
. 2016.05.17 17:48:22 - OpenVPN > OPTIONS IMPORT: --ifconfig/up options modified
. 2016.05.17 17:48:22 - OpenVPN > OPTIONS IMPORT: route options modified
. 2016.05.17 17:48:22 - OpenVPN > OPTIONS IMPORT: route-related options modified
. 2016.05.17 17:48:22 - OpenVPN > OPTIONS IMPORT: --ip-win32 and/or --dhcp-option options modified
. 2016.05.17 17:48:22 - OpenVPN > TUN/TAP device tun0 opened
. 2016.05.17 17:48:22 - OpenVPN > TUN/TAP TX queue length set to 100
. 2016.05.17 17:48:22 - OpenVPN > do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
. 2016.05.17 17:48:22 - OpenVPN > /sbin/ifconfig tun0 10.4.43.86 netmask 255.255.0.0 mtu 1500 broadcast 10.4.255.255
. 2016.05.17 17:48:27 - OpenVPN > /sbin/route add -net 213.152.162.113 netmask 255.255.255.255 gw 192.168.0.1
. 2016.05.17 17:48:27 - OpenVPN > /sbin/route add -net 0.0.0.0 netmask 128.0.0.0 gw 10.4.0.1
. 2016.05.17 17:48:27 - OpenVPN > /sbin/route add -net 128.0.0.0 netmask 128.0.0.0 gw 10.4.0.1
. 2016.05.17 17:48:27 - Starting Management Interface
. 2016.05.17 17:48:27 - OpenVPN > Initialization Sequence Completed
I 2016.05.17 17:48:27 - /etc/resolv.conf renamed to /etc/resolv.conf.airvpn as backup
I 2016.05.17 17:48:27 - DNS of the system updated to VPN DNS (Rename method: /etc/resolv.conf generated)
I 2016.05.17 17:48:27 - Flushing DNS
I 2016.05.17 17:48:27 - Checking route
W 2016.05.17 17:49:07 - The request timed out
! 2016.05.17 17:49:07 - Disconnecting
. 2016.05.17 17:49:07 - Management - Send 'signal SIGTERM'
. 2016.05.17 17:49:07 - OpenVPN > MANAGEMENT: CMD 'signal SIGTERM'
. 2016.05.17 17:49:07 - OpenVPN > SIGTERM received, sending exit notification to peer
. 2016.05.17 17:49:07 - OpenVpn Management > >INFO:OpenVPN Management Interface Version 1 -- type 'help' for more info
. 2016.05.17 17:49:07 - OpenVpn Management > SUCCESS: signal SIGTERM thrown
. 2016.05.17 17:49:12 - OpenVPN > /sbin/route del -net 213.152.162.113 netmask 255.255.255.255
. 2016.05.17 17:49:12 - OpenVPN > /sbin/route del -net 0.0.0.0 netmask 128.0.0.0
. 2016.05.17 17:49:12 - OpenVPN > /sbin/route del -net 128.0.0.0 netmask 128.0.0.0
. 2016.05.17 17:49:12 - OpenVPN > Closing TUN/TAP interface
. 2016.05.17 17:49:12 - OpenVPN > /sbin/ifconfig tun0 0.0.0.0
. 2016.05.17 17:49:12 - OpenVPN > SIGTERM[soft,exit-with-notification] received, process exiting
. 2016.05.17 17:49:12 - Connection terminated.
I 2016.05.17 17:49:12 - DNS of the system restored to original settings (Rename method)
I 2016.05.17 17:49:15 - Checking authorization ...

 



#6 EdensSpire

EdensSpire

    Advanced Member

  • Members
  • PipPipPip
  • 459 posts

Posted 17 May 2016 - 04:17 PM

here are the logs

 

Spoiler


 

 

I'm afraid your logs don't really show much of a reason why the authorization check is stuck, it may be that it tries to connect to the login server and is unable to get through I also noticed this 

I 2016.05.17 17:48:27 - Flushing DNS
I 2016.05.17 17:48:27 - Checking route
W 2016.05.17 17:49:07 - The request timed out
! 2016.05.17 17:49:07 - Disconnecting

So it may be related to the routing table since it times out when it is unable to get through to the server. Have you tried using the installed version instead of portable?



#7 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 6814 posts

Posted 17 May 2016 - 07:11 PM

@coconuts

 

. 2016.05.17 17:44:52 - Operating System: Unix 4.5.0.1 - Linux 4.5.0--amd64 #1 SMP Debian 4.5.3-2

 

What exact Debian distribution version are you running?

 

Kind regards



#8 coconuts

coconuts

    Member

  • Members
  • PipPip
  • 13 posts

Posted 18 May 2016 - 04:50 PM

EdensSpire, I cannot use the installable version as I do not have mono. All attempts at installing mono have failed.

 

@staff Kali Linux 2016.1



#9 heisenberg1977

heisenberg1977

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 25 June 2016 - 04:50 PM

I'm having the same issue with Kali Linux (Rolling) running in Virtualbox. @Coconuts did you ever make any progress at getting Eddie to connect? I've tried many different servers with the same result.



#10 heisenberg1977

heisenberg1977

    Newbie

  • Members
  • Pip
  • 9 posts

Posted 25 June 2016 - 04:57 PM

I've rolled back and rebuilt my Kali VM to no avail. I am able to login, but can't see anything under the servers tab.

 

I tried the same package (airvpn_linux_x64_portable.tar.gz) on a Linux MINT 17.3 VM in VirtualBox and it works without issue.

 

Has anybody had success installing the Eddie client under Kali Rolling?



#11 J0hnny5

J0hnny5

    Member

  • Members
  • PipPip
  • 26 posts

Posted 18 February 2017 - 09:52 AM

I had the same problem and seemed to be related to the version of Eddie. I can confirm with 100% certainty that the latest version available today, Version: 2.11.15, fixes this issue.

Download the package https://airvpn.org/linux/

select:    /Linux/64/Debian/GUI/

(assuming of course that your VM is 64bit Linux; not sure why you would have a 32bit Linux though, at least in a VM. Check with   uname -r  )

Save the file, which will look like:    eddie-ui_2.11.15_linux_x64_debian.deb

open terminal

cd Downloads

gdebi eddie-ui_2.11.15_linux_x64_debian.deb

(if the above step does not work, then install gdebi with "apt-get install gdebi" , minus the quotes)

reboot

 

(after reboot, the AirVPN logo will be in your Internet folder)







Similar Topics Collapse


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Users: 14748 - BW: 40388 Mbit/sYour IP: 107.22.102.16Guest Access.