Jump to content


Photo

stunnel: server is down?

stunnel

  • Please log in to reply
3 replies to this topic

#1 suomynonamai

suomynonamai

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 03 July 2014 - 04:33 PM

I installed stunnel (32-bit) on Windows 7 w/ SP1, 64-bit. OpenVPN client is also 64-bit.

 

For testing purposes, I used the Config Generator to produce the following two files

 

AirVPN_CA-Hoedus_SSL-443.ovpn

AirVPN_CA-Hoedus_SSL-443.ssl

 

which I moved to C:\Program Files\OpenVPN\config

 

In a command prompt window, I typed the following:

 

C:\Program Files\OpenVPN\config>stunnel "AirVPN_CA-Hoedus_SSL-443.ssl"

 

The following error message appeared:

[ ] No limit detected for the number of clients
[.] stunnel 5.02 on x86-pc-msvc-1500 platform
[.] Compiled/running with OpenSSL 1.0.1h-fips 5 Jun 2014
[.] Threading:WIN32 Sockets:SELECT,IPv6 SSL:ENGINE,OCSP,FIPS
[ ] errno: (*_errno())
[.] Reading configuration from file AirVPN_CA-Hoedus_SSL-443.ssl
[!] Cannot open configuration file
[.]  
[.] Syntax:
[.] stunnel [ [-install | -uninstall] [-quiet] [<filename>] ] | -help | -version | -sockets
[.]     <filename>  - use specified config file
[.]     -install    - install NT service
[.]     -uninstall  - uninstall NT service
[.]     -quiet      - don't display a message box on success
[.]     -help       - get config file help
[.]     -version    - display version and defaults
[.]     -sockets    - display default socket options

[!] Server is down
 

How do I fix the above problem?

 

Is stunnel attempting to use IPv6? (I always disable IPv6 on the advice of friends who say that IPv6 leaks DNS and other data packets)

 

 



#2 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7855 posts

Posted 03 July 2014 - 04:51 PM

Hello!

 

No, the problem is local, stunnel is not able to open AirVPN_CA-Hoedus_SSL-443.ssl file.

 

Check that it is really inside the current working directory and that access flags are correct. You are using a particular directory which needs administrator privileges to be accessed, so if stunnel is run from a command prompt without administrator privileges, all the files inside that directory can't be accessed by it.

 

Kind regards



#3 suomynonamai

suomynonamai

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 04 July 2014 - 01:56 AM

What does the "it" refer to? stunnel.exe?

 

Do you mean that I should copy stunnel.exe to C:\Program Files\OpenVPN\config\ ?

 

By default *.ovpn files are located in C:\Program Files\OpenVPN\config\

 

And what do you mean by "access flags"? What should the correct access flags be for C:\Program Files\OpenVPN\config\ ?

 

Check that it is really inside the current working directory and that access flags are correct.



#4 suomynonamai

suomynonamai

    Newbie

  • Members
  • Pip
  • 3 posts

Posted 04 July 2014 - 01:58 AM

Following your tip, I opened a command prompt with administrative privileges.

 

I received the same error message.

 

You are using a particular directory which needs administrator privileges to be accessed, so if stunnel is run from a command prompt without administrator privileges, all the files inside that directory can't be accessed by it.







Similar Topics Collapse


2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

Servers online. Online Sessions: 15365 - BW: 50924 Mbit/sYour IP: 52.201.27.211Guest Access.