Jump to content


Photo

Using AirVPN with Ubuntu Network Manager

linux ubuntu

  • This topic is locked This topic is locked
5 replies to this topic

#1 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 7000 posts

Posted 23 April 2014 - 12:37 PM

UPDATE 01-SEP-17

Due to multiple, critical  problems in network-manager-openvpn which after years have not been solved we recommend to NOT use it. Please understand that we will not provide support to network-manager-openvpn. In GNU/Linux we recommend that you run our free and open source software "Eddie" or OpenVPN directly

 

 

Warning: Ubuntu 14.04 has an issue on configuration files import. At 25/04/2014 there's still no fix. Bug Report

  • Go to Config Generator page, choose Linux and choose your preferred options.
  • Select Advanced Mode
  • Tick Separate certs/keys from .ovpn files

    ubuntu-network-manager-5.png

  • Click on any archive format. Save the downloaded archive file somewhere, say in ~/.airvpn. Extract it. Five files should be extracted. Try to make sure nobody but you can read the file user.key, because that one is secret.
  • Install the package named network-manager-openvpn-gnome, which is a plugin to NetworkManager handling OpenVPN connections. The install will automatically include all needed packages, like openvpn etc.
  • Click on NetworkManager icon in top-right bar, and choose Edit Connections...

    ubuntu-network-manager-1.png

  • Click Add, choose Import a saved VPN configuration, click Create... and choose a .ovpn file extracted from files generated by our Config Generator.

    ubuntu-network-manager-2.png

  • The imported information is displayed. Click Save... and close the NetworkManager Connections editor.

    ubuntu-network-manager-3.png

  • From now on, the imported connections are showed under VPN Connections menu. Click it to connect.

    ubuntu-network-manager-4.png



#2 VPNuserhello

VPNuserhello

    Newbie

  • New Members
  • Pip
  • 1 posts

Posted 28 April 2014 - 06:01 PM

You will have to manually enter the VPN in in 14.04.

Here's what I did to get it working:

First download and extract your keys and opvn file from airvpn. Remember where these are, probably in downloads.

Now go to network manager in the tray and choose vpn connections -> configure VPN.

A network connections window will open. Click Add, choose Open VPN in the dropdown, click create.

Name your connection whatever you want.

Now open your opvn file in gedit that you downloaded from Airvpn, it will have the gateway address in it and port number.

You will see next to the word remote will be the address that you will copy and paste into the Gateway field within your newly created OpenVPN connection.

Under Authentication, the type is Certificates (TLS).

User Certificate, CA Certificate and private key will be the files you downloaded from Airvpn. Click the folder icon next to the entry field and browse to their download location.

Now click the advanced button.

Under the general tab tick Use custom gateway port and change it to whatever is listed after the remote entry you typed earlier in the gateway field. Its in the opvn file that you opened in gedit. most likey 443

Tick Use LZO compression.

Now click the security tab, choose AES-256-CBC for the cipher.

Now click the TLS Authentication tab, tick Use additional TLS authentication. Under the key file entry browse to the dowloaded ta.key you downloaded from Airvpn.

Change Key direction to 1 and click OK.

Now click save.

Your entry should now be in the Network connections window under the VPN category. Click close.

Now choose the vpn connection in network manager and Voila you should connect.

Hope this helps someone else.



#3 sandrovaldavid

sandrovaldavid

    Newbie

  • Members
  • Pip
  • 7 posts

Posted 28 April 2014 - 06:42 PM

Another approach, open the package manager and type in vpn to the search bar. When it comes back, I tagged anything that said it would be useful to complete a vpn connection, in both network manager and otherwise, and supporting packages. Rebooted and got the usual import dialogue as an option in the pulldown menu. Not elegant, but it worked for me. If someone could nail down which missing package invokes the import menu, it would simplify all this but I do not know nor have time to chase it.



#4 choq

choq

    Member

  • Members
  • PipPip
  • 28 posts

Posted 07 May 2014 - 05:50 AM

Bug in config manager: ADVANCED MODE doesn' t work after selecting linux. Using chrome.

Firefox is ok. Maybe an add-on something.....



#5 choq

choq

    Member

  • Members
  • PipPip
  • 28 posts

Posted 07 May 2014 - 05:50 AM

-



#6 choq

choq

    Member

  • Members
  • PipPip
  • 28 posts

Posted 07 May 2014 - 05:51 AM

It was notscript for chrome blocking the interface.







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

Servers online. Online Sessions: 15322 - BW: 53433 Mbit/sYour IP: 54.160.245.121Guest Access.