Jump to content


Photo

Using AirVPN with Debian Network Manager (NOT RECOMMENDED)

linux debian

  • This topic is locked This topic is locked
2 replies to this topic

#1 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 6887 posts

Posted 21 April 2014 - 10:47 AM

21/04/2014: network-manager-openvpn runs OpenVPN so that OpenVPN does not check the server certificate.
Therefore we DO NOT RECOMMEND usage of network-manager for security reasons.
This issue is already fixed in newest version not yet available in Debian 7 Wheezy
  • Download your configuration file from the page Config Generator
  • Select "Advanced Mode"
  • Tick "Separate certs/keys from .ovpn files"
  • Save the downloaded zip-file somewhere, say in ~/.airvpn. Unzip it. Five files should be extracted. Try to make sure nobody but you can read the file user.key, because that one is secret.
  • Erase the zip-file. Or at least, make sure only you can read it (since it contains the secret user.key file inside)
  • Install the package named network-manager-openvpn-gnome, which is a plugin to NetworkManager handling OpenVPN connections. The install will automatically include all needed packages, like openvpn etc.
  • Perhaps you'll have to log out and log in again, or even restart the computer or something. To check that openvpn plugin was properly installed in NetworkManager, click on the nm-applet (the NetworkManager icon) => VPN Connections => Configure VPN. In the little window that comes up, click the Add button. Is there an OpenVPN option in the menu? Good. But don't click on it. Just close the windows. This was just a check.
  • Click on the nm-applet (the NetworkManager icon) => VPN Connections => Configure VPN
  • In the little window that comes up, click the Import button.
  • In the file chooser that comes up, find the previously downloaded file air.ovpn (perhaps you stored it in the ~/.airvpn directory?)
  • A new little window comes up. It is pre-filled with the necessary airvpn-configuration stuff.
  • Click the NetworkManager applet. Under VPN-connections, you should now be able to select the VPN-connection named air. After a little while, the applet icon should be decorated with a little padlock.
For any comment or feedback, you can find the discussion here.
Thanks to HugeHedon for this article.

#2 dwright

dwright

    Advanced Member

  • Members
  • PipPipPip
  • 77 posts

Posted 23 May 2014 - 12:46 PM

I'm considering switching to Debian, and I was just wondering, does the warning still apply or is it now "fixed"?

 

What is the best way of connecting to Air in Debian if not this, and what are the risks of using the not recommended method?



#3 Staff

Staff

    Advanced Member

  • Staff
  • PipPipPip
  • 6887 posts

Posted 23 May 2014 - 06:22 PM

Hello,

 

in Debian 7, Eddie 2.1beta works very well. Otherwise run OpenVPN directly.

 

Kind regards







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Servers online. Online Users: 13940 - BW: 39165 Mbit/sYour IP: 54.162.255.186Guest Access.